aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRene Peinthor2019-01-04 19:03:01 +0100
committerRene Peinthor2019-01-04 19:03:01 +0100
commit57871e69ce41ac58f43288a27a54d77da7ed873e (patch)
tree279a2b7ab5007bdf90503451588b0b7ed113f3bb
downloadaur-57871e69ce41ac58f43288a27a54d77da7ed873e.tar.gz
initial package version
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD40
-rw-r--r--README.md5
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6893f5a94433
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = brother-dcpl3550cdw
+ pkgdesc = CUPS driver for Brother DCP-L3550CDW
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://support.brother.com/g/b/producttop.aspx?c=eu_ot&lang=en&prod=dcpl3550cdw_eu
+ arch = x86_64
+ license = unknown
+ source = http://download.brother.com/welcome/dlf103938/dcpl3550cdwpdrv-1.0.2-0.i386.rpm
+ md5sums = 155eed84f5cbd7f406582d83c1c5c2d3
+
+pkgname = brother-dcpl3550cdw
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cef2199b822a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dede0b993085
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Cameron Eagans <me@cweagans.net>
+# Based on brother-hll2370dn package from AUR.
+
+pkgname="brother-dcpl3550cdw"
+pkgver="1.0.2"
+pkgrel=1
+pkgdesc="CUPS driver for Brother DCP-L3550CDW"
+arch=('x86_64')
+url="https://support.brother.com/g/b/producttop.aspx?c=eu_ot&lang=en&prod=dcpl3550cdw_eu"
+license=('unknown')
+_model="dcpl3550cdw"
+_revision=0
+
+#https://download.brother.com/welcome/dlf103938/dcpl3550cdwpdrv-1.0.2-0.i386.rpm
+source=("http://download.brother.com/welcome/dlf103938/${_model,,}pdrv-${pkgver}-${_revision}.i386.rpm")
+md5sums=("155eed84f5cbd7f406582d83c1c5c2d3")
+
+package() {
+ # Using /usr/share instead of /opt
+ mkdir -p "$pkgdir/usr/share"
+ cp -R "$srcdir/opt/brother" "$pkgdir/usr/share"
+ sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/${_model}/cupswrapper/brother_lpdwrapper_${_model}"
+ sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/${_model}/lpd/filter_${_model}"
+
+ # symlink for lpdwrapper so it correctly figures out the printer model from the path
+ install -d "$pkgdir/usr/lib/cups/filter/"
+ ln -s "/usr/share/brother/Printers/${_model}/cupswrapper/brother_lpdwrapper_${_model}" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_${_model}"
+
+ # symlink for the PPD
+ install -d "$pkgdir/usr/share/cups/model/"
+ ln -s "/usr/share/brother/Printers/${_model}/cupswrapper/brother_${_model}_printer_en.ppd" "$pkgdir/usr/share/cups/model/"
+
+ # a couple architecture-specific symlinks
+ #ln -s "/usr/share/brother/Printers/${_model}/lpd/$CARCH/brprintconflsr3" "$pkgdir/usr/share/brother/Printers/${_model}/lpd/"
+ #ln -s "/usr/share/brother/Printers/${_model}/lpd/$CARCH/rawtobr3" "$pkgdir/usr/share/brother/Printers/${_model}/lpd/"
+
+ # symlink for inf because it tries to execute it there
+ ln -s "/usr/share/brother/Printers/${_model}/inf" "$pkgdir/usr/share/brother/Printers/${_model}/lpd/"
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..3833c158a8d9
--- /dev/null
+++ b/README.md
@@ -0,0 +1,5 @@
+# brother-dcpl3550cdw
+
+This is mostly working based on the PKGBUILD from brother-dcpl2550dw.
+
+If you're using your DCP-L3550CDW as a network printer, you need to manually add the printer as an LPD printer. In GNOME, I have to enter the IP for the printer for that option to show up.