summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMykola Bespaliuk2016-04-21 10:34:08 -0400
committerMykola Bespaliuk2016-04-21 10:34:08 -0400
commitac61853bec24de4b72eea3c7f4c7e16bdcfb129e (patch)
tree94f9befbb8912753a1446d9c521e8858e3e66a07
downloadaur-brother-hll2300d.tar.gz
created BKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad698df83657
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = brother-hll2300d
+ pkgdesc = Brother HL-L2300D CUPS driver
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://www.brother.com
+ arch = x86_64
+ arch = i686
+ license = custom:Brother
+ depends = perl
+ depends = bash
+ depends = lib32-glibc
+ source = http://download.brother.com/welcome/dlf101899/hll2300dcupswrapper-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101898/hll2300dlpr-3.2.0-1.i386.rpm
+ md5sums = 788bb36490f3615c47ad601a261e5f54
+ md5sums = 86f88229cd00833a3ad4620207aa3829
+
+pkgname = brother-hll2300d
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c2aae3f3d75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mykola Bespaliuk (kolkabes [at] gmail [dot] com)
+pkgname=brother-hll2300d
+pkgver=3.2.0_1
+pkgrel=1
+pkgdesc="Brother HL-L2300D CUPS driver"
+url="http://www.brother.com"
+arch=('x86_64' 'i686')
+depends=('perl' 'bash')
+license=('custom:Brother')
+source=(
+ http://download.brother.com/welcome/dlf101899/hll2300dcupswrapper-${pkgver//_/-}.i386.rpm
+ http://download.brother.com/welcome/dlf101898/hll2300dlpr-${pkgver//_/-}.i386.rpm
+)
+md5sums=(
+ '788bb36490f3615c47ad601a261e5f54'
+ '86f88229cd00833a3ad4620207aa3829'
+)
+
+if [[ "$CARCH" == "x86_64" ]]; then
+ depends+=('lib32-glibc')
+fi
+
+package() {
+ mkdir -p "${pkgdir}/opt"
+ cp -R "${srcdir}/opt/brother" "${pkgdir}/opt/brother"
+
+ mkdir -p "${pkgdir}/usr/lib/cups/filter"
+ echo "#! /opt/brother/Printers/HLL2300D/cupswrapper/brother_lpdwrapper_HLL2300D" > "${srcdir}/filter-shim"
+ install -m 0755 -o root -g root "${srcdir}/filter-shim" "${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_HLL2300D"
+
+ mkdir -p "${pkgdir}/usr/share/ppd/cupsfilters"
+ install -m 0644 -o root -g root "${srcdir}/opt/brother/Printers/HLL2300D/cupswrapper/brother-HLL2300D-cups-en.ppd" "${pkgdir}/usr/share/ppd/cupsfilters"
+} \ No newline at end of file