summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Cafe2018-10-08 16:21:13 -0300
committerDaniel Cafe2018-10-08 16:21:13 -0300
commit1e0fe45f8d17bc200792e7a7c6edce883d367c08 (patch)
tree93efaaef00de0c81ff30a202a6c6848b05dd6d5b
downloadaur-brother-hll6402dw.tar.gz
Initial commit of Brother HL-L6402DW printer driver
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD68
-rw-r--r--brother-hll6402dw.patch22
3 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08b0743d1137
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = brother-hll6402dw
+ pkgdesc = Brother HL-L6402DW CUPS driver
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://brother.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cups
+ source = http://download.brother.com/welcome/dlf102572/hll6402dwcupswrapper-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf102571/hll6402dwlpr-3.2.0-1.i386.rpm
+ source = brother-hll6402dw.patch
+ md5sums = 21826a4bf266256afe4e81f83a6ab15c
+ md5sums = 61a40f6ff2a5d2f03875a270e8d18bd5
+ md5sums = 1d5900258fec40a29588d0700dd2a742
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-hll6402dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..719b7c874ccb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Daniel Cafe
+
+model="hll6402dw"
+MODEL="HLL6402DW"
+
+pkgname="brother-${model}"
+pkgver="3.2.0_1"
+pkgrel=1
+pkgdesc="Brother HL-L6402DW CUPS driver"
+
+url="http://brother.com"
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('cups')
+depends_x86_64=('lib32-glibc')
+
+source=("http://download.brother.com/welcome/dlf102572/${model}cupswrapper-3.2.0-1.i386.rpm"
+ "http://download.brother.com/welcome/dlf102571/${model}lpr-3.2.0-1.i386.rpm"
+ "brother-${model}.patch")
+
+md5sums=('21826a4bf266256afe4e81f83a6ab15c'
+ '61a40f6ff2a5d2f03875a270e8d18bd5'
+ '1d5900258fec40a29588d0700dd2a742')
+
+prepare() {
+ patch -p1 < brother-${model}.patch
+}
+
+package() {
+ cp -a "$srcdir/var" "$pkgdir"
+
+ install -Dm644 \
+ "$srcdir/opt/brother/Printers/${MODEL}/cupswrapper/brother-${MODEL}-cups-en.ppd" \
+ "$pkgdir/usr/share/cups/model/brother-${MODEL}-cups-en.ppd"
+
+ install -Dm755 \
+ "$srcdir/opt/brother/Printers/${MODEL}/cupswrapper/brother_lpdwrapper_${MODEL}" \
+ "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_${MODEL}"
+
+ install -Dm755 \
+ "$srcdir/opt/brother/Printers/${MODEL}/cupswrapper/paperconfigml1" \
+ "$pkgdir/usr/share/Brother/Printer/${MODEL}/cupswrapper/paperconfigml1"
+
+ install -Dm644 \
+ "$srcdir/opt/brother/Printers/${MODEL}/inf/br${MODEL}func" \
+ "$pkgdir/usr/share/Brother/Printer/${MODEL}/inf/br${MODEL}func"
+
+ install -Dm644 \
+ "$srcdir/opt/brother/Printers/${MODEL}/inf/br${MODEL}rc" \
+ "$pkgdir/usr/share/Brother/Printer/${MODEL}/inf/br${MODEL}rc"
+
+ install -Dm755 \
+ "$srcdir/opt/brother/Printers/${MODEL}/inf/setupPrintcap" \
+ "$pkgdir/usr/share/Brother/Printer/${MODEL}/inf/setupPrintcap"
+
+ install -Dm755 \
+ "$srcdir/opt/brother/Printers/${MODEL}/lpd/brprintconflsr3" \
+ "$pkgdir/usr/share/Brother/Printer/${MODEL}/lpd/brprintconflsr3"
+
+ install -Dm755 \
+ "$srcdir/opt/brother/Printers/${MODEL}/lpd/filter_${MODEL}" \
+ "$pkgdir/usr/share/Brother/Printer/${MODEL}/lpd/filter_${MODEL}"
+
+ install -Dm755 \
+ "$srcdir/opt/brother/Printers/${MODEL}/lpd/rawtobr3" \
+ "$pkgdir/usr/share/Brother/Printer/${MODEL}/lpd/rawtobr3"
+}
diff --git a/brother-hll6402dw.patch b/brother-hll6402dw.patch
new file mode 100644
index 000000000000..4efcd79faa99
--- /dev/null
+++ b/brother-hll6402dw.patch
@@ -0,0 +1,22 @@
+diff --git a/opt/brother/Printers/HLL6402DW/cupswrapper/brother_lpdwrapper_HLL6402DW b/opt/brother/Printers/HLL6402DW/cupswrapper/brother_lpdwrapper_HLL6402DW
+index 8281c15..01acb5d 100755
+--- a/opt/brother/Printers/HLL6402DW/cupswrapper/brother_lpdwrapper_HLL6402DW
++++ b/opt/brother/Printers/HLL6402DW/cupswrapper/brother_lpdwrapper_HLL6402DW
+@@ -53 +53,3 @@ chomp($basedir);
+-$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
++#$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
++my $PRINTER = "HLL6402DW";
++my $basedir = "/usr/share/Brother/Printer/$PRINTER";
+@@ -85 +87 @@ my $PPD = $ENV{PPD};
+-my $PRINTER=$basedir;
++#my $PRINTER=$basedir;
+@@ -92,3 +94,3 @@ if ( @ARGV >= 6 ){
+-$PRINTER =~ s/^\/opt\/.*\/Printers\///g;
+-$PRINTER =~ s/\/cupswrapper//g;
+-$PRINTER =~ s/\///g;
++#$PRINTER =~ s/^\/opt\/.*\/Printers\///g;
++#$PRINTER =~ s/\/cupswrapper//g;
++#$PRINTER =~ s/\///g;
+@@ -807 +809 @@ sub exec_lpdconfig {
+- $lpddir = $basedir."/lpd/";
++ $lpddir = $basedir."/lpd";