summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Singer2016-10-23 15:57:08 +0200
committerRoland Singer2016-10-23 15:57:08 +0200
commit117ea24527f66a26118659620f4657ad873078b5 (patch)
tree7303321a07a897e51dc54405d4128ac4e2ef4769
downloadaur-brother-mfc6490cw-cupswrapper.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
-rw-r--r--brother-mfc6490cw-cupswrapper.install5
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20814a8deeba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = brother-mfc6490cw-cupswrapper
+ pkgdesc = LPR-to-CUPS wrapper for Brother MFC-6490CW multifunction network printer
+ pkgver = 1.1.2_2
+ pkgrel = 5
+ url = http://solutions.brother.com/linux/en_us/download_prn.html#MFC-6490CW
+ install = brother-mfc6490cw-cupswrapper.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cups
+ depends = ghostscript
+ depends = brother-mfc6490cw-lpr>=1.1.2_2
+ source = http://download.brother.com/welcome/dlf006182/mfc6490cwcupswrapper-1.1.2-2.i386.deb
+ md5sums = 8c0c560d2fd9b7a019f26968c47e8a0a
+
+pkgname = brother-mfc6490cw-cupswrapper
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b51e4ce87852
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Mark Doe <mark.doe.priv@gmail.com>
+# Contributor: Benjamin Bukowski <crankidiot(at)gmail.com>
+
+_printer=mfc6490cw
+pkgname=brother-${_printer}-cupswrapper
+pkgver=1.1.2_2
+_version="${pkgver//_/-}"
+pkgrel=5
+pkgdesc="LPR-to-CUPS wrapper for Brother MFC-6490CW multifunction network printer"
+arch=('i686' 'x86_64')
+url='http://solutions.brother.com/linux/en_us/download_prn.html#MFC-6490CW'
+license=('GPL')
+depends=('cups' 'ghostscript' "brother-${_printer}-lpr>=${pkgver}")
+install="$pkgname.install"
+
+source=("http://download.brother.com/welcome/dlf006182/${_printer}cupswrapper-${_version}.i386.deb")
+md5sums=('8c0c560d2fd9b7a019f26968c47e8a0a')
+
+package() {
+ cd $srcdir
+
+ ar x ${_printer}cupswrapper-${_version}.i386.deb || return 1
+ [ ! -d "data" ] && mkdir data
+ tar -xzvf data.tar.gz -C data || return 1
+
+ [ ! -d "data/usr/share" ] && mkdir data/usr/share
+ mv data/usr/local/Brother data/usr/share/brother
+ rm -r data/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' data/` || return 1
+ sed -i 's|/etc/init.d|/etc/rc.d|' `grep -lr '/etc/init.d' data/` || return 1
+
+ cp -r data/usr $pkgdir || return 1
+}
diff --git a/brother-mfc6490cw-cupswrapper.install b/brother-mfc6490cw-cupswrapper.install
new file mode 100644
index 000000000000..c4075a965af7
--- /dev/null
+++ b/brother-mfc6490cw-cupswrapper.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "Running cupswrappermfc6490cw install script..."
+ /usr/share/brother/Printer/mfc6490cw/cupswrapper/cupswrappermfc6490cw
+ /bin/true
+}