summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreygjhart2017-05-28 10:05:07 +0200
committerGreygjhart2017-05-28 10:06:42 +0200
commit9b9d7296f58a7e011823ca93e6364255e891b407 (patch)
treece2eb08527d8508a621494f3135a12684e848743
downloadaur-brother-mfcj6720dw-lpr.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78326a5ed371
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = brother-mfcj6720dw-lpr
+ pkgdesc = LPR driver for Brother MFC-j6720DW multifunction network printer
+ pkgver = 3.0.0_1
+ pkgrel = 3
+ url = http://support.brother.com/g/b/downloadtop.aspx?c=us&lang=en&prod=mfcj6720dw_us_eu_as
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = tcsh
+ source = http://download.brother.com/welcome/dlf100964/mfcj6720dwlpr-3.0.0-1.i386.deb
+ md5sums = 61b86b329944c1ed117a41bc9b1accb6
+
+pkgname = brother-mfcj6720dw-lpr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b2e845ab133
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Mark Doe <mark.doe.priv@gmail.com>
+# Contributor: Benjamin Bukowski <crankidiot(at)gmail.com>
+
+_printer=mfcj6720dw
+pkgname=brother-${_printer}-lpr
+pkgver=3.0.0_1
+_version=${pkgver//_/-}
+pkgrel=3
+pkgdesc="LPR driver for Brother MFC-j6720DW multifunction network printer"
+arch=('i686' 'x86_64')
+url="http://support.brother.com/g/b/downloadtop.aspx?c=us&lang=en&prod=mfcj6720dw_us_eu_as"
+license=('GPL')
+depends=('tcsh')
+source=("http://download.brother.com/welcome/dlf100964/${_printer}lpr-${_version}.i386.deb")
+md5sums=('61b86b329944c1ed117a41bc9b1accb6')
+
+package() {
+ cd $srcdir
+
+ ar x ${_printer}lpr-${_version}.i386.deb || return 1
+ [ ! -d "data" ] && mkdir data
+ tar -xzvf data.tar.gz -C data || return 1
+
+ [ ! -d "data/usr/share" ] && mkdir data/usr/share
+ mv data/opt/brother data/usr/share/brother
+ rm -r data/opt
+ sed -i 's|/opt/brother|/usr/share/brother|g' `grep -lr '/opt/brother' data/` || return 1
+
+ cp -r data/usr $pkgdir || return 1
+}