summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Delgado2021-01-13 20:04:15 -0500
committerDylan Delgado2021-01-13 20:04:15 -0500
commit84699c0f962c4fde6f2328195a6eb86213b59e92 (patch)
treee2fd6ccf494286ad4764c9ca9f2e4f79f2afa9d3
downloadaur-84699c0f962c4fde6f2328195a6eb86213b59e92.tar.gz
Initial commit, based on version 0.9.1.2
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD38
-rw-r--r--cmake.patch20
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a95a8367c2c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = browservice
+ pkgdesc = Browse the modern web on historical browsers
+ pkgver = 0.9.1.2
+ pkgrel = 1
+ url = https://github.com/ttalvitie/browservice
+ arch = x86_64
+ arch = armv7l
+ arch = aarch64
+ license = MIT
+ depends = wget
+ depends = cmake
+ depends = poco
+ depends = pango
+ depends = libjpeg-turbo
+ depends = libxcb
+ depends = libx11
+ depends = python
+ depends = xorg-server-xvfb
+ depends = xorg-xauth
+ depends = at-spi2-atk
+ depends = alsa-lib
+ depends = nss
+ depends = libcups
+ depends = libxcursor
+ depends = libxss
+ depends = libxcomposite
+ depends = libxkbcommon
+ depends = ttf-ms-fonts
+ source = https://github.com/ttalvitie/browservice/archive/v0.9.1.2.tar.gz
+ source = cmake.patch
+ sha256sums = 4936efb4389605d96e358cd61a6a689b13c3b3b137ce7e79f3c96cfc290d3d92
+ sha256sums = 9a89293e55961adadca26829e2a97f06286b19b554032917cccbf1bd0bd53700
+
+pkgname = browservice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3d6f3538ad6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+#Maintainer: Dylan Delgado <dylan1496@live.com>
+
+pkgname=browservice
+pkgver=0.9.1.2
+pkgrel=1
+pkgdesc='Browse the modern web on historical browsers'
+url='https://github.com/ttalvitie/browservice'
+license=('MIT')
+arch=('x86_64' 'armv7l' 'aarch64')
+depends=('wget' 'cmake' 'poco' 'pango' 'libjpeg-turbo' 'libxcb' 'libx11' 'python' 'xorg-server-xvfb' 'xorg-xauth' 'at-spi2-atk' 'alsa-lib' 'nss' 'libcups' 'libxcursor' 'libxss' 'libxcomposite' 'libxkbcommon' 'ttf-ms-fonts')
+source=("https://github.com/ttalvitie/browservice/archive/v${pkgver}.tar.gz"
+'cmake.patch')
+sha256sums=('4936efb4389605d96e358cd61a6a689b13c3b3b137ce7e79f3c96cfc290d3d92'
+'9a89293e55961adadca26829e2a97f06286b19b554032917cccbf1bd0bd53700')
+
+prepare() {
+cd "${srcdir}/${pkgname}-${pkgver}"
+patch --strip=1 < ../cmake.patch
+}
+
+build() {
+cd "${srcdir}/${pkgname}-${pkgver}"
+./download_cef.sh
+./setup_cef.sh
+make -j
+}
+
+package() {
+cd "${srcdir}/${pkgname}-${pkgver}"
+install -Dm755 release/bin/chrome-sandbox "${pkgdir}/usr/bin/chrome-sandbox"
+install -Dm755 release/bin/browservice "${pkgdir}/usr/bin/browservice"
+install -Dm755 cef/Release/libcef.so "${pkgdir}/usr/lib/libcef.so"
+install -Dm755 release/bin/icudtl.dat "${pkgdir}/usr/lib/icudtl.dat"
+install -Dm755 release/bin/cef.pak "${pkgdir}/usr/lib/cef.pak"
+install -Dm755 release/bin/cef_100_percent.pak "${pkgdir}/usr/lib/cef_100_percent.pak"
+install -Dm755 release/bin/cef_200_percent.pak "${pkgdir}/usr/lib/cef_200_percent.pak"
+install -Dm755 release/bin/cef_extensions.pak "${pkgdir}/usr/lib/cef_extensions.pak"
+} \ No newline at end of file
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 000000000000..03af4e018872
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,20 @@
+diff --unified --recursive --text browservice-0.9.1.2/setup_cef.sh browservice-patch/setup_cef.sh
+--- browservice-0.9.1.2/setup_cef.sh 2020-11-21 05:38:52.000000000 -0500
++++ browservice-patch/setup_cef.sh 2021-01-13 16:55:27.846282188 -0500
+@@ -18,13 +18,13 @@
+
+ if [ "$ARCH" == "x86_64" ] || [[ "$ARCH" =~ ^i[3-7]86$ ]]
+ then
+- CMAKEFLAGS=""
++ CMAKEFLAGS="-DCEF_COMPILER_FLAGS=-Wno-error=cpp"
+ elif [ "$ARCH" == "armv7l" ]
+ then
+- CMAKEFLAGS="-DPROJECT_ARCH=arm"
++ CMAKEFLAGS="-DPROJECT_ARCH=arm -DCEF_COMPILER_FLAGS=-Wno-error=cpp"
+ elif [ "$ARCH" == "aarch64" ]
+ then
+- CMAKEFLAGS="-DPROJECT_ARCH=arm64"
++ CMAKEFLAGS="-DPROJECT_ARCH=arm64 -DCEF_COMPILER_FLAGS=-Wno-error=cpp"
+ else
+ echo "Unsupported architecture"
+ exit 1