summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikuro Kagamine2019-06-18 22:22:44 +1000
committerMikuro Kagamine2019-06-18 22:22:44 +1000
commit174e7e12aab22272585577a4da053179624960f5 (patch)
tree428661d3fd825c9c38487bb0bb7ea8491252bd94
parent7ab325d05b30e39a1d9d9717ed0ac83975e115c2 (diff)
downloadaur-174e7e12aab22272585577a4da053179624960f5.tar.gz
1.5.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a9514be2c2b..cf4f273d641e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = browsh
pkgdesc = A fully-modern text-based browser, rendering to TTY and browsers
- pkgver = 1.5.0
+ pkgver = 1.5.2
pkgrel = 1
url = https://www.brow.sh
arch = x86_64
@@ -14,16 +14,16 @@ pkgbase = browsh
makedepends = go-bindata
makedepends = dep
makedepends = git
- depends = firefox>=57
+ depends = firefox>=63
optdepends = upx: compress binary
conflicts = browsh-bin
conflicts = browsh-git
- noextract = browsh-1.5.0-an.fx.xpi
+ noextract = browsh-1.5.2-an.fx.xpi
options = !strip
- source = https://github.com/browsh-org/browsh/archive/v1.5.0.tar.gz
- source = https://github.com/browsh-org/browsh/releases/download/v1.5.0/browsh-1.5.0-an.fx.xpi
- sha512sums = 1ba4ac0e5d217201d626f62a7dd91dc6364e81b1ba633221d23b21f231334e8d241dfa9827d8dc064502838a6bfc1232b915678120eb3dd6ad99c75c5d51fe39
- sha512sums = 1e8efff581313c73e993c74a24cfe577b2694abdf259ca647d6fa88d4bf7930e6f3641444f5178f3c5166a8a32930a0f75cdb780a0fcb4581bdea0ecbb8c942c
+ source = https://github.com/browsh-org/browsh/archive/v1.5.2.tar.gz
+ source = https://github.com/browsh-org/browsh/releases/download/v1.5.2/browsh-1.5.2-an.fx.xpi
+ sha256sums = c1a39b8982caa3cf96d67ff4e8b2d6fd80746a8f3ddd13f0650cbc875ca7b8fd
+ sha256sums = c3b475953de61a930c12c89cde3d2630e511b28ddbd21da7830e02173df32a2d
pkgname = browsh
diff --git a/PKGBUILD b/PKGBUILD
index eaea7c64d0f2..61695a2ca107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Mikuro Kagamine <mikurok@forgecrushing.com>
pkgname=browsh
-pkgver=1.5.0
+pkgver=1.5.2
pkgrel=1
pkgdesc='A fully-modern text-based browser, rendering to TTY and browsers'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='https://www.brow.sh'
license=('LGPL2.1')
-depends=('firefox>=57')
+depends=('firefox>=63')
makedepends=('go' 'go-bindata' 'dep' 'git')
optdepends=('upx: compress binary')
conflicts=('browsh-bin' 'browsh-git')
@@ -15,6 +15,9 @@ options=('!strip')
noextract=("${pkgname}-${pkgver}-an.fx.xpi")
source=("https://github.com/${pkgname}-org/${pkgname}/archive/v${pkgver}.tar.gz"
"https://github.com/${pkgname}-org/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}-an.fx.xpi")
+sha256sums=('c1a39b8982caa3cf96d67ff4e8b2d6fd80746a8f3ddd13f0650cbc875ca7b8fd'
+ 'c3b475953de61a930c12c89cde3d2630e511b28ddbd21da7830e02173df32a2d')
+
prepare() {
## Go is fussy.
@@ -54,11 +57,9 @@ build() {
strip --strip-all "${srcdir}/${pkgname}"
if [ $(which upx 2>/dev/null) ]; then
echo Compressing ${pkgname} with UPX...
- upx --best "${srcdir}/${pkgname}"; fi
+ upx "${srcdir}/${pkgname}"; fi
}
package() {
install -Dm755 $pkgname "${pkgdir}/usr/bin/${pkgname}"
}
-sha512sums=('1ba4ac0e5d217201d626f62a7dd91dc6364e81b1ba633221d23b21f231334e8d241dfa9827d8dc064502838a6bfc1232b915678120eb3dd6ad99c75c5d51fe39'
- '1e8efff581313c73e993c74a24cfe577b2694abdf259ca647d6fa88d4bf7930e6f3641444f5178f3c5166a8a32930a0f75cdb780a0fcb4581bdea0ecbb8c942c')