summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2015-08-05 00:27:44 +0200
committerPeter Mattern2015-08-05 00:27:44 +0200
commit3261f903d1880649092fda617781c5f5549da858 (patch)
treee6021b9e344ec901039931e43b24811ea5ccf13a
downloadaur-brscan2.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
-rw-r--r--brother-eula.txt58
-rw-r--r--brscan2.install21
4 files changed, 145 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44bb21ace0c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = brscan2
+ pkgdesc = SANE driver from Brother for brscan2 models
+ pkgver = 0.2.5_1
+ pkgrel = 1
+ url = http://support.brother.com
+ install = brscan2.install
+ arch = i686
+ arch = x86_64
+ license = custom:Brother
+ license = GPL
+ depends = libusb-compat
+ depends = sane
+ source_i686 = http://download.brother.com/welcome/dlf006639/brscan2-0.2.5-1.i386.rpm
+ sha256sums_i686 = f9c12f8467288c48cd00b532b2c64f53764a001f4b193f1c5f1ac746a1bd7c9c
+ source_x86_64 = http://download.brother.com/welcome/dlf006640/brscan2-0.2.5-1.x86_64.rpm
+ sha256sums_x86_64 = ab02c4e2292e9847a0338a225973735ccaec49c3d443f584004c8f91f5d6a8c9
+
+pkgname = brscan2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6600bc82a904
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+# Contributor: libernux <dutchman55 at gmx dot com>
+# Contributor: Olaf Leidinger <leidola at newcon dot de>
+# Contributor: Hervé Cauwelier <herve at oursours dot net>
+# Contributor: Marc Straube <dev at marcstraube dot de>
+
+pkgname=brscan2
+pkgver=0.2.5_1
+pkgrel=1
+pkgdesc="SANE driver from Brother for $pkgname models"
+arch=("i686" "x86_64")
+url="http://support.brother.com"
+license=("custom:Brother" "GPL")
+depends=("libusb-compat" "sane")
+install=brscan2.install
+source_i686=("http://download.brother.com/welcome/dlf006639/$pkgname-${pkgver/_/-}.i386.rpm")
+sha256sums_i686=("f9c12f8467288c48cd00b532b2c64f53764a001f4b193f1c5f1ac746a1bd7c9c")
+source_x86_64=("http://download.brother.com/welcome/dlf006640/$pkgname-${pkgver/_/-}.x86_64.rpm")
+sha256sums_x86_64=("ab02c4e2292e9847a0338a225973735ccaec49c3d443f584004c8f91f5d6a8c9")
+
+prepare() {
+
+ # adjust use of lib64 to habits on Arch Linux x86_64
+
+ if [ "$CARCH" == x86_64 ] ; then
+
+ # path
+ mv usr/lib64 usr/lib
+
+ # symbolic links
+ cd usr/lib
+ ln -sf /usr/lib/libbrcolm2.so.1 libbrcolm2.so
+ ln -sf /usr/lib/libbrcolm2.so.1.0.1 libbrcolm2.so.1
+ ln -sf /usr/lib/libbrscandec2.so.1 libbrscandec2.so
+ ln -sf /usr/lib/libbrscandec2.so.1.0.0 libbrscandec2.so.1
+ cd sane
+ ln -sf /usr/lib/sane/libsane-brother2.so.1 libsane-brother2.so
+ ln -sf /usr/lib/sane/libsane-brother2.so.1.0.7 libsane-brother2.so.1
+
+ fi
+}
+
+package() {
+ cp -a usr $pkgdir
+ install -D -m644 $startdir/brother-eula.txt \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/brother-eula.txt b/brother-eula.txt
new file mode 100644
index 000000000000..2bc5524e507c
--- /dev/null
+++ b/brother-eula.txt
@@ -0,0 +1,58 @@
+This Agreement provides terms and conditions for license grant for use of the software
+that is distributed with this Agreement ("Software") from Brother Industries, Ltd.
+("Brother") to recipients thereof ("You").
+
+1. The Software is comprised of the following software modules:
+
+ i. Certain software modules that is the subject of GNU GENERAL PUBLIC LICENSE
+ ("GPL Modules"),
+ and
+ ii. Other software modules ("Non-GPL Modules")
+
+ You may distinguish each of GPL Modules by downloading source files of the Software as
+ Brother separately makes available and reading such files.
+
+2. Your use of all GPL Modules shall be subject to the terms and conditions of GNU GENERAL
+ PUBLIC LICENSE Version 2, June 1991 ("GPLv2"). Please see
+ http://support.brother.com/g/s/agreement/English_gpl/agree.html. You shall use GPL Modules
+ in accordance with the terms and conditions of GPLv2. Your use of GPL Modules shall be
+ deemed as your agreement to the terms and conditions of GPLv2.
+
+3. You have the right to use all Non-GPL Modules only in accordance with the following terms
+ and conditions.
+ Your use of Non-GPL Modules shall be deemed as your agreement to the following terms and
+ conditions:
+
+ i. Brother retains any and all copyrights to Non-GPL Modules. In no case this Agreement
+ shall be construed to assign or otherwise transfer from Brother to you any copyrights
+ or other intellectual property rights to whole or any part of Non-GPL Modules.
+
+ ii. Brother grants you a non-exclusive license to reproduce and/or distribute (via Internet
+ or in any other manner) Non-GPL Modules. Brother further grants you a non-exclusive
+ license to modify, alter, translate or otherwise prepare derivative works of Non-GPL
+ Modules and to reproduce and/or distribute (via Internet or in any other manner) such
+ modification, alteration, translation or other derivative works of Non-GPL Modules.
+
+ iii. When you distribute (via Internet or in any other manner) Non-GPL Modules or any
+ modification, alteration, translation or other derivative works thereof under the license
+ granted in accordance with subparagraph 3(ii) above, you must expressly grant any and
+ all recipient thereof the license equivalent to this Agreement which applies to Non-GPL
+ Modules.
+
+ iv. The license of Non-GPL Modules from Brother hereunder is granted "AS IS. BROTHER HEREBY
+ DISCLAIMS ANY WARRANTIES WITH RESPECT TO NON-GPL MODULES, EXPRESS OR IMPLIED, INCLUDING
+ BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR
+ PURPOSE OR NON-INFRINGEMENT.
+
+ v. To the extent allowed by applicable laws, Brother shall have no liability in contract,
+ tort (including negligence or breach of statutory duty) or otherwise for any interruption
+ of use, loss of data, or for any indirect, incidental, punitive or consequential loss or
+ damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that
+ arises under, out of, or in contemplation of this Agreement or otherwise arises due to
+ any error, inaccuracy or defect in Non-GPL Modules even if Brother has been advised of the
+ possibility of such loss or damage.
+
+ vi. The form in which Non-GPL Modules is distributed is subject to Brother's sole discretion.
+ Brother does not have any obligation to distribute or disclose Non-GPL Modules in source
+ code form. In no case shall this Agreement be deemed as Brother's express or implied
+ agreement to disclose source code of Non-GPL Modules.
diff --git a/brscan2.install b/brscan2.install
new file mode 100644
index 000000000000..1d35d1d35787
--- /dev/null
+++ b/brscan2.install
@@ -0,0 +1,21 @@
+post_install() {
+ grep brother2 /etc/sane.d/dll.conf >/dev/null 2>&1
+ if [ $? != 0 ] ; then
+ echo 'brother2' >> /etc/sane.d/dll.conf
+ else
+ echo ''
+ echo 'Note: SANE backend "brother2" was already registered in /etc/sane.d/dll.conf'
+ echo ''
+ fi
+}
+
+post_remove() {
+ grep brother2 /etc/sane.d/dll.conf >/dev/null 2>&1
+ if [ $? = 0 ] ; then
+ sed -i '/^brother2$/d' /etc/sane.d/dll.conf
+ else
+ echo ''
+ echo 'Note: SANE backend "brother2" was already removed from /etc/sane.d/dll.conf'
+ echo ''
+ fi
+}