summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkejpies2021-10-19 20:55:05 +0200
committerkejpies2021-10-19 20:55:05 +0200
commit6b837820ca7a89e0b4c6a249a4237f067172bccd (patch)
tree296946c8617ec0cedc48dc88202d2d0123d48a4a
parent9fce585d50ba6be048ac7628627f90120e542a8f (diff)
downloadaur-6b837820ca7a89e0b4c6a249a4237f067172bccd.tar.gz
Un-bruhing bruh
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88b28f045c96..c5287184bd80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = bruh
- pkgdesc = Bruh sound, but as a program. You can use it to make your software more fun.
+ pkgdesc = bruh sound, but as a program
pkgver = 2.0
pkgrel = 1
- arch = i686
+ url = https://github.com/kejpies/bruh
arch = x86_64
- license = GPL
- makedepends = make
- makedepends = coreutils
- makedepends = gcc
- optdepends = pulseaudio
+ license = GPL3
depends = alsa-utils
- provides = bruh
- source = git+https://github.com/kejpies/bruh
- md5sums = SKIP
+ optdepends = pulseaudio: ALSA alternative
+ source = bruh-2.0.tar.gz::https://github.com/kejpies/bruh/archive/2.0.tar.gz
+ sha256sums = 3fc159835ee7baac6776bbf946e711bbd0337abd6d7b1a8ad97ca9513ea8e1d4
+ sha256sums = ecafd2f2d0698deb90c7192a71c83645eb03ca64a4b06a24dc79c93a75fd6d8a
pkgname = bruh
-
diff --git a/PKGBUILD b/PKGBUILD
index 0ee27383537e..a0af39dd2d60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
# Maintainer: Konrad SekuĊ‚a <konradsekula@outlook.com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=bruh
pkgver=2.0
pkgrel=1
-pkgdesc="Bruh sound, but as a program. You can use it to make your software more fun."
-arch=('i686' 'x86_64')
-license=('GPL')
+pkgdesc="bruh sound, but as a program"
+arch=('x86_64')
+license=('GPL3')
+url='https://github.com/kejpies/bruh'
depends=("alsa-utils")
-makedepends=("make" "coreutils" "gcc")
-optdepends=("pulseaudio: for pa support if you don't like ALSA")
-source=("git+https://github.com/kejpies/bruh")
-provides=("bruh")
-pkgver(){
- cd "$srcdir/$pkgname"
- cat ver
-}
+optdepends=("pulseaudio: ALSA alternative")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('3fc159835ee7baac6776bbf946e711bbd0337abd6d7b1a8ad97ca9513ea8e1d4'
+ 'ecafd2f2d0698deb90c7192a71c83645eb03ca64a4b06a24dc79c93a75fd6d8a')
build() {
- cd "$srcdir/$pkgname"
- make
+ cd "$pkgname-$pkgver"
+ make
}
+
package() {
- cd "$srcdir/$pkgname"
-
- install -Dm 755 -o root bruh $pkgdir"/usr/bin/bruh"
- install -Dm 644 -o root bruh.wav $pkgdir"/usr/share/bruh/bruh.wav"
- install -Dm 644 -o root bruh.1.gz $pkgdir"/usr/share/man/man1/bruh.1.gz"
+ cd "$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}
-
-md5sums=(SKIP)