summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-08 04:46:30 +0300
committerDimitris Kiziridis2020-07-08 04:46:30 +0300
commitae0bc960733e65e8ac6d56b9ae0aa6eea48a9353 (patch)
tree8e3734f02ac953e92db303ce47778285e8a3783e
downloadaur-btnx-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..debb75a6776e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = btnx-git
+ pkgdesc = A daemon that enables rerouting of mouse button events through uinput as keyboard and other mouse button combinations
+ pkgver = r23.ef3f5b9
+ pkgrel = 1
+ url = https://github.com/cdobrich/btnx
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = btnx-config
+ depends = libdaemon
+ depends = bash
+ provides = btnx
+ source = btnx::git+https://github.com/cdobrich/btnx
+ sha256sums = SKIP
+
+pkgname = btnx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a49f1fe61434
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=btnx-git
+_pkgname=btnx
+pkgver=r23.ef3f5b9
+pkgrel=1
+pkgdesc="A daemon that enables rerouting of mouse button events through uinput as keyboard and other mouse button combinations"
+arch=('x86_64')
+url='https://github.com/cdobrich/btnx'
+license=('GPL2')
+provides=('btnx')
+depends=('btnx-config'
+ 'libdaemon'
+ 'bash')
+makedepends=('git')
+source=("btnx::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd btnx
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd btnx
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd btnx
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file