summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-01-17 18:37:55 +0100
committerwillemw122023-01-17 18:37:55 +0100
commitecb14458a834a19b769f9b8a908e08d6468c3ebd (patch)
tree32d687b5f240e9ef689d135498387fc7861211fa
parent039194137013f70ad54ae89c162e1bcc1a4a9f54 (diff)
downloadaur-ecb14458a834a19b769f9b8a908e08d6468c3ebd.tar.gz
Add conflicts. Fix source name. ...
Change description, optdepends description. Change url from http to https. Remove BINDIR="/usr/bin" from make install. Remove options=('!makeflags').
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8aed37828734..b65cc42ecfce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = btrbk-git
- pkgdesc = A backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to your backup locations.
- pkgver = 0.32.2.r0.gbdc1f5c
+ pkgdesc = Backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to your backup locations
+ pkgver = 0.32.5.r28.ga75765c
pkgrel = 1
- url = http://digint.ch/btrbk
+ url = https://digint.ch/btrbk/
arch = any
license = GPL3
makedepends = asciidoctor
makedepends = git
- depends = perl
depends = btrfs-progs
- optdepends = openssh: remote backup support,
- optdepends = mbuffer: --progress support and add buffering to send-stream
- optdepends = sudo: support for the btrfs-progs-sudo backend
+ depends = perl
+ optdepends = mbuffer: send/receive buffering and rate limiting, progress bars
+ optdepends = openssh: transfer backups from/to remote locations,
+ optdepends = sudo: btrfs-progs-sudo backend
provides = btrbk
- options = !makeflags
- source = git+https://github.com/digint/btrbk.git
+ conflicts = btrbk
+ source = btrbk-git::git+https://github.com/digint/btrbk.git
sha256sums = SKIP
pkgname = btrbk-git
diff --git a/PKGBUILD b/PKGBUILD
index b8026176af19..e8919bd08861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,29 @@
-# Maintainer: Michael Duell < mail at akurei dot me >
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Michael Duell < mail at akurei dot me >
# Contributor: Daniel J. Campos <dcampos2015 at my dot fit dot edu>
+
pkgname=btrbk-git
-pkgver=0.32.2.r0.gbdc1f5c
+pkgver=0.32.5.r28.ga75765c
pkgrel=1
-pkgdesc="A backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to your backup locations."
-url="http://digint.ch/btrbk"
+pkgdesc="Backup tool for btrfs subvolumes, taking advantage of btrfs specific capabilities to create atomic snapshots and transfer them incrementally to your backup locations"
arch=('any')
+url="https://digint.ch/btrbk/"
license=('GPL3')
-provides=('btrbk')
-depends=('perl' 'btrfs-progs')
+depends=('btrfs-progs' 'perl')
makedepends=('asciidoctor' 'git')
-options=('!makeflags') # temporary fix for https://github.com/digint/btrbk/pull/341
-optdepends=('openssh: remote backup support',
- 'mbuffer: --progress support and add buffering to send-stream'
- 'sudo: support for the btrfs-progs-sudo backend')
-source=("git+https://github.com/digint/btrbk.git")
+optdepends=('mbuffer: send/receive buffering and rate limiting, progress bars'
+ 'openssh: transfer backups from/to remote locations',
+ 'sudo: btrfs-progs-sudo backend')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+https://github.com/digint/btrbk.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/btrbk"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C $pkgname describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-
package() {
- cd "${srcdir}/btrbk"
- make DESTDIR="${pkgdir}" BINDIR="/usr/bin" install
- #install -Dm644 COPYING "$pkgdir/usr/share/licenses/btrbk/COPYING"
+ make -C $pkgname DESTDIR="$pkgdir/" install
}
-