summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Schulte2018-04-30 17:00:26 -0700
committerEric Schulte2018-04-30 21:36:45 -0700
commit410e6a76811d96b11d988490b0f9f64782dee4e1 (patch)
tree0b34014e11a4acd6998936c3e731ae8d65d12ee0
downloadaur-bugzoo-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD46
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2459d36493ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bugzoo-git
+ pkgdesc = Keep your bugs contained. A platform for studying historical software bugs.
+ pkgver = r1.77d0bd1
+ pkgrel = 1
+ url = https://squareslab.github.io/BugZoo
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ depends = docker
+ depends = python-numpy
+ depends = python-flask
+ depends = python-tabulate
+ depends = python-gitpython
+ depends = python-dockerpty
+ provides = bugzoo-git
+ conflicts = bugzoo-git
+
+pkgname = bugzoo-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6c5134b8b9e6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..450a07109023
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Eric Schulte <eschulte@grammatech.com>
+pkgname=bugzoo-git
+pkgver=r1.77d0bd1
+pkgrel=1
+pkgdesc="Keep your bugs contained. A platform for studying historical software bugs."
+arch=('any')
+url="https://squareslab.github.io/BugZoo"
+license=('MIT')
+groups=()
+depends=('python' 'docker' 'python-numpy' 'python-flask'
+ 'python-tabulate' 'python-gitpython' 'python-dockerpty')
+makedepends=('git' 'python' 'python-setuptools')
+provides=('bugzoo-git')
+conflicts=('bugzoo-git')
+backup=()
+options=()
+install=
+noextract=()
+source=()
+md5sums=()
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# This is necessary instead of specifying the git url in the SOURCE
+# array because we need to pass the depth flag to git.
+prepare() {
+ if [ -d bugzoo ];then
+ cd bugzoo
+ git pull
+ else
+ git clone https://github.com/squareslab/bugzoo.git --depth 1
+ fi
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}