aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2016-08-31 06:14:13 -1000
committerGaetan Bisson2016-08-31 06:14:13 -1000
commit8854039c39f6ca3bb8234530ff13ad67e98536c9 (patch)
tree7d79f41e99d14e5fd434d8dd9fe50c2a6d82c9f9
parenta93a550811640baa599bff46b09bb1560093d814 (diff)
downloadaur-8854039c39f6ca3bb8234530ff13ad67e98536c9.tar.gz
in stop_vm after upgrade /tmp/$vport does not exist
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xarch.build2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13cd155c4e75..6e4fd14017b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = buildstuff
pkgdesc = Stuff to build packages in virtual machines
pkgver = 0.9
- pkgrel = 2
+ pkgrel = 3
url = http://arch.vesath.org/
arch = any
license = custom:ISC
@@ -18,7 +18,7 @@ pkgbase = buildstuff
sha1sums = 9065a73d67c5c021ae9d0624b973ca93053ee1dc
sha1sums = 6ecd04bec1630ddd9ceb947e330b9624c3fa8d64
sha1sums = 853f64797cdd0a57e7049f594340db20bd4e1eba
- sha1sums = 8020a4dab3a02bebe933550a675741262e799ad9
+ sha1sums = b30c0e4ba2c5628b210593d5e2d348ce1c84c6f1
sha1sums = 39d491e77bb573ef17d3a41dc149735c2c107b6c
pkgname = buildstuff
diff --git a/PKGBUILD b/PKGBUILD
index cdb3658d1784..3be005669b1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=buildstuff
pkgver=0.9
-pkgrel=2
+pkgrel=3
pkgdesc='Stuff to build packages in virtual machines'
url='http://arch.vesath.org/'
arch=('any')
@@ -28,5 +28,5 @@ package() {
sha1sums=('9065a73d67c5c021ae9d0624b973ca93053ee1dc'
'6ecd04bec1630ddd9ceb947e330b9624c3fa8d64'
'853f64797cdd0a57e7049f594340db20bd4e1eba'
- '8020a4dab3a02bebe933550a675741262e799ad9'
+ 'b30c0e4ba2c5628b210593d5e2d348ce1c84c6f1'
'39d491e77bb573ef17d3a41dc149735c2c107b6c')
diff --git a/arch.build b/arch.build
index 773386c13949..03f654329ba3 100755
--- a/arch.build
+++ b/arch.build
@@ -37,7 +37,7 @@ start_vm() {
stop_vm() {
ssh $vhost 'sudo poweroff' || true
wait
- rm /tmp/$vport
+ rm -f /tmp/$vport
}
trap_err() {