summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyush Agarwal2021-09-05 19:45:19 +0530
committerAyush Agarwal2021-09-05 19:45:19 +0530
commitdd560e1a3bb1dc1d7dcc89c633096baa61992f30 (patch)
tree00dd0f5cc22c95e221d92d46c5417941eb35370c
parent15dd2c508ce850c7cfe798b34ffc145cbddbaf87 (diff)
downloadaur-dd560e1a3bb1dc1d7dcc89c633096baa61992f30.tar.gz
revive the buku package and update it to v4.6
The buku package had apparently been deleted back in January 2021 from the AUR. Since I use this package, I'm reviving it. https://lists.archlinux.org/pipermail/aur-requests/2021-January/048339.html
-rw-r--r--.SRCINFO28
-rw-r--r--[-rwxr-xr-x]PKGBUILD54
2 files changed, 52 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5250323f6dce..b1b63ee20b07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = buku
- pkgdesc = Powerful command-line bookmark manager. CLI only.
- pkgver = 4.3
+ pkgdesc = Bookmark manager like a text-based mini-web
+ pkgver = 4.6
pkgrel = 1
- url = https://github.com/jarun/Buku
- arch = any
- license = GPL3
- makedepends = make
+ url = https://github.com/jarun/buku
+ arch = x86_64
+ license = GPL
+ makedepends = python-setuptools
depends = python
- depends = python-beautifulsoup4
- depends = python-cryptography
- depends = python-urllib3
depends = python-certifi
+ depends = python-urllib3
+ depends = python-cryptography
+ depends = python-beautifulsoup4
depends = python-html5lib
- source = buku-4.3.tar.gz::https://codeload.github.com/jarun/Buku/tar.gz/v4.3
- sha256sums = 4c91cb0ac83164153c65705f46af29aaede78a2ed48d836cd2269b0fc71fed7a
+ optdepends = wl-clipboard: to copy text in wayland
+ optdepends = wl-clipboard-rs: to copy text in wayland
+ optdepends = xsel: to copy text in xorg
+ optdepends = xclip: to copy text in xorg
+ conflicts = buku-git
+ source = buku-4.6.tar.gz::https://github.com/jarun/buku/archive/refs/tags/v4.6.tar.gz
+ sha256sums = 2e1968016d3856184db8ac49cdc92a6c70869f62846185f28c8c60ead0c42888
pkgname = buku
-
diff --git a/PKGBUILD b/PKGBUILD
index a8b7a41eb494..8ad557e97850 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,42 @@
-# Maintainer: Ben Oliver <ben@bfoliver.com>
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
-# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
-# Maintainer: Julian Paul Dasmarinas <julian.dasma@gmail.com>
+# Maintainer: Ayush Agarwal <ayush at fastmail dot in>
+# Contributor: Ben Oliver <ben at bfoliver dot com>
+# Contributor: Andy Weidenbaum <archbaum at gmail dot com>
+# Contributor: John Jenkins <twodopeshaggy at gmail dot com>
+# Contributor: Julian Paul Dasmarinas <julian.dasma at gmail dot com>
pkgname=buku
-pkgver=4.3
+pkgver=4.6
pkgrel=1
-pkgdesc="Powerful command-line bookmark manager. CLI only."
-arch=('any')
-depends=('python' 'python-beautifulsoup4' 'python-cryptography' 'python-urllib3' 'python-certifi' 'python-html5lib')
-makedepends=('make')
-url="https://github.com/jarun/Buku"
-license=('GPL3')
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/jarun/Buku/tar.gz/v$pkgver)
-sha256sums=('4c91cb0ac83164153c65705f46af29aaede78a2ed48d836cd2269b0fc71fed7a')
+pkgdesc="Bookmark manager like a text-based mini-web"
+arch=(x86_64)
+url="https://github.com/jarun/buku"
+license=('GPL')
+depends=('python'
+ 'python-certifi'
+ 'python-urllib3'
+ 'python-cryptography'
+ 'python-beautifulsoup4'
+ 'python-html5lib')
+makedepends=('python-setuptools')
+optdepends=('wl-clipboard: to copy text in wayland'
+ 'wl-clipboard-rs: to copy text in wayland'
+ 'xsel: to copy text in xorg'
+ 'xclip: to copy text in xorg')
+conflicts=('buku-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jarun/buku/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('2e1968016d3856184db8ac49cdc92a6c70869f62846185f28c8c60ead0c42888')
package() {
- cd "$srcdir/buku-$pkgver"
- make DESTDIR="${pkgdir}" PREFIX=/usr install
- install -Dm644 auto-completion/fish/buku.fish "${pkgdir}/usr/share/fish/vendor_completions.d/buku.fish"
- install -Dm644 auto-completion/bash/buku-completion.bash "${pkgdir}/etc/bash_completion.d/buku"
- install -Dm644 auto-completion/zsh/_buku "${pkgdir}/usr/share/zsh/site-functions/_buku"
+ cd "$pkgname-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+
+ rm -f "$pkgdir"/usr/bin/bukuserver
+ rm -rf "$pkgdir"/usr/lib/python3.9/site-packages/bukuserver
+ gzip -f buku.1
+
+ install -Dm644 auto-completion/fish/buku.fish "${pkgdir}/usr/share/fish/vendor_completions.d/buku.fish"
+ install -Dm644 auto-completion/bash/buku-completion.bash "${pkgdir}/usr/share/bash-completion/completions/buku"
+ install -Dm644 auto-completion/zsh/_buku "${pkgdir}/usr/share/zsh/site-functions/_buku"
+ install -Dm644 buku.1.gz "${pkgdir}/usr/share/man/man1/buku.1.gz"
}