summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-06 17:43:37 -0600
committerLuis Martinez2022-02-06 17:43:37 -0600
commit7a433afba022691ebe25a8a61ac24d2302566b8c (patch)
tree73057e639506db70f0cb18cadbb94dbad8f76f47
downloadaur-bunnyfetch.tar.gz
initial commit based on bunnyfetch-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5956be869fa8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bunnyfetch
+ pkgdesc = Tiny system info fetch utility.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/rosettea/bunnyfetch
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ depends = glibc
+ source = bunnyfetch::git+https://github.com/rosettea/bunnyfetch#commit=4acf55b?signed
+ validpgpkeys = 784DF7A14968C5094E16839C904FC49417B44DCD
+ sha256sums = SKIP
+
+pkgname = bunnyfetch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdd8effa8d40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Devin Singh <drsingh2518@icloud.com>
+
+pkgname=bunnyfetch
+pkgver=0.2.0
+pkgrel=1
+_commit=4acf55b
+pkgdesc="Tiny system info fetch utility."
+arch=('x86_64' 'i686' 'aarch64')
+license=('MIT')
+url="https://github.com/rosettea/bunnyfetch"
+depends=('glibc')
+makedepends=('go' 'git')
+source=("$pkgname::git+$url#commit=$_commit?signed")
+sha256sums=('SKIP')
+validpgpkeys=('784DF7A14968C5094E16839C904FC49417B44DCD') ## TorchedSammy
+
+prepare() {
+ cd "$pkgname"
+ mkdir -p build
+ go mod download
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname"
+ go build -o build
+}
+
+check() {
+ cd "$pkgname"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname"
+ install -D "build/$pkgname" -t "$pkgdir/usr/bin/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
+