summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-01-24 00:45:32 +0000
committerJoão Figueiredo2021-01-24 00:45:32 +0000
commit63b986dba766ba0ea1d3fd64b57bf4e153e19bb2 (patch)
tree7c26c251f9de821b172f13d9c63d054d310c2e0b
parenta37396c8ea2b8c463f51e2182f5993f112938671 (diff)
downloadaur-bup.tar.gz
Update to 0.32
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
-rw-r--r--changelog.md85
-rw-r--r--python.patch10
4 files changed, 40 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5408a2a8eb1b..bd46d0f338e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bup
pkgdesc = Efficient backup system based on the git packfile format
- pkgver = 0.31
- pkgrel = 3
+ pkgver = 0.32
+ pkgrel = 1
url = https://bup.github.io/
changelog = changelog.md
arch = x86_64
@@ -16,12 +16,8 @@ pkgbase = bup
depends = git
optdepends = python-tornado: for bup web
conflicts = bup-git
- source = bup-0.31.tar.gz::https://github.com/bup/bup/archive/0.31.tar.gz
- source = argv.patch::https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54.patch
- source = python.patch
- sha256sums = 2f54351aed653b4b9567d3a534af598a5bc63b32efd7cc593bcecac3b89e16d1
- sha256sums = 09b639aad2cd7e71c76b80011d566a9fad82e748eabf795fcdf2ec0ec3c28315
- sha256sums = 24e2bc085f9b778cd8f553342436bf7174fd3983c0e34ce7ba84b2012dfa4062
+ source = bup-0.32.tar.gz::https://github.com/bup/bup/archive/0.32.tar.gz
+ sha256sums = a894cfa96c44b9ef48003b2c2104dc5fa6361dd2f4d519261a93178984a51259
pkgname = bup
diff --git a/PKGBUILD b/PKGBUILD
index fb54c5c6dd4d..9fed09940774 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
# Contributor: SanskritFritz (gmail)
pkgname=bup
-pkgver=0.31
-pkgrel=3
+pkgver=0.32
+pkgrel=1
pkgdesc='Efficient backup system based on the git packfile format'
arch=('x86_64')
url='https://bup.github.io/'
@@ -20,24 +20,10 @@ optdepends=('python-tornado: for bup web')
makedepends=('pandoc')
#checkdepends=('rsync' 'python-tornado')
conflicts=('bup-git')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bup/bup/archive/${pkgver}.tar.gz"
- "argv.patch::https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54.patch"
- "python.patch")
-sha256sums=('2f54351aed653b4b9567d3a534af598a5bc63b32efd7cc593bcecac3b89e16d1'
- '09b639aad2cd7e71c76b80011d566a9fad82e748eabf795fcdf2ec0ec3c28315'
- '24e2bc085f9b778cd8f553342436bf7174fd3983c0e34ce7ba84b2012dfa4062')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bup/bup/archive/${pkgver}.tar.gz")
+sha256sums=('a894cfa96c44b9ef48003b2c2104dc5fa6361dd2f4d519261a93178984a51259')
changelog=changelog.md
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 < ../argv.patch
- # Backport this commit for python 3.9 compiling support:
- # https://github.com/bup/bup/commit/3a2a997771a1af6722059f15589fc15866d4bc54
-
- patch -p1 < ../python.patch
- # Always choose python3 over other versions
-}
-
build() {
cd "$pkgname-$pkgver"
./configure
diff --git a/changelog.md b/changelog.md
index 588fca5051ab..f4cad895df19 100644
--- a/changelog.md
+++ b/changelog.md
@@ -1,77 +1,56 @@
-Notable changes in 0.31 (since 0.30.1)
-======================================
+Notable changes in 0.32 since 0.31)
+===================================
-* Python 3 is now supported, and Python 2 support is deprecated. It's
+* Python 3 is now preferred. Python 2 support is deprecated, and it's
possible that we'll stop new development for Python 2 fairly soon.
If so, we'll probably continue to fix bugs in the last Python 2
compatible version for a while, but please make plans to migrate.
-* `bup features` has been added. It reports information about bup
- itself, including the Python version, and the current availability
- of features like readline or support for POSIX ACLs.
+ At the moment, ./configure doesn't explicitly look for any python
+ newer than python3.8 by default (though one might be selected by the
+ eventual python3 fallback). If desired, you can explicitly select a
+ version like this:
-May require attention
----------------------
+ PYTHON=python3.9 ./configure
-* bup now relies on libacl directly instead of python-pylibacl, which
- will require installing the relevant packages (e.g. libacl1-dev)
- before building.
+* With Python 3.9, the command line reported in tools like `ps` and
+ `top` will be `python...` rather than `bup...`. This was caused by
+ an upstream change that appears to have been reverted. We're likely
+ to avoid the issue entirely in a future relese.
-* bup now relies on libreadline directly instead of python's built-in
- support, which will require installing the relevant packages
- (e.g. libreadline-dev) before building.
-
-* `bup version --tag` has been removed. It was actually a synonym for
- `bup version`, which still works fine. The fact that the version
- may have a corresponding git tag is no longer relevant to the
- command.
+Bugs
+----
-* `git describe` style strings will no longer appear in the `bup
- version` for non-release builds. The version in that case will
- currently just be formatted as `PENDING_RELEASE~HASH`, where `~` has
- the [Debian semantics](https://www.debian.org/doc/debian-policy/ch-controlfields.html#version),
- for example, 0.31~5ac3821c0f1fbd6a1b1742e91ffd556cd1116041). This
- is part of the fix for the issue with varying `git archive` content
- mentioned below.
+* A number of Python 3 compatibility problems have been fixed.
-General
--------
+* `bup web` should no longer crash when attempting to listen on IPV6
+ interfaces.
-* `bup fsck` should now avoid displaying `par2` errors when testing it
- for parallel processing support.
+* `bup restore -vv` should no longer crash when printing paths with
+ Python 3.
-* The documentation for the hashsplit algorithm in DESIGN has been
- updated to reflect quirks of the implementation, which didn't quite
- match the original specification.
+* `bup --prune-older --pretend` should format the plus/minus lines
+ correctly now.
-Bugs
-----
+* The `TTY_WIDTH` should now be correctly propagated to subprocesses
+ and remotes..
-* When running `bup on` with a remote ssh `ForceCommand`, bup should
- now respect that setting when running sub-commands.
+* Errors encountered while writing packfiles should be handled more
+ carefully.
-* It should no longer be possible for the content of archives generated
- by `git archive` (including releases retrieved from github) to vary
- based on the current set of repository refs (tags, branches, etc.).
- Previously archives generated from the same tag could differ
- slightly in content.
+* Some issues with the handling of integral type signs and sizes on
+ the C side have been fixed.
Build and install
-----------------
-* `bup` itself is now located in now located in the cmd/ directory in
- the install tree and finds sub-commands, etc. relative to its own
- location.
-
-* The metadata tests should no longer fail on systems with SELinux
- enabled.
+* The tests are now handled by pytest. See the
+ [README](../README#getting-started) for the additional dependency
+ information and further instructions.
Thanks to (at least)
====================
-Aaron M. Ucko, Aidan Hobson Sayers, Alexander Barton, Brian Minton,
-Christian Cornelssen, Eric Waguespack, Gernot Schulz, Greg Troxel,
-Hartmut Krafft, Johannes Berg, Luca Carlon, Mark J Hewitt, Ralf
-Hemmecke, Reinier Maas, Rob Browning, Robert Edmonds, Wyatt Alt, Zev
-Eisenberg, gkonstandinos, and kd7spq
+Christian Brabandt, Greg Troxel, Gustavo Goretkin, Jean-Paul Marmorat,
+Johannes Berg, Karl-Philipp Richter, Rob Browning, and danpawlikZ
diff --git a/python.patch b/python.patch
deleted file mode 100644
index 13dc292cfa3b..000000000000
--- a/python.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/config/configure 2020-08-22 18:12:01.000000000 +0100
-+++ b/config/configure 2020-12-25 17:32:45.230892240 +0000
-@@ -66,6 +66,7 @@
- AC_SUB bup_make "$MAKE"
-
- bup_python="$(type -p "$PYTHON")"
-+test -z "$bup_python" && bup_python="$(bup_find_prog python3 '')"
- test -z "$bup_python" && bup_python="$(bup_find_prog python2.7 '')"
- test -z "$bup_python" && bup_python="$(bup_find_prog python2.6 '')"
- test -z "$bup_python" && bup_python="$(bup_find_prog python2 '')"