summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Cherny2018-04-23 15:54:50 +0300
committerEugene Cherny2018-04-23 15:54:50 +0300
commita25726926197800f1dc93c7fbb45ee61d04f6c9e (patch)
treeaade7e0639d7ccf7ad360cc7daaeba3dc0c6888a
parentcba9f8854339f11804f860e81c7b561c8621adf2 (diff)
downloadaur-a25726926197800f1dc93c7fbb45ee61d04f6c9e.tar.gz
[+] proper distribution with fixed cabbage paths
-rw-r--r--Cabbage.desktop4
-rw-r--r--CabbageLite.desktop4
-rw-r--r--PKGBUILD61
-rw-r--r--cabbage.pngbin0 -> 18257 bytes
-rw-r--r--fix_default_dirs.patch15
5 files changed, 54 insertions, 30 deletions
diff --git a/Cabbage.desktop b/Cabbage.desktop
index 95e7ecffc722..418f47eb1cc1 100644
--- a/Cabbage.desktop
+++ b/Cabbage.desktop
@@ -4,7 +4,7 @@ Name=Cabbage
GenericName=Audio development toolkit
Type=Application
Categories=AudioVideo;Audio;Multimedia
-Exec=/opt/cabbage/Cabbage
+Exec=/usr/bin/Cabbage
Terminal=false
StartupNotify=false
-Icon=/opt/cabbage/cabbage.png
+Icon=/usr/share/icons/hicolor/512x512/apps/cabbage.png
diff --git a/CabbageLite.desktop b/CabbageLite.desktop
index b817489bf6af..ccf4118eec72 100644
--- a/CabbageLite.desktop
+++ b/CabbageLite.desktop
@@ -4,7 +4,7 @@ Name=Cabbage Lite
GenericName=Audio development toolkit
Type=Application
Categories=AudioVideo;Audio;Multimedia
-Exec=/opt/cabbage/CabbageLite
+Exec=/usr/bin/CabbageLite
Terminal=false
StartupNotify=false
-Icon=/opt/cabbage/cabbage.png
+Icon=/usr/share/icons/hicolor/48x48/apps/cabbage.png
diff --git a/PKGBUILD b/PKGBUILD
index 957308e47d57..e195f35452bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Eugene Cherny <iam@oscii.ru>
pkgname=cabbage-git
pkgrel=1
-pkgver=2.0.0r1173
+pkgver=2.0.0r1188
pkgdesc='A framework for audio software development'
arch=('x86_64')
url="http://cabbageaudio.com/"
@@ -13,14 +13,16 @@ conflicts=('cabbage')
provides=('cabbage')
source=('git+https://github.com/rorywalsh/cabbage.git#branch=master'
'git+https://github.com/WeAreROLI/JUCE.git#tag=5.2.0'
- 'buildCabbage.patch'
+ 'fix_default_dirs.patch'
+ 'cabbage.png'
'Cabbage.desktop'
'CabbageLite.desktop')
md5sums=('SKIP'
'SKIP'
- '14c1f8e2590b0a98b3448a4267e679f2'
- 'c499a03801cf0e760c14759ab1927bef'
- '39992361c05babc4d12cbdcd2c3f6e04')
+ '822602714ba40c56144debaec5e1b0cb'
+ 'c3c8e35dd46c86f22a3565aa4dd828a8'
+ '35cfc89844c90769f4dc4f8309b340b1'
+ 'c39a85709e31e03a0850f2e324a4faea')
_projucer_dir="JUCE/extras/Projucer/Builds/LinuxMakefile/build/"
_projucer="${_projucer_dir}/Projucer"
@@ -72,26 +74,17 @@ function patch_strings_in_file() {
}
prepare() {
- # Projucer - building here to use it in pkgver()
-
- sed -i -e "s/JUCER_ENABLE_GPL_MODE 0/JUCER_ENABLE_GPL_MODE 1/" \
- "${srcdir}/JUCE/extras/Projucer/JuceLibraryCode/AppConfig.h"
- cd "${srcdir}/JUCE/extras/Projucer/Builds/LinuxMakefile/"
- make -j4
-
- # a hack to make Projucer use the system's VST header path
- patch_strings_in_file "${srcdir}/${_projucer}" "~/SDKs/VST_SDK/VST3_SDK" "/usr/include/vst36"
- # will be replaced with the following once Cabbage is ported to JUCE 5.3.0
- # "${srcdir}/${_projucer_dir}" --set-global-search-path linux vst3Path /usr/include/vst36/
-
- # Cabbage
-
cd "${srcdir}/cabbage"
for f in *jucer; do
sed -i "s@/usr/local/include/csound@/usr/include/csound@g" "$f"
sed -i "s@/usr/local/lib@/usr/lib@g" "$f"
done
- patch -p1 < ../../buildCabbage.patch
+
+ b="${srcdir}/cabbage/Builds/LinuxMakefile/buildCabbage"
+ sed -i "s@/usr/local/include/csound@/usr/include/csound@g" "$b"
+ sed -i "/CabbageBuild\/cabbage.desktop/d" "$b"
+
+ patch -p1 < ../../fix_default_dirs.patch
}
pkgver() {
@@ -100,20 +93,36 @@ pkgver() {
}
build() {
+ # Projucer
+
+ sed -i -e "s/JUCER_ENABLE_GPL_MODE 0/JUCER_ENABLE_GPL_MODE 1/" \
+ "${srcdir}/JUCE/extras/Projucer/JuceLibraryCode/AppConfig.h"
+ cd "${srcdir}/JUCE/extras/Projucer/Builds/LinuxMakefile/"
+ make -j4
+
+ # a hack to make Projucer use the system's VST header path
+ patch_strings_in_file "${srcdir}/${_projucer}" "~/SDKs/VST_SDK/VST3_SDK" "/usr/include/vst36"
+ # will be replaced with the following once Cabbage is ported to JUCE 5.3.0
+ # "${srcdir}/${_projucer_dir}" --set-global-search-path linux vst3Path /usr/include/vst36/
+
+ # Cabage
+
cd "${srcdir}/cabbage/Builds/LinuxMakefile"
./buildCabbage
}
package() {
+ install -Dm644 cabbage.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/cabbage.png"
install -Dm644 Cabbage.desktop "${pkgdir}/usr/share/applications/Cabbage.desktop"
install -Dm644 Cabbage.desktop "${pkgdir}/usr/share/applications/CabbageLite.desktop"
cd "${srcdir}/cabbage/Builds/LinuxMakefile/CabbageBuild/"
- install -d "${pkgdir}/opt/Cabbage"
- cp -R ./* "${pkgdir}/opt/Cabbage/"
- chmod -R 755 "${pkgdir}/opt/Cabbage"
- install -d "${pkgdir}/usr/bin"
- ln -s ../../opt/Cabbage/Cabbage "${pkgdir}/usr/bin/Cabbage"
- ln -s ../../opt/Cabbage/CabbageLite "${pkgdir}/usr/bin/CabbageLite"
+ for f in Cabbage CabbageLite CabbagePluginEffect.so CabbagePluginSynth.so opcodes.txt; do
+ install -Dm755 "$f" "${pkgdir}/usr/bin/$f"
+ done
+
+ install -d "${pkgdir}/usr/share/doc/cabbage/examples"
+ cp -r Examples/* "${pkgdir}/usr/share/doc/cabbage/examples/"
+ chmod -R 755 "${pkgdir}/usr/share/doc/cabbage"
}
diff --git a/cabbage.png b/cabbage.png
new file mode 100644
index 000000000000..17636c8e915e
--- /dev/null
+++ b/cabbage.png
Binary files differ
diff --git a/fix_default_dirs.patch b/fix_default_dirs.patch
new file mode 100644
index 000000000000..59a117f242e4
--- /dev/null
+++ b/fix_default_dirs.patch
@@ -0,0 +1,15 @@
+diff --git a/Source/Settings/CabbageSettings.cpp b/Source/Settings/CabbageSettings.cpp
+index 6d98818b..6fde16df 100755
+--- a/Source/Settings/CabbageSettings.cpp
++++ b/Source/Settings/CabbageSettings.cpp
+@@ -49,7 +49,9 @@ void CabbageSettings::setDefaultSettings()
+ #if defined(WIN32)
+ manualPath = "C:\\Program Files\\Csound6_x64\\doc\\manual";
+ #elif !defined(MACOSX)
+- manualPath = File::getSpecialLocation (File::currentExecutableFile).getParentDirectory().getFullPathName() + "/CsoundDocs";
++ examplesDir = "/usr/share/doc/cabbage/examples";
++ cabbageHelp = "/usr/share/doc/cabbage/help";
++ manualPath = "/usr/share/doc/csound-doc";
+ #else
+ examplesDir = File::getSpecialLocation (File::currentExecutableFile).getParentDirectory().getParentDirectory().getFullPathName() + "/Examples";
+ cabbageHelp = File::getSpecialLocation (File::currentExecutableFile).getParentDirectory().getParentDirectory().getFullPathName() + "/CabbageManual";