summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Greenup2020-07-25 08:42:36 +1000
committerRyan Greenup2020-07-25 08:42:36 +1000
commit13ec78393d43cf41ecf55b26cc86c16f5d3afae8 (patch)
treec05613e450fbffd4738b346312ac8ba6dc43ecbd
parentf6d7fdb8545ba59d190e697ca300261ba60e6af4 (diff)
downloadaur-13ec78393d43cf41ecf55b26cc86c16f5d3afae8.tar.gz
Removed Block Comments
-rw-r--r--PKGBUILD22
1 files changed, 2 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08f20163382b..1af20a847a43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=1.0
pkgrel=1
pkgdesc="Modular Shell Scripts for an MD Notebook"
arch=('x86_64')
-url="ryangreenup.github.io/cadmus"
+url="https://ryangreenup.github.io/cadmus"
license=('GPL3')
provides=('cadmus')
makedepends=(git)
@@ -20,6 +20,7 @@ depends=(
sed
grep
jq
+ wmctrl
pandoc
ranger
recode
@@ -27,39 +28,20 @@ depends=(
skim
xclip
)
-## These aren't in the official repos and could have
-## been installed with cargo
optdepends=('nodejs-markserv: Preview Support'
'tectonic: Additional option for PDF Export'
'mdcat: Pretty Print'
- ## These are just optional
'texlive-core: PDF Export'
'wmctrl: Move Windows'
'wl-clipboard: Clipboard for Wayland')
-#source=("git+https://github.com/RyanGreenup/cadmus.git#tag=${pkgver}")
source=("https://github.com/RyanGreenup/cadmus/releases/download/${pkgver}/cadmus.tar.xz")
-# source=("git+https://github.com/RyanGreenup/cadmus.git")
-# source=("git+https://github.com/RyanGreenup/cadmus.git#branch=makepkg")
sha256sums=('370d6ef60507aeaa8dfbc53e704bafa068df14cc891d5d700750be3e072b1d4d')
package() {
-################################################################################
-# If I wanted to actually install it by splitting up the binaries and resources
-################################################################################
-
-# install -Dm755 "$srcdir/cadmus/bin/*" -t "${pkgdir}/usr/bin/"
-# install -Dm644 "${srcdir}/README.md" -t "${pkgdir}/usr/share/doc/${pkgname%-bin}"
-# install -d "${srcdir}/cadmus/" -Dt "${pkgdir}/$HOME/.cadmus"
-
-################################################################################
-# Using the portable philosphy that I've previously settled on
-################################################################################
-
mkdir -p "${pkgdir}/opt/cadmus";
mkdir -p "${pkgdir}/usr/bin";
rsync -av ${srcdir}/cadmus/* "${pkgdir}/opt/cadmus/"
ln -rsf "${pkgdir}/opt/cadmus/bin/cadmus" "${pkgdir}/usr/bin/cadmus"
-
}