summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormahaoran.02023-06-12 16:35:51 +0800
committermahaoran.02023-06-12 16:35:51 +0800
commit59a03ce6db299cc1724389b9c1796e4c5cb22d50 (patch)
treeecf103876232f0717a3a07a132b2ee7733063db7
downloadaur-caffeine-ng-regex.tar.gz
initial commit
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD53
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5068905bb169
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = caffeine-ng-regex
+ pkgdesc = Status bar application able to temporarily inhibit the screensaver and sleep mode.
+ pkgver = 4.2.0
+ pkgrel = 1
+ url = https://codeberg.org/0xcccccccccccc/caffeine-ng-regex
+ arch = any
+ license = GPL-3.0-or-later
+ makedepends = git
+ makedepends = meson
+ makedepends = scdoc
+ depends = python-gobject
+ depends = python-xdg
+ depends = python-dbus
+ depends = python-click
+ depends = python-ewmh
+ depends = gtk3
+ depends = libnotify
+ depends = python-setproctitle
+ depends = python-wheel
+ depends = python-pulsectl
+ depends = libindicator-gtk3
+ depends = libayatana-appindicator
+ optdepends = xfconf: Support for Xfce presentation mode.
+ provides = caffeine
+ provides = caffeine-bzr
+ provides = caffeine-oneclick
+ provides = caffeine-systray
+ conflicts = caffeine
+ conflicts = caffeine-bzr
+ conflicts = caffeine-oneclick
+ conflicts = caffeine-systray
+ conflicts = caffeine-ng
+ replaces = caffeine-oneclick
+ replaces = caffeine-systray
+ source = caffeine-ng-4.2.0.tar.gz::https://codeberg.org/0xcccccccccccc/caffeine-ng-regex/archive/main.tar.gz
+ sha512sums = SKIP
+
+pkgname = caffeine-ng-regex
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6578cb877189
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Haoran Ma <1399898323@qq.com>
+
+pkgname=caffeine-ng-regex
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="Status bar application able to temporarily inhibit the screensaver and sleep mode."
+arch=(any)
+url="https://codeberg.org/0xcccccccccccc/caffeine-ng-regex"
+license=("GPL-3.0-or-later")
+depends=(
+ python-gobject
+ python-xdg
+ python-dbus
+ python-click
+ python-ewmh
+ gtk3
+ libnotify
+ python-setproctitle
+ python-wheel
+ python-pulsectl
+ libindicator-gtk3
+ libayatana-appindicator
+)
+optdepends=(
+ # "libappindicator-gtk3: AppIndicator support (eg: Plasma, Unity)."
+ "xfconf: Support for Xfce presentation mode."
+)
+makedepends=(
+ git
+ meson
+ scdoc
+)
+conflicts=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray caffeine-ng)
+provides=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
+replaces=(caffeine-oneclick caffeine-systray)
+source=("caffeine-ng-$pkgver.tar.gz::https://codeberg.org/0xcccccccccccc/caffeine-ng-regex/archive/main.tar.gz")
+sha512sums=('SKIP')
+
+build() {
+ cd "$srcdir/caffeine-ng-regex"
+ arch-meson . build
+ meson compile -C build
+}
+
+check() {
+ cd "$srcdir/caffeine-ng-regex"
+ meson test --no-rebuild --print-errorlogs -C build
+}
+
+package() {
+ cd "$srcdir/caffeine-ng-regex"
+ DESTDIR="$pkgdir" meson install --no-rebuild -C build
+}