summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2020-08-22 15:04:35 +0200
committerPieter Goetschalckx2020-08-22 15:04:35 +0200
commit338b7f0280de9df24c4a586976807b218c1bd1e8 (patch)
tree683e8b96a967b13809e8b5ed2e732bfa0248522e
downloadaur-cage-graph.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rwxr-xr-xcage-graph3
-rw-r--r--cage-graph.desktop10
-rw-r--r--cage-graph.patch98
5 files changed, 167 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5a07e80522c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cage-graph
+ pkgdesc = The Chemical & abstract Graph environment.
+ pkgver = 2016.02.23
+ pkgrel = 1
+ url = https://caagt.ugent.be/CaGe
+ arch = x86_64
+ license = unknown
+ depends = jdk8-openjdk
+ source = https://github.com/CaGe-graph/CaGe/releases/download/2016-02-23/CaGe.zip
+ source = cage-graph.patch
+ source = cage-graph.desktop
+ source = cage-graph
+ sha256sums = 42dd2f67d44826849426f347d0bc8fdbac4e194881d62c9cab36bb66964c27b8
+ sha256sums = 95a026eb3df6b9ddacbe0869473d9f3eba163d5db7091e5c3dd25d40d6bf817e
+ sha256sums = cb161b27d20728851f697851be87cea4f37e5711241a4367569ee8bfae40c0a5
+ sha256sums = 2abd0e5128c265421d4563466eceedc5f475b5a9ee0ae8c2e947c73f21aa3fa3
+
+pkgname = cage-graph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abedfd421158
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Pieter Goetschalckx
+
+pkgname=cage-graph
+pkgver=2016.02.23
+pkgrel=1
+pkgdesc='The Chemical & abstract Graph environment.'
+arch=(x86_64)
+url=https://caagt.ugent.be/CaGe
+license=(unknown)
+depends=(jdk8-openjdk)
+source=(
+ https://github.com/CaGe-graph/CaGe/releases/download/${pkgver//./-}/CaGe.zip
+ ${pkgname}.patch
+ ${pkgname}.desktop
+ ${pkgname}
+)
+sha256sums=('42dd2f67d44826849426f347d0bc8fdbac4e194881d62c9cab36bb66964c27b8'
+ '95a026eb3df6b9ddacbe0869473d9f3eba163d5db7091e5c3dd25d40d6bf817e'
+ 'cb161b27d20728851f697851be87cea4f37e5711241a4367569ee8bfae40c0a5'
+ '2abd0e5128c265421d4563466eceedc5f475b5a9ee0ae8c2e947c73f21aa3fa3')
+
+prepare() {
+ patch -p1 -i ${pkgname}.patch
+}
+
+build() {
+ export CFLAGS="-fcommon"
+ sh INSTALL.sh
+}
+
+package() {
+ install -Dm644 cage.sh CaGe.ini java javadir .rasmolrc *.jar -t ${pkgdir}/usr/lib/cage-graph/
+ cp -r Generators img Native PreCompute ${pkgdir}/usr/lib/cage-graph/
+
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -Dm644 ${pkgname}.desktop -t ${pkgdir}/usr/share/applications/
+}
diff --git a/cage-graph b/cage-graph
new file mode 100755
index 000000000000..7b21abfa3521
--- /dev/null
+++ b/cage-graph
@@ -0,0 +1,3 @@
+#! /bin/sh
+mkdir -p $HOME/.cage/Generators
+exec sh /usr/lib/cage-graph/cage.sh
diff --git a/cage-graph.desktop b/cage-graph.desktop
new file mode 100644
index 000000000000..1218bc26904a
--- /dev/null
+++ b/cage-graph.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=CaGe
+Comment=Chemical & abstract Graph environment
+Categories=Education;Science;Math;Chemistry;ComputerScience;
+Icon=/usr/lib/cage-graph/img/logo.png
+TryExec=/usr/bin/cage-graph
+Exec=/usr/bin/cage-graph
+StartupWMClass=cage-CaGe
diff --git a/cage-graph.patch b/cage-graph.patch
new file mode 100644
index 000000000000..f524e5a8778d
--- /dev/null
+++ b/cage-graph.patch
@@ -0,0 +1,98 @@
+diff -u a/CaGe.ini b/CaGe.ini
+--- a/CaGe.ini 2015-04-30 15:08:14.000000000 +0200
++++ b/CaGe.ini 2020-08-22 14:31:28.220417000 +0200
+@@ -20,7 +20,7 @@
+
+ # If this is true (or yes or 1), let user edit generator and embedder commands
+ # and suppress the warning about Rasmol's unreliability.
+-CaGe.ExpertMode: false
++CaGe.ExpertMode: true
+
+
+ # If this is true (or yes or 1), print detailed information to standard error.
+@@ -55,13 +55,13 @@
+ # The installation includes an empty subdirectory called "Data"
+ # and here, commented out, is a setting for RunDir that uses it.
+ # CaGe.Generators.RunDir: $[CaGe.InstallDir]/Data
+-CaGe.Generators.RunDir: .
++CaGe.Generators.RunDir: ${HOME}/.cage
+
+ # The search path used for generator and embedder processes, as well as
+ # any other pipes started by entering file names starting with '|'.
+ # - Separate path entries by space, not by ':' or ';' or whatever.
+ # - The search path is relative to RunDir, not to the start directory.
+-CaGe.Generators.Path: $[CaGe.InstallDir]/Generators ${PATH}
++CaGe.Generators.Path: $(CaGe.Generators.RunDir)/Generators $[CaGe.InstallDir]/Generators ${PATH}
+
+ # A file for generators' stderr output, relative to the start directory.
+ # CaGe tries to delete this at the end, even if no generator was ever run.
+@@ -255,4 +255,4 @@
+ # The following property specifies the class for the default type
+ Scad.type: cage.writer.scad.BallStickType
+ # The next property specifies the default resolution to use for SCAD outputs
+-Scad.resolution: medium
+\ No newline at end of file
++Scad.resolution: medium
+diff -u a/cage.sh b/cage.sh
+--- a/cage.sh 2015-07-15 10:28:04.000000000 +0200
++++ b/cage.sh 2020-08-22 15:00:33.654414263 +0200
+@@ -80,9 +80,9 @@
+ -classpath "$cp1$cp2" \
+ -Xdock:name="CaGe" \
+ -Xdock:icon=img/logo.png \
+- cage.CaGe 2>"$CaGe_InstallDir"./cage.log
++ cage.CaGe
+ else sh "$CaGe_InstallDir"./java \
+ -D"CaGe.InstallDir=$CaGe_InstallDir_NoSlash" \
+ -classpath "$cp1$cp2" \
+- cage.CaGe 2>"$CaGe_InstallDir"./cage.log
++ cage.CaGe
+ fi
+diff -u a/INSTALL.sh b/INSTALL.sh
+--- a/INSTALL.sh 2015-03-05 14:14:22.000000000 +0100
++++ b/INSTALL.sh 2020-08-22 14:58:33.640648487 +0200
+@@ -165,11 +165,8 @@
+ }
+
+
+-add_to_javadirlist "$PATH" ":"
+-prepare_javadirlist_prompt
+-
+ choice=""
+-while [ -z "$choice" ]
++while false
+ do
+ echo ""
+ test -n "$javadirlist" && echo "$nl$javadirlist"
+@@ -217,7 +214,7 @@
+ fi
+ done
+
+-javadir="` cd \"$javadir\"; pwd `"
++javadir="/usr/lib/jvm/java-8-openjdk"
+ echo ""
+ echo " Ok."
+ echo ""
+@@ -257,7 +254,7 @@
+ echo ""
+ (
+ cd PreCompute &&
+-make
++make CFLAGS="-O4 -w -fcommon"
+ make compute &
+ ) || error_exit "- 'make' failure, aborting."
+ echo ""
+@@ -269,7 +266,7 @@
+ echo ""
+ (
+ cd Generators &&
+-make
++make CFLAGS="-O4 -w -fcommon"
+ ) || error_exit "- 'make' failure, aborting."
+ echo ""
+ echo " Ok."
+@@ -293,4 +290,3 @@
+ echo " CaGe is started by the 'cage.sh' command."
+ echo " The file 'CaGe.ini' contains some options and comments."
+ echo ""
+-