summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDreamMaoMao2025-05-01 21:08:44 +0800
committerDreamMaoMao2025-05-01 21:08:44 +0800
commit6efd7ce1fa0983e36485cf3f8d6672532a3dbc9d (patch)
treed9bd8cfbbda21bca2aa67ce4917b2f8bf2505e84
downloadaur-cage-mao-git.tar.gz
add package
-rw-r--r--.SRCINFO25
-rw-r--r--LICENSE18
-rw-r--r--PKGBUILD46
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42e8410f96de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = cage-mao-git
+ pkgdesc = Kiosk compositor for Wayland with gamma and numlock support
+ pkgver = r354.a9584a1
+ pkgrel = 1
+ url = https://www.hjdskes.nl/projects/cage/
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = scdoc
+ makedepends = wayland-protocols
+ makedepends = xorg-server-xwayland
+ depends = glibc
+ depends = wayland
+ depends = wlroots-0.18-git
+ depends = libxkbcommon
+ optdepends = polkit: System privilege control. Required if not using seatd service
+ optdepends = xorg-server-xwayland: X11 support
+ provides = cage
+ conflicts = cage
+ conflicts = cage-git
+ source = cage-mao-git::git+https://github.com/DreamMaoMao/cage.git
+ sha512sums = SKIP
+
+pkgname = cage-mao-git
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ede42a17372d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,18 @@
+Binary files, as well as any files describing changes ("patches") to the software that is being built are excluded from this license.
+They are provided under the license terms of the software they describe
+changes for.
+
+Any files containing a license notice are excluded from this license. They are provided under the license terms defined in their respective notices.
+
+Copyright 2024 Arch Linux Contributors
+
+Permission to use, copy, modify, and/or distribute this software for
+any purpose with or without fee is hereby granted.
+
+THE SOFTWARE IS PROVIDED “AS IS” AND THE AUTHOR DISCLAIMS ALL
+WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE
+FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY
+DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN
+AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT
+OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83e433e6ecd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: DreamMaoMao <maoopzopaasnmakslpo@gmail.com>
+
+pkgname=cage-mao-git
+pkgver=r354.a9584a1
+pkgrel=1
+pkgdesc="Kiosk compositor for Wayland with gamma and numlock support"
+depends=(glibc wayland wlroots-0.18-git libxkbcommon)
+makedepends=(git meson scdoc wayland-protocols xorg-server-xwayland)
+optdepends=(
+ 'polkit: System privilege control. Required if not using seatd service'
+ 'xorg-server-xwayland: X11 support'
+)
+arch=(x86_64)
+url="https://www.hjdskes.nl/projects/cage/"
+license=(MIT)
+provides=(cage)
+conflicts=(cage cage-git)
+source=("${pkgname}::git+https://github.com/DreamMaoMao/cage.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ if git describe --long --tags >/dev/null 2>&1; then
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ else
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+ fi
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ # export PKG_CONFIG_PATH="/usr/lib/wlroots0.17/pkgconfig/"
+ meson setup --buildtype=release --prefix /usr "$srcdir/build"
+ ninja -C "$srcdir/build"
+}
+
+check() {
+ ninja -C "$srcdir/build" test
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ DESTDIR="$pkgdir" meson install -C "$srcdir/build"
+ install -vDm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -vDm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}