summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsamoht92772023-09-08 12:30:03 -0300
committersamoht92772023-09-08 12:30:03 -0300
commit1413b93e4011f56356b1b77c6c36e47dfee069c6 (patch)
tree54208702f88541ffb6ce5a5f55116ca89d5b3107
parent3bd0a6a585f669466679b10d383e422b9a96fc7b (diff)
downloadaur-cairo-lang.tar.gz
Fixed pkgrel.
-rw-r--r--PKGBUILD10
-rwxr-xr-xupdate-version.sh2
2 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df3ffe75c089..e1858474ba92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgname="cairo-lang"
pkgver=2.2.0
release=""
pkgdesc="Cairo language installation"
-pkgrel = 1
+pkgrel="1"
arch=("x86_64")
url="https://cairo-by-example.com/"
license=('APACHE')
@@ -31,5 +31,11 @@ package() {
mv cairo-$pkgver$release/target/release/$pkg $pkgdir/usr/bin/
done
- echo "Please export the variable CARGO_MANIFEST_DIR=/usr/lib/corelib/ to your shell's config file."
+ add_to_config
+}
+
+add_to_config() {
+ declare -A shells=(["bash"]=".bashrc" ["fish"]=".config/fish/config.fish" ["zsh"]=".zshrc")
+
+ echo "export CARGO_MANIFEST_DIR=\"/usr/bin/corelib/\"" >>/home/$USER/${shells[$(basename $(echo $SHELL))]}
}
diff --git a/update-version.sh b/update-version.sh
index 80184d7ee39e..163abf3cf4a3 100755
--- a/update-version.sh
+++ b/update-version.sh
@@ -17,7 +17,7 @@ pkgname="cairo-lang"
pkgver=${VERSION[0]#v}
release="${VERSION[1]}"
pkgdesc="Cairo language installation"
-pkgrel = 1
+pkgrel="1"
arch=("x86_64")
url="https://cairo-by-example.com/"
license=('APACHE')