summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Baxter2024-03-08 10:04:01 +1300
committerJeremy Baxter2024-03-08 10:04:01 +1300
commit8884f1e5f897a1b87f558aa74b2378a5f4c893e9 (patch)
tree032815e2acc8a0b6a5f78848641f403302e883ff
parent6c86bcc700a3ae9ce7a1f83643237926bbd8170e (diff)
downloadaur-callisto-git.tar.gz
move to sourcehut
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec161d56db4f..0cad3b75d266 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = callisto-git
pkgdesc = standalone scripting platform for Lua 5.4
- pkgver = v0.1.0.r97.g019fea4
+ pkgver = 0_gitbd664d10c2dee5e772b9bc3beb6a6f4bdc4203ae
pkgrel = 1
- url = https://github.com/jtbx/callisto
+ url = https://sr.ht/~jeremy/callisto/
arch = x86_64
license = GPL
makedepends = git
+ depends = readline
options = !emptydirs
- source = callisto-git::git+https://github.com/jtbx/callisto.git
+ source = callisto-git::git+https://git.sr.ht/~jeremy/callisto
sha256sums = SKIP
pkgname = callisto-git
diff --git a/PKGBUILD b/PKGBUILD
index 6f1bda2008f3..20a06117e518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: Jeremy Baxter <jtbx@disroot.org>
pkgname=callisto-git
-pkgver=v0.1.0.r97.g019fea4
+pkgver=0_gitbd664d10c2dee5e772b9bc3beb6a6f4bdc4203ae
pkgrel=1
pkgdesc='standalone scripting platform for Lua 5.4'
arch=('x86_64')
-url='https://github.com/jtbx/callisto'
-makedepends=('git')
-license=('GPL')
+url='https://sr.ht/~jeremy/callisto/'
+depends=(readline)
+makedepends=(git)
+license=(GPL)
options=('!emptydirs')
-source=("$pkgname::git+https://github.com/jtbx/callisto.git")
+source=("$pkgname::git+https://git.sr.ht/~jeremy/callisto")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "0_git"
+ git -C "$pkgname" rev-parse HEAD
}
build() {
cd "$pkgname"
- make -j$(nproc)
+ ./configure -wreadline
+ make
}
package() {