summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J2024-06-29 11:49:36 +0300
committerEcho J2024-06-29 11:49:36 +0300
commit509280227cb045e78bebc12fdd9591792bcc88d8 (patch)
tree1861e3f9aed086cd9b39b7a6bd08fa24c5157892
parent22fd126fb30ee288aded08e4dc4d3aa62f92a054 (diff)
downloadaur-cambalache.tar.gz
Update package to 0.90.4
And add a nvchecker file
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD6
4 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8db159f53257..41c2fed061ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cambalache
pkgdesc = A new RAD tool for Gtk 4 and 3
- pkgver = 0.90.2
- pkgrel = 2
+ pkgver = 0.90.4
+ pkgrel = 1
url = https://gitlab.gnome.org/jpu/cambalache
arch = x86_64
license = LGPL-2.1-only
@@ -22,7 +22,7 @@ pkgbase = cambalache
depends = python-lxml
depends = webkit2gtk-4.1
depends = webkitgtk-6.0
- source = https://gitlab.gnome.org/jpu/cambalache/-/archive/0.90.2/cambalache-0.90.2.tar.gz
- sha512sums = f962260b4be8f77f1036afe90e9489a3f9fda3d4a3c7786005c113fa434a4bc598094cfc799deefca2a8b935c7308aea995626e8e32089b7e06b256fe6098291
+ source = https://gitlab.gnome.org/jpu/cambalache/-/archive/0.90.4/cambalache-0.90.4.tar.gz
+ sha512sums = ac8b45b8ab45bb2ef9def2d9dbe75eb22bd2a2542af00c014934ef0ce9c54c98146b4a25b7066526de4fc772b40d97380e880b6d2f6cf16df76868e743e7d695
pkgname = cambalache
diff --git a/.gitignore b/.gitignore
index 018a3de08144..218cc907c9ed 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!PKGBUILD
!.SRCINFO
!.gitignore
+!.nvchecker.toml
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..dc763129857d
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[cambalache]
+source = "git"
+git = "https://gitlab.gnome.org/jpu/cambalache.git"
+include_regex = '.*.[0-9]*[02468].*'
diff --git a/PKGBUILD b/PKGBUILD
index cb0f128dd52e..92e3cff5de82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# shellcheck shell=bash disable=SC2034,SC2164
pkgname=cambalache
-pkgver=0.90.2
-pkgrel=2
+pkgver=0.90.4
+pkgrel=1
pkgdesc="A new RAD tool for Gtk 4 and 3"
arch=('x86_64')
url="https://gitlab.gnome.org/jpu/cambalache"
@@ -13,7 +13,7 @@ depends=('dconf' 'gdk-pixbuf2' 'glib2' 'gtk3' 'gtk4' 'gtksourceview5' 'hicolor-i
'libhandy' 'pango' 'python-gobject' 'python-lxml' 'webkit2gtk-4.1' 'webkitgtk-6.0')
makedepends=('gobject-introspection' 'meson' 'ninja')
source=("${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('f962260b4be8f77f1036afe90e9489a3f9fda3d4a3c7786005c113fa434a4bc598094cfc799deefca2a8b935c7308aea995626e8e32089b7e06b256fe6098291')
+sha512sums=('ac8b45b8ab45bb2ef9def2d9dbe75eb22bd2a2542af00c014934ef0ce9c54c98146b4a25b7066526de4fc772b40d97380e880b6d2f6cf16df76868e743e7d695')
build() {
arch-meson "${pkgname}-${pkgver}" build