summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2023-04-16 19:58:17 -0400
committerPaul Hentschel (hpmachining)2023-04-16 19:58:17 -0400
commit4f8f76e9c028db5568fe276f1576eb612505b922 (patch)
tree7864f51f082fbc2320a0b7d2ec429782515b97e9
parent5528a76e46b746f2c4e305a1d10c354a1102d669 (diff)
downloadaur-camotics.tar.gz
Updated to version 1.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--0001_python3_and_scons.patch160
-rw-r--r--PKGBUILD17
3 files changed, 12 insertions, 177 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 025e71a0edf5..068eca5d0eb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = camotics
pkgdesc = 3-axis NC machining simulation software
- pkgver = 1.2.0
- pkgrel = 4
+ pkgver = 1.3.0
+ pkgrel = 1
url = https://camotics.org/
arch = x86_64
license = GPL2
@@ -9,13 +9,11 @@ pkgbase = camotics
makedepends = python-six
makedepends = qt5-tools
makedepends = cbang
- depends = v8-3.14
+ depends = v8-r
depends = qt5-websockets
depends = cairo
depends = desktop-file-utils
- source = camotics-1.2.0.tar.gz::https://github.com/CauldronDevelopmentLLC/camotics/archive/v1.2.0.tar.gz
- source = 0001_python3_and_scons.patch
- sha256sums = f5203d2bbd32c4e347a8f79122e57b2deea68e6c5bd4f0be4087c4d62a31c8a4
- sha256sums = efd61c32d9adffffe73672effbcdcedcedcc14693c797ac4d93574ac4e20c1b9
+ source = camotics-1.3.0.tar.gz::https://github.com/CauldronDevelopmentLLC/camotics/archive/refs/tags/v1.3.0.tar.gz
+ sha256sums = d863781be2a5f4af8d9594e95cb6a752a67e034985dc522c7a95ddb4238150be
pkgname = camotics
diff --git a/0001_python3_and_scons.patch b/0001_python3_and_scons.patch
deleted file mode 100644
index a7822de05850..000000000000
--- a/0001_python3_and_scons.patch
+++ /dev/null
@@ -1,160 +0,0 @@
---- a/config/qt5/__init__.py 2019-02-09 03:42:39.000000000 -0500
-+++ b/config/qt5/__init__.py 2022-03-12 12:05:18.481925020 -0500
-@@ -42,7 +42,12 @@
- import SCons.Util
-
-
--class ToolQt5Warning(SCons.Warnings.Warning): pass
-+def _bytes_to_str(s):
-+ if isinstance(s, bytes): return s.decode()
-+ return s
-+
-+
-+class ToolQt5Warning(SCons.Warnings.SConsWarning): pass
- class GeneratedMocFileNotIncluded(ToolQt5Warning): pass
- class QtdirNotFound(ToolQt5Warning): pass
-
-@@ -187,7 +192,7 @@
- if moc_options['debug']:
- print("scons: qt5: Scanning '%s' (header of '%s')" %
- (h, cpp))
-- h_contents = h.get_contents()
-+ h_contents = _bytes_to_str(h.get_contents())
-
- if moc_options['gobble_comments']:
- h_contents = self.ccomment.sub('', h_contents)
-@@ -271,7 +276,7 @@
- print("scons: qt5: Scanning '%s' (header of '%s')" %
- (h, cpp))
-
-- h_contents = h.get_contents()
-+ h_contents = _bytes_to_str(h.get_contents())
- if moc_options['gobble_comments']:
- h_contents = self.ccomment.sub('', h_contents)
- h_contents = self.cxxcomment.sub('', h_contents)
-@@ -370,7 +375,8 @@
- continue
-
- try:
-- cpp_contents = cpp.get_contents()
-+ cpp_contents = _bytes_to_str(cpp.get_contents())
-+
- if moc_options['gobble_comments']:
- cpp_contents = self.ccomment.sub('', cpp_contents)
- cpp_contents = self.cxxcomment.sub('', cpp_contents)
-@@ -423,6 +429,7 @@
- p = subprocess.Popen('%s -v' % moc, shell = True,
- stdout = subprocess.PIPE, close_fds = True)
- vernumber = p.stdout.read()
-+ if isinstance(vernumber, bytes): vernumber = vernumber.decode()
- vernumber = mocver_re.match(vernumber)
-
- if vernumber:
-@@ -457,7 +464,7 @@
- else: result.append(itemPath)
- return result
-
-- contents = node.get_contents()
-+ contents = _bytes_to_str(node.get_contents())
- includes = qrcinclude_re.findall(contents)
- qrcpath = os.path.dirname(node.path)
- dirs = [included for included in includes if
-@@ -751,7 +758,7 @@
- QT5_MOCDEFPREFIX = '-D',
- QT5_MOCDEFSUFFIX = '',
- QT5_MOCDEFINES = '${_defines(QT5_MOCDEFPREFIX, CPPDEFINES, '
-- 'QT5_MOCDEFSUFFIX, __env__)}',
-+ 'QT5_MOCDEFSUFFIX, __env__, TARGET, SOURCE)}',
- QT5_MOCCPPPATH = [],
- QT5_MOCINCFLAGS = '$( ${_concat(QT5_MOCINCPREFIX, QT5_MOCCPPPATH, '
- 'INCSUFFIX, __env__, RDirs)} $)',
-@@ -932,7 +939,7 @@
- except: pass
-
- debugSuffix = ''
-- if sys.platform in ["darwin", "linux2"] and not crosscompiling :
-+ if sys.platform in ["darwin", "linux2", "linux"] and not crosscompiling :
- if debug : debugSuffix = '_debug'
- for module in modules :
- if module not in pclessModules : continue
---- a/SConstruct 2019-02-09 03:42:39.000000000 -0500
-+++ b/SConstruct 2022-03-12 12:03:04.921922687 -0500
-@@ -48,7 +48,7 @@
- lines += os.popen('svn status -v cbang').readlines()
- lines = filter(lambda l: len(l) and l[0] in 'MA ', lines)
- files = map(lambda l: l.split()[-1], lines)
-- files = filter(lambda f: not os.path.isdir(f), files)
-+ files = list(filter(lambda f: not os.path.isdir(f), files))
-
- tar = env.TarBZ2Dist('camotics', files)
- Alias('dist', tar)
-@@ -129,7 +129,7 @@
- src = []
- for subdir in ['', 'ast', 'parse', 'interp', 'machine', 'plan', 'plan/bbctrl']:
- src += Glob('src/gcode/%s/*.cpp' % subdir)
--src = map(lambda path: re.sub(r'^src/', 'build/', str(path)), src)
-+src = list(map(lambda path: re.sub(r'^src/', 'build/', str(path)), src))
- lib = env.Library('build/libGCode', src)
- libGCode = lib
- env.Prepend(LIBS = lib)
-@@ -137,14 +137,14 @@
-
- # libSTL
- src = Glob('src/stl/*.cpp')
--src = map(lambda path: re.sub(r'^src/', 'build/', str(path)), src)
-+src = list(map(lambda path: re.sub(r'^src/', 'build/', str(path)), src))
- lib = env.Library('build/libSTL', src)
- env.Prepend(LIBS = lib)
-
-
- # libDXF
- src = Glob('src/dxf/*.cpp')
--src = map(lambda path: re.sub(r'^src/', 'build/', str(path)), src)
-+src = list(map(lambda path: re.sub(r'^src/', 'build/', str(path)), src))
- lib = env.Library('build/libDXF', src)
- env.Prepend(LIBS = lib)
-
-@@ -155,7 +155,7 @@
- for subdir in subdirs: src += Glob('src/camotics/%s/*.cpp' % subdir)
- if env['with_tpl']: src += Glob('src/tplang/*.cpp')
-
--src = map(lambda path: re.sub(r'^src/', 'build/', str(path)), src)
-+src = list(map(lambda path: re.sub(r'^src/', 'build/', str(path)), src))
-
-
- # Build Info
-@@ -185,6 +185,7 @@
- for subdir in subdirs:
- guiSrc += Glob('src/camotics/%s/*.cpp' % subdir)
- guiSrc = map(lambda path: re.sub(r'^src/', 'build/', str(path)), guiSrc)
-+ guiSrc = list(guiSrc)
-
- # Qt
- dialogs = '''
-@@ -294,13 +295,15 @@
- cmd = 'git ls-files examples/'
- p = subprocess.Popen(cmd, shell = True, stdout = subprocess.PIPE)
- examples = p.communicate()[0]
-- examples = map(lambda x: [x, x], examples.split())
-+ if isinstance(examples, bytes): examples = examples.decode()
-+ examples = list(map(lambda x: [x, x], examples.split()))
-
- # Machines
- cmd = 'git ls-files machines/'
- p = subprocess.Popen(cmd, shell = True, stdout = subprocess.PIPE)
- machines = p.communicate()[0]
-- machines = map(lambda x: [x, x], machines.split())
-+ if isinstance(machines, bytes): machines = machines.decode()
-+ machines = list(map(lambda x: [x, x], machines.split()))
-
- # Package
- if 'package' in COMMAND_LINE_TARGETS:
-@@ -355,7 +358,7 @@
- platform_independent = ('tpl_lib'),
-
- documents = ['README.md', 'CHANGELOG.md'] + examples + machines,
-- programs = map(lambda x: str(x[0]), execs),
-+ programs = list(map(lambda x: str(x[0]), execs)),
- desktop_menu = ['CAMotics.desktop'],
- changelog = 'CHANGELOG.md',
-
diff --git a/PKGBUILD b/PKGBUILD
index 2e4c0a31ce24..325c3174a4a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Justin R. St-Amant <jstamant24 at gmail dot com>
pkgname=camotics
-pkgver=1.2.0
-pkgrel=4
+pkgver=1.3.0
+pkgrel=1
pkgdesc="3-axis NC machining simulation software"
arch=('x86_64')
url="https://camotics.org/"
license=('GPL2')
depends=(
- 'v8-3.14'
+ 'v8-r'
'qt5-websockets'
'cairo'
'desktop-file-utils'
@@ -21,25 +21,22 @@ makedepends=(
'cbang'
)
source=(
- "$pkgname-$pkgver.tar.gz::https://github.com/CauldronDevelopmentLLC/$pkgname/archive/v$pkgver.tar.gz"
- "0001_python3_and_scons.patch"
+ "$pkgname-$pkgver.tar.gz::https://github.com/CauldronDevelopmentLLC/$pkgname/archive/refs/tags/v$pkgver.tar.gz"
)
-sha256sums=('f5203d2bbd32c4e347a8f79122e57b2deea68e6c5bd4f0be4087c4d62a31c8a4'
- 'efd61c32d9adffffe73672effbcdcedcedcc14693c797ac4d93574ac4e20c1b9')
+sha256sums=('d863781be2a5f4af8d9594e95cb6a752a67e034985dc522c7a95ddb4238150be')
prepare() {
cd "CAMotics-$pkgver"
- patch -p1 -i "../0001_python3_and_scons.patch"
}
build() {
cd "CAMotics-$pkgver"
- CBANG_HOME=/opt/cbang scons linkflags=$LDFLAGS
+ CBANG_HOME=/opt/cbang scons cxxstd="c++17" linkflags="$LDFLAGS"
}
package() {
cd "CAMotics-$pkgver"
- CBANG_HOME=/opt/cbang scons install install_prefix="$pkgdir/usr"
+ CBANG_HOME=/opt/cbang scons cxxstd="c++17" install install_prefix="$pkgdir/usr"
install -d "$pkgdir/usr/share/$pkgname"/tpl_lib
cp -a tpl_lib/ "$pkgdir/usr/share/$pkgname"