summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2023-12-23 16:47:45 +0800
committertaotieren2023-12-23 16:47:45 +0800
commit313c237fda0a7f3a139839410a346f544b35dd21 (patch)
tree7aa964afc19d11d0dd489f3ad6fae3b186c67502
downloadaur-can-doc-git.tar.gz
update can-doc-git
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d056dd9f10f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = can-doc-git
+ pkgdesc = Linux-CAN / SocketCAN documentation
+ pkgver = r9.9f10695
+ pkgrel = 1
+ url = https://github.com/linux-can/can-doc
+ arch = any
+ license = unkown
+ makedepends = git
+ optdepends = can-utils: Linux-CAN / SocketCAN user space applications
+ optdepends = can-isotp-dkms: Kernel modules for isotp
+ provides = can-doc
+ conflicts = can-doc
+ source = can-doc-git::git+https://github.com/linux-can/can-doc.git
+ sha256sums = SKIP
+
+pkgname = can-doc-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68133be3b548
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgbase=can-doc-git
+pkgname=can-doc-git
+pkgver=r9.9f10695
+pkgrel=1
+groups=()
+pkgdesc="Linux-CAN / SocketCAN documentation"
+arch=(any)
+url="https://github.com/linux-can/can-doc"
+license=('unkown')
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+depends=()
+makedepends=(git)
+optdepends=("can-utils: Linux-CAN / SocketCAN user space applications"
+ "can-isotp-dkms: Kernel modules for isotp")
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+# git describe --long --tags | sed 's/^v//g' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+prepare()
+{
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/share/doc/${pkgname%-git}"
+
+ cd "${srcdir}/${pkgname}"/
+ rm -rf .*
+ cp -rv * "${pkgdir}/usr/share/doc/${pkgname%-git}/"
+}