summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2024-01-30 19:24:32 +0100
committerFabioLolix2024-01-30 19:24:32 +0100
commit05cfa351d4213cbcfa2053bf97cc026c13f74f43 (patch)
tree8b47ae3c9077097d55e9046f2207769241c745da
parent2535e138d7f24d624b9df91843d3f382ae9fe747 (diff)
downloadaur-cantata.tar.gz
fix build with taglib 2.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d281d6ef15f2..1ed5dde08618 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cantata
pkgdesc = Qt5 client for the music player daemon (MPD)
pkgver = 2.5.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/CDrummond/cantata
arch = x86_64
license = GPL3
@@ -25,6 +25,8 @@ pkgbase = cantata
optdepends = perl-uri: dynamic playlist
optdepends = sshfs: remote devices support
source = https://github.com/CDrummond/cantata/releases/download/v2.5.0/cantata-2.5.0.tar.bz2
+ source = cantata-tablib-2.0-compatibility.patch::https://github.com/fenuks/cantata/commit/45bac9eb3e99ed75b6539f92418556dac1c0193d.patch
sha256sums = eb7e00ab3f567afaa02ea2c86e2fe811a475afab93182b95922c6eb126821724
+ sha256sums = f9611a1c1e23b99ffb4ee709ec10982a9289e840ec4014b1bbaff798d226a8ad
pkgname = cantata
diff --git a/PKGBUILD b/PKGBUILD
index e158dd74628e..08c0ceca2093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
-# Contributor: Federico Cinelli <cinelli@aur.archlinux.org>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Federico Cinelli <cinelli@aur.archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Mcder3 <mcder3[at]gmail[dot]com>
# Contributor: MisterFred <mister.fred[at]free[dot]fr>
pkgname=cantata
pkgver=2.5.0
-pkgrel=4
+pkgrel=5
pkgdesc='Qt5 client for the music player daemon (MPD)'
arch=(x86_64)
url='https://github.com/CDrummond/cantata'
@@ -21,6 +22,8 @@ depends=(libcddb
qt5-svg
taglib
udisks2)
+#depends+=(libtag.so
+# libebur128.so)
optdepends=('ffmpeg: ReplayGain support'
'libebur128: ReplayGain support'
'mpd: playback'
@@ -30,12 +33,20 @@ makedepends=(cmake
ffmpeg
libebur128
qt5-tools)
-source=(https://github.com/CDrummond/cantata/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2)
-sha256sums=('eb7e00ab3f567afaa02ea2c86e2fe811a475afab93182b95922c6eb126821724')
+source=("https://github.com/CDrummond/cantata/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2"
+ "cantata-tablib-2.0-compatibility.patch::https://github.com/fenuks/cantata/commit/45bac9eb3e99ed75b6539f92418556dac1c0193d.patch")
+sha256sums=('eb7e00ab3f567afaa02ea2c86e2fe811a475afab93182b95922c6eb126821724'
+ 'f9611a1c1e23b99ffb4ee709ec10982a9289e840ec4014b1bbaff798d226a8ad')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i ../cantata-tablib-2.0-compatibility.patch
+}
build() {
- cmake -B build -S $pkgname-$pkgver \
+ cmake -B build -S "$pkgname-$pkgver" -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr
+
cmake --build build
}