summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-04-06 13:00:55 -0400
committerTed Alff2017-04-06 13:00:55 -0400
commit222b13289f3415d3a68867d6f66d9e8dc88cae39 (patch)
treeb745fed09c76f8910474d7529191aa6bfde64556
parent1a687bc3c1562c39415b2da541c2651d4b08c713 (diff)
downloadaur-cardapio-bzr.tar.gz
Updated (really uses git -- maybe I'll try to change the name)
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
-rw-r--r--arch_and_python_stuff.patch146
-rw-r--r--xdg_fix.patch71
-rw-r--r--xfce_cinnamon_better_support.patch55
5 files changed, 96 insertions, 233 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53b5d418ad68..4c5e31368400 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,28 @@
# Generated by mksrcinfo v8
-# Mon Dec 28 13:56:09 UTC 2015
+# Thu Apr 6 17:00:33 UTC 2017
pkgbase = cardapio-bzr
pkgdesc = An alternative Gnome menu, launcher, and much more!
- pkgver = 886
- pkgrel = 2
+ pkgver = 996
+ pkgrel = 1
url = https://launchpad.net/cardapio
arch = i686
arch = x86_64
license = GPL3
- makedepends = bzr
+ makedepends = git
depends = python2-xdg
depends = xdg-user-dirs
depends = python2-dbus
- depends = python2-gnomedesktop
+ depends = gnome-python-desktop
depends = python2-keybinder2
- depends = python2-simplejson
- depends = gnome-control-center
- depends = tk
optdepends = tracker: search capability
provides = cardapio
conflicts = cardapio
- source = cardapio::bzr+https://launchpad.net/cardapio/trunk
- source = arch_and_python_stuff.patch
+ source = cardapio::git+https://git.launchpad.net/cardapio
source = xdg_fix.patch
+ source = xfce_cinnamon_better_support.patch
sha256sums = SKIP
- sha256sums = 3fdaae9f4248c10d665492fb85f018d22d1a7120c65a1491efe58a2437bb98d0
- sha256sums = 7c9915154d57c50724a5670b4dd4bb831f89208225690c3a0bcc039b60eefea3
+ sha256sums = da05e1f24399ae3dc401ab3a89e05eb1a610c7777bbb45c723444f0c782fa5d9
+ sha256sums = 8b3b22b9ee5e3d26b1f9c09f49b70f35f7a3ffb7e6579e87a7a78183482ec856
pkgname = cardapio-bzr
diff --git a/PKGBUILD b/PKGBUILD
index 758f959cb48d..ddfeead3dc7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,37 @@
_pkgname=cardapio
pkgname=${_pkgname}-bzr
-pkgver=886
-pkgrel=2
+pkgver=996
+pkgrel=1
pkgdesc="An alternative Gnome menu, launcher, and much more!"
arch=('i686' 'x86_64')
url="https://launchpad.net/cardapio"
license=('GPL3')
conflicts=('cardapio')
provides=('cardapio')
-depends=('python2-xdg' 'xdg-user-dirs' 'python2-dbus' 'python2-gnomedesktop' 'python2-keybinder2' 'python2-simplejson' 'gnome-control-center' 'tk')
-makedepends=('bzr')
+depends=('python2-xdg' 'xdg-user-dirs' 'python2-dbus' 'gnome-python-desktop' 'python2-keybinder2')
+makedepends=('git')
optdepends=('tracker: search capability')
-source=('cardapio::bzr+https://launchpad.net/cardapio/trunk'
- 'arch_and_python_stuff.patch'
- 'xdg_fix.patch')
+source=('cardapio::git+https://git.launchpad.net/cardapio'
+ 'xdg_fix.patch'
+ 'xfce_cinnamon_better_support.patch')
pkgver() {
- cd "${_pkgname}"
- printf "%s" "$(bzr revno)"
+ cd ${srcdir}/${_pkgname}
+ git rev-list --count HEAD
}
prepare() {
- msg "Arch and Python2 adjustments..."
cd "${srcdir}/${_pkgname}"
- patch -uNp2 -r- -i ../arch_and_python_stuff.patch || return 1
- patch -uNp2 -r- -i ../xdg_fix.patch || return 1
+ # All the python2 fixes
+ sed -i 's:python\([ \t$]\):python2\1:g' Makefile
+ find ./src -type f -exec sed -i 's:\(#!.*python\):&2:' '{}' \;
+ # Doesn't like concatting NoneType + str
+ patch -uNp2 -r- -i ../xdg_fix.patch
+ # Add some cinnamon and xfce specifics
+ patch -uNp2 -r- -i ../xfce_cinnamon_better_support.patch
+ # We're not Ubuntu
+ rm src/plugins/software_center.py
}
build() {
@@ -39,9 +45,9 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
- rm "${pkgdir}"/usr/share/locale/cardapio.pot
+ rm "${pkgdir}"/usr/share/locale/cardapio.pot
}
sha256sums=('SKIP'
- '3fdaae9f4248c10d665492fb85f018d22d1a7120c65a1491efe58a2437bb98d0'
- '7c9915154d57c50724a5670b4dd4bb831f89208225690c3a0bcc039b60eefea3')
+ 'da05e1f24399ae3dc401ab3a89e05eb1a610c7777bbb45c723444f0c782fa5d9'
+ '8b3b22b9ee5e3d26b1f9c09f49b70f35f7a3ffb7e6579e87a7a78183482ec856')
diff --git a/arch_and_python_stuff.patch b/arch_and_python_stuff.patch
deleted file mode 100644
index 9787e7c8a8f3..000000000000
--- a/arch_and_python_stuff.patch
+++ /dev/null
@@ -1,146 +0,0 @@
-diff -Naur ./cardapio.orig/Makefile ./cardapio/Makefile
---- ./cardapio.orig/Makefile 2012-09-08 21:27:31.836738592 -0400
-+++ ./cardapio/Makefile 2012-09-08 21:31:24.632143534 -0400
-@@ -1,4 +1,4 @@
--PYTHON = `which python`
-+PYTHON = `which python2`
-
- ifeq ($(DESTDIR),)
- DESTDIR =
-@@ -31,8 +31,8 @@
- install: install-alone install-panel install-docky install-awn install-shell install-mate install-cinnamon
-
- install-alone:
-- python -m compileall src/
-- python -m compileall src/plugins/
-+ $(PYTHON) -m compileall src/
-+ $(PYTHON) -m compileall src/plugins/
-
- # remove old files which have been renamed or moved to another package
- rm -f $(PREFIX)/lib/cardapio/cardapio.py
-@@ -89,7 +89,7 @@
- cp -f res/cardapio*.svg $(PREFIX)/share/pixmaps/
-
- mkdir -p $(PREFIX)/bin
-- ln -sf ../lib/cardapio/cardapio $(PREFIX)/bin/cardapio
-+ #ln -sf ../lib/cardapio/cardapio $(PREFIX)/bin/cardapio
-
- mkdir -p $(PREFIX)/share/applications
- cp -f res/cardapio.desktop $(PREFIX)/share/applications/
-@@ -98,7 +98,7 @@
- cp -f res/cardapio.service $(PREFIX)/share/dbus-1/services/cardapio.service
-
- install-panel: install-alone
-- python -m compileall src/gnomepanel/
-+ $(PYTHON) -m compileall src/gnomepanel/
- cp -f src/gnomepanel/cardapio-gnome-panel $(PREFIX)/lib/cardapio/
- cp -f src/gnomepanel/cardapio-gnome3-panel $(PREFIX)/lib/cardapio/
-
-@@ -109,11 +109,11 @@
- cp -f src/gnomepanel/__init__* $(PREFIX)/lib/cardapio/gnomepanel/
-
- mkdir -p $(PREFIX)/bin
-- ln -sf ../lib/cardapio/cardapio-gnome-panel $(PREFIX)/bin/cardapio-gnome-panel
-- ln -sf ../lib/cardapio/cardapio-gnome3-panel $(PREFIX)/bin/cardapio-gnome3-panel
-+ #ln -sf ../lib/cardapio/cardapio-gnome-panel $(PREFIX)/bin/cardapio-gnome-panel
-+ #ln -sf ../lib/cardapio/cardapio-gnome3-panel $(PREFIX)/bin/cardapio-gnome3-panel
-
- mkdir -p $(PREFIX)/lib/gnome-applets
-- ln -sf ../cardapio/cardapio-gnome3-panel $(PREFIX)/lib/gnome-applets/cardapio-gnome-panel
-+ #ln -sf ../cardapio/cardapio-gnome3-panel $(PREFIX)/lib/gnome-applets/cardapio-gnome-panel
-
- mkdir -p $(PREFIX)/share/dbus-1/services
- cp -f src/gnomepanel/cardapio.service $(PREFIX)/share/dbus-1/services/org.gnome.panel.applet.CardapioGnomeApplet.service
-@@ -130,7 +130,7 @@
- rm locale/*.po
-
- install-mate: install-alone
-- python -m compileall src/matepanel/
-+ $(PYTHON) -m compileall src/matepanel/
- cp -f src/matepanel/cardapio-mate-panel-applet $(PREFIX)/lib/cardapio/
-
- mkdir -p $(PREFIX)/lib/cardapio/matepanel
-@@ -139,7 +139,7 @@
- cp -f src/matepanel/__init__* $(PREFIX)/lib/cardapio/matepanel/
-
- mkdir -p $(PREFIX)/bin
-- ln -sf ../lib/cardapio/cardapio-mate-panel-applet $(PREFIX)/bin/cardapio-mate-panel-applet
-+ #ln -sf ../lib/cardapio/cardapio-mate-panel-applet $(PREFIX)/bin/cardapio-mate-panel-applet
-
- mkdir -p $(PREFIX)/lib/matecomponent/servers
- #cp -f src/matepanel/cardapio.server $(PREFIX)/lib/matecomponent/servers/
-@@ -150,7 +150,7 @@
- rm locale/*.po
-
- install-docky: install-alone
-- python -m compileall src/docky/
-+ $(PYTHON) -m compileall src/docky/
- cp -f res/cardapioDocky.desktop $(PREFIX)/lib/cardapio/
-
- mkdir -p $(PREFIX)/lib/cardapio/docky
-diff -Naur ./cardapio.orig/src/Cardapio.py ./cardapio/src/Cardapio.py
---- ./cardapio.orig/src/Cardapio.py 2012-09-08 21:27:31.846738098 -0400
-+++ ./cardapio/src/Cardapio.py 2012-09-08 21:28:06.239884241 -0400
-@@ -117,7 +117,7 @@
-
- class Cardapio(dbus.service.Object):
-
-- distro_name = platform.linux_distribution()[0]
-+ distro_name = 'ArchLinux'
-
- MIN_VISIBILITY_TOGGLE_INTERVAL = 0.200 # seconds (this is a bit of a hack to fix some focus problems)
- PLUGIN_REBUILD_DELAY = 30000 # milliseconds
-@@ -2930,7 +2930,7 @@
- self._launch_raw(self.de.about_de)
-
- elif verb == 'AboutDistro':
-- self._launch_raw(self.de.about_distro)
-+ self.launch_raw('xdg-open http://wiki.archlinux.org')
-
- else: self._view.open_about_dialog()
-
-diff -Naur ./cardapio.orig/src/cardapio ./cardapio/src/cardapio
---- ./cardapio.orig/src/cardapio 2012-09-08 21:27:31.843404944 -0400
-+++ ./cardapio/src/cardapio 2012-09-08 21:28:06.239884241 -0400
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- #
- # Cardapio is an alternative menu applet, launcher, and much more!
- #
-diff -Naur ./cardapio.orig/src/docky/cardapio_helper.py ./cardapio/src/docky/cardapio_helper.py
---- ./cardapio.orig/src/docky/cardapio_helper.py 2012-09-08 21:27:31.846738098 -0400
-+++ ./cardapio/src/docky/cardapio_helper.py 2012-09-08 21:28:06.239884241 -0400
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
-
- #
- # Copyright (C) 2010 Cardapio Team (tvst@hotmail.com)
-diff -Naur ./cardapio.orig/src/gnomepanel/cardapio-gnome-panel ./cardapio/src/gnomepanel/cardapio-gnome-panel
---- ./cardapio.orig/src/gnomepanel/cardapio-gnome-panel 2012-09-08 21:27:31.846738098 -0400
-+++ ./cardapio/src/gnomepanel/cardapio-gnome-panel 2012-09-08 21:28:06.239884241 -0400
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- #
- # Cardapio is an alternative menu applet, launcher, and much more!
- # Copyright (C) 2010 Cardapio Team (tvst@hotmail.com)
-diff -Naur ./cardapio.orig/src/gnomepanel/cardapio-gnome3-panel ./cardapio/src/gnomepanel/cardapio-gnome3-panel
---- ./cardapio.orig/src/gnomepanel/cardapio-gnome3-panel 2012-09-08 21:27:31.846738098 -0400
-+++ ./cardapio/src/gnomepanel/cardapio-gnome3-panel 2012-09-08 21:28:06.239884241 -0400
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- #
- # Cardapio is an alternative menu applet, launcher, and much more!
- # Copyright (C) 2010 Cardapio Team (tvst@hotmail.com)
-diff -Naur ./cardapio.orig/src/matepanel/cardapio-mate-panel-applet ./cardapio/src/matepanel/cardapio-mate-panel-applet
---- ./cardapio.orig/src/matepanel/cardapio-mate-panel-applet 2012-09-08 21:27:31.843404944 -0400
-+++ ./cardapio/src/matepanel/cardapio-mate-panel-applet 2012-09-08 21:28:06.239884241 -0400
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- #
- # Cardapio is an alternative menu applet, launcher, and much more!
- #
diff --git a/xdg_fix.patch b/xdg_fix.patch
index 64449efcb51a..a0ed9c631ec4 100644
--- a/xdg_fix.patch
+++ b/xdg_fix.patch
@@ -1,61 +1,12 @@
-diff -Naur ./cardapio.old/src/Cardapio.py ./cardapio/src/Cardapio.py
---- ./cardapio.old/src/Cardapio.py 2015-12-27 23:12:03.443879297 -0500
-+++ ./cardapio/src/Cardapio.py 2015-12-27 23:12:29.254221586 -0500
-@@ -41,6 +41,7 @@
- import gio
- import glib
- import json
-+ import xdg
+diff -Naur ./cardapio.orig/src/XDGMenuHelper.py ./cardapio/src/XDGMenuHelper.py
+--- ./cardapio.orig/src/XDGMenuHelper.py 2017-04-06 12:15:42.646494966 -0400
++++ ./cardapio/src/XDGMenuHelper.py 2017-04-06 12:16:01.526494168 -0400
+@@ -29,7 +29,7 @@
+ In this case, the implementation is for the XDG version.
+ """
+
+- def __init__(self, filename = None, prefix = None):
++ def __init__(self, filename = None, prefix = ""):
+ if filename: self._node = Menu.parse(prefix + filename)
+ else: self._node = None
- import urllib2
- import gettext
-@@ -53,6 +54,7 @@
-
- from time import time
- from xdg import DesktopEntry
-+ from xdg import BaseDirectory
- from pango import ELLIPSIZE_END
- from threading import Lock, Thread
- from locale import setlocale, LC_ALL
-@@ -453,7 +455,7 @@
- self._plugin_database['pinned'] = {'class' : plugin_class, 'instances' : []}
-
- plugin_dirs = [
-- os.path.join(DesktopEntry.xdg_config_home, 'Cardapio', 'plugins'),
-+ os.path.join(BaseDirectory.xdg_config_home, 'Cardapio', 'plugins'),
- os.path.join(self.cardapio_path, 'plugins'),
- ]
-
-@@ -631,7 +633,7 @@
- ~/.cache/Cardapio)
- """
-
-- self._config_folder_path = os.path.join(DesktopEntry.xdg_config_home, 'Cardapio')
-+ self._config_folder_path = os.path.join(BaseDirectory.xdg_config_home, 'Cardapio')
-
- if not os.path.exists(self._config_folder_path):
- os.mkdir(self._config_folder_path)
-@@ -640,7 +642,7 @@
- fatal_error('Error creating config folder!', 'Cannot create folder "%s" because a file with that name already exists!' % self._config_folder_path)
- self._quit()
-
-- self._cache_folder_path = os.path.join(DesktopEntry.xdg_cache_home, 'Cardapio')
-+ self._cache_folder_path = os.path.join(BaseDirectory.xdg_cache_home, 'Cardapio')
-
- if not os.path.exists(self._cache_folder_path):
- os.mkdir(self._cache_folder_path)
-@@ -1931,7 +1933,7 @@
-
- self._add_app_button(_('Home'), 'user-home', section, 'xdg', self._home_folder_path, _('Open your personal folder'), self._app_list)
-
-- xdg_folders_file_path = os.path.join(DesktopEntry.xdg_config_home, 'user-dirs.dirs')
-+ xdg_folders_file_path = os.path.join(BaseDirectory.xdg_config_home, 'user-dirs.dirs') #***
- xdg_folders_file = file(xdg_folders_file_path, 'r')
- # TODO: xdg_folders_file = codecs.open(xdg_folders_file_path, mode='r', encoding='utf-8')
-
-@@ -3303,5 +3305,3 @@
- __builtin__.get_output = get_output
- __builtin__.fatal_error = fatal_error
- __builtin__.which = which
--
--
diff --git a/xfce_cinnamon_better_support.patch b/xfce_cinnamon_better_support.patch
new file mode 100644
index 000000000000..744404cc89ea
--- /dev/null
+++ b/xfce_cinnamon_better_support.patch
@@ -0,0 +1,55 @@
+diff -Naur ./cardapio.orig/src/DesktopEnvironment.py ./cardapio/src/DesktopEnvironment.py
+--- ./cardapio.orig/src/DesktopEnvironment.py 2017-04-06 12:42:53.829759311 -0400
++++ ./cardapio/src/DesktopEnvironment.py 2017-04-06 12:43:02.613092267 -0400
+@@ -63,13 +63,13 @@
+ self.environent = 'gnome3'
+
+ if self.environment == 'kde' : pass
+- elif self.environment == 'xfce' : pass
++ elif self.environment == 'xfce' : self.init_xfce()
+ elif self.environment == 'lxde' : self.init_lxde()
+ elif self.environment == 'lwde' : pass
+ elif self.environment == 'mate' : self.init_mate()
+- elif self.environment == 'gnome' : self.init_gnome()
++ elif self.environment == 'gnome' : self.init_gnome3()
+ elif self.environment == 'gnome-shell' : self.init_gnome3()
+- elif self.environment == 'cinnamon' : self.init_gnome3()
++ elif self.environment == 'cinnamon' : self.init_cinnamon()
+
+ def init_gnome(self):
+ """
+@@ -135,6 +135,34 @@
+ self.save_session = 'pkill -SIGTERM lxsession'
+ self.shutdown = 'lxde-logout'
+
++ def init_xfce(self):
++ """
++ Override some of the default variables for use in XFCE
++ """
++ self.about_de = 'xfce4-about'
++ self.about_distro = None
++ self.menu_editor = 'menulibre'
++ self.file_open = "xdg-open '%s'"
++ self.connect_to_server = 'thunar'
++ self.lock_screen = 'xflock4'
++ self.save_session = 'xfce4-session-logout'
++ self.shutdown = 'xfce4-session-logout'
++ self.execute_in_terminal = None
++
++ def init_cinnamon(self):
++ """
++ Override some of the default variables for use in Cinnamon
++ """
++ self.about_de = 'cinnamon-settings info'
++ self.about_distro = 'cinnamon-settings info'
++ self.menu_editor = 'cinnamon-menu-editor'
++ self.file_open = "xdg-open '%s'"
++ self.connect_to_server = 'nemo-connect-server'
++ self.lock_screen = 'cinnamon-screensaver-command --lock'
++ self.save_session = 'cinnamon-session-quit --logout'
++ self.shutdown = 'cinnamon-session-quit --power-off'
++ self.execute_in_terminal = None
++
+
+ def register_session_close_handler(self, handler):
+ """