summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Malaco2022-08-04 03:14:23 -0300
committerJonas Malaco2022-08-04 03:20:59 -0300
commit8d5ab64efd69e8821c56150194a2a689d9929e73 (patch)
tree6df75052d8348253f1e5c0bfb536368bf8ab78e2
parent0d2989471076d4a7faaddee1863f5ac9dbd60518 (diff)
downloadaur-cargo-criterion.tar.gz
Correctly specify the supported architectures
This package can be compiled for several architectures but, once built, is *not* architecture-independent. See [1] for more information. While I can currently only test it on x86_64, this package probably also works on other Tier 1 and Tier 2 Rust targets with Host Tools.[2] [1] https://wiki.archlinux.org/title/PKGBUILD#arch [2] https://doc.rust-lang.org/rustc/platform-support.html
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD4
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 553d73c6023c..e9527f796cbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,12 @@
pkgbase = cargo-criterion
pkgdesc = Cargo plugin for analyzing and reporting on Criterion-rs benchmarks.
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bheisler/cargo-criterion
- arch = any
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ arch = armv7h
license = Apache
license = MIT
depends = cargo
diff --git a/PKGBUILD b/PKGBUILD
index 637e628c308b..fed718272ecb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Jonas Malaco <jonas@protocubo.io>
pkgname=cargo-criterion
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Cargo plugin for analyzing and reporting on Criterion-rs benchmarks.'
-arch=('any')
+arch=('x86_64' 'i686' 'aarch64' 'armv7h')
url='https://github.com/bheisler/cargo-criterion'
license=('Apache' 'MIT')
depends=('cargo' 'rust')