summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2022-11-10 19:37:23 +0100
committerXiretza2022-11-10 19:37:23 +0100
commita1541301a7031934e5977a6805d7d46bbd20ef3e (patch)
tree0d5380d4ab211d183b686ded130c83255513ee86
parent8908d3963974382083bf62b63b65e1b429c0b2ee (diff)
downloadaur-catch2-git.tar.gz
Update patches, update check() for new debug package layout
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Remove-misguided-attempt-at-reproducibility-that-bre.patch16
-rw-r--r--0002-ApprovalTests-fix-path-rewriting-for-debug-builds.patch8
-rw-r--r--PKGBUILD8
4 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10b7bcf67ff2..e16c1b03f6cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = catch2-git
pkgdesc = Modern, C++-native, header-only, test framework for unit-tests, TDD and BDD (developmental version)
- pkgver = 3.0.0.preview4.r48.g81f612c9
+ pkgver = 3.1.1.r45.gb65c0e27
pkgrel = 1
url = https://github.com/catchorg/catch2
arch = x86_64
@@ -8,13 +8,13 @@ pkgbase = catch2-git
makedepends = cmake
makedepends = python
makedepends = git
- provides = catch2=3.0.0.preview4.r48.g81f612c9
+ provides = catch2=3.1.1.r45.gb65c0e27
conflicts = catch2
source = git+https://github.com/catchorg/Catch2
source = 0001-Remove-misguided-attempt-at-reproducibility-that-bre.patch
source = 0002-ApprovalTests-fix-path-rewriting-for-debug-builds.patch
sha256sums = SKIP
- sha256sums = 6bf9e7322a4a4399b483118e4c5bea1a0a214aca5938f687cf2f44bfb7b9b3fe
- sha256sums = 8c25aa44ad638eed275190c2850ede73c626ecabf4d8bd176e8d707d04c4a74a
+ sha256sums = d26bd252d163e4648217c942bc5a9ac36edba6a151759edd57597ae437866d8e
+ sha256sums = 72fd49a773699f85eb0954074231c9229ee442c58e2c4e476c25d4ce2328381b
pkgname = catch2-git
diff --git a/0001-Remove-misguided-attempt-at-reproducibility-that-bre.patch b/0001-Remove-misguided-attempt-at-reproducibility-that-bre.patch
index a61dec15cb6d..37f8d3e549a3 100644
--- a/0001-Remove-misguided-attempt-at-reproducibility-that-bre.patch
+++ b/0001-Remove-misguided-attempt-at-reproducibility-that-bre.patch
@@ -1,4 +1,4 @@
-From 1abd458351a44c14942b93ca77084a7cc0e3589e Mon Sep 17 00:00:00 2001
+From 31c875b3fa603938c37c53fc318882a9bb07c07f Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Thu, 25 Nov 2021 15:59:16 +0100
Subject: [PATCH 1/2] Remove misguided attempt at reproducibility that breaks
@@ -11,19 +11,19 @@ packages work, -ffile-prefix-map overrides this.
1 file changed, 2 deletions(-)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 4aa755a4..57bd0fae 100644
+index e81d9b6f..a4cbd546 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -252,7 +252,6 @@ add_library(Catch2 STATIC
- ${BENCHMARK_HEADERS}
- ${BENCHMARK_SOURCES}
+@@ -332,7 +332,6 @@ source_group("generated headers"
)
+
+ add_library(Catch2 ${ALL_FILES})
-add_build_reproducibility_settings(Catch2)
add_library(Catch2::Catch2 ALIAS Catch2)
if (ANDROID)
-@@ -302,7 +301,6 @@ target_include_directories(Catch2
- add_library(Catch2WithMain STATIC
+@@ -385,7 +384,6 @@ target_include_directories(Catch2
+ add_library(Catch2WithMain
${SOURCES_DIR}/internal/catch_main.cpp
)
-add_build_reproducibility_settings(Catch2WithMain)
@@ -31,5 +31,5 @@ index 4aa755a4..57bd0fae 100644
target_link_libraries(Catch2WithMain PUBLIC Catch2)
set_target_properties(Catch2WithMain
--
-2.35.1
+2.38.1
diff --git a/0002-ApprovalTests-fix-path-rewriting-for-debug-builds.patch b/0002-ApprovalTests-fix-path-rewriting-for-debug-builds.patch
index 7842f05e2683..75848c5b5a48 100644
--- a/0002-ApprovalTests-fix-path-rewriting-for-debug-builds.patch
+++ b/0002-ApprovalTests-fix-path-rewriting-for-debug-builds.patch
@@ -1,4 +1,4 @@
-From bf2d69e857366267dc9cc710ba325db1b6940003 Mon Sep 17 00:00:00 2001
+From 74edb0c633892f14943342976b3e8ff0ba7a76fa Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sun, 13 Mar 2022 15:12:37 +0100
Subject: [PATCH 2/2] ApprovalTests: fix path rewriting for debug builds
@@ -8,10 +8,10 @@ Subject: [PATCH 2/2] ApprovalTests: fix path rewriting for debug builds
1 file changed, 13 insertions(+), 7 deletions(-)
diff --git a/tools/scripts/approvalTests.py b/tools/scripts/approvalTests.py
-index 36bbdd2f..8b39679c 100755
+index 592be36e..8e8f9285 100755
--- a/tools/scripts/approvalTests.py
+++ b/tools/scripts/approvalTests.py
-@@ -72,14 +72,20 @@ def diffFiles(fileA, fileB):
+@@ -94,14 +94,20 @@ def diffFiles(fileA, fileB):
def normalizeFilepath(line):
@@ -40,5 +40,5 @@ index 36bbdd2f..8b39679c 100755
m = langFilenameParser.match(line)
--
-2.35.1
+2.38.1
diff --git a/PKGBUILD b/PKGBUILD
index 126fa85ffe86..cc1a702ac779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Bart Verhagen <barrie.verhagen at gmail dot com>
pkgname=catch2-git
-pkgver=3.0.0.preview4.r48.g81f612c9
+pkgver=3.1.1.r45.gb65c0e27
pkgrel=1
pkgdesc="Modern, C++-native, header-only, test framework for unit-tests, TDD and BDD (developmental version)"
arch=('x86_64')
@@ -23,8 +23,8 @@ source=(
"0002-ApprovalTests-fix-path-rewriting-for-debug-builds.patch"
)
sha256sums=('SKIP'
- '6bf9e7322a4a4399b483118e4c5bea1a0a214aca5938f687cf2f44bfb7b9b3fe'
- '8c25aa44ad638eed275190c2850ede73c626ecabf4d8bd176e8d707d04c4a74a')
+ 'd26bd252d163e4648217c942bc5a9ac36edba6a151759edd57597ae437866d8e'
+ '72fd49a773699f85eb0954074231c9229ee442c58e2c4e476c25d4ce2328381b')
pkgver() {
cd Catch2
@@ -55,7 +55,7 @@ build() {
check() {
# dbgsrcdir needs to be passed to the testsuite, since it does some pathname mangling that is
# broken by -ffile-prefix-map - see 0002-ApprovalTests-fix-path-rewriting-for-debug-builds.patch
- dbgsrcdir="${DBGSRCDIR:-/usr/src/debug}" make -C build test
+ dbgsrcdir="${DBGSRCDIR:-/usr/src/debug}/$pkgbase" make -C build test
}
package() {