summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStar Brilliant2015-06-16 02:24:47 +0800
committerStar Brilliant2015-06-16 02:24:47 +0800
commit5f12f365ae5b45533209250e54ba8dec60accbc3 (patch)
tree2873ba5b32bc268846f0136b60e3ae6b40023ce2
downloadaur-catlooking-git.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c2b4ecaf6d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = catlooking-git
+ pkgdesc = A text writer with clear and simple interface allowing you to concentrate on your text
+ pkgver = 20130526
+ pkgrel = 1
+ url = http://catlooking.com/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt4
+ provides = catlooking
+ conflicts = catlooking
+ source = git://github.com/sychev/catlooking.git
+ md5sums = SKIP
+
+pkgname = catlooking-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5928fb4d6a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
+
+pkgname=catlooking-git
+pkgver=20130526
+pkgrel=1
+pkgdesc="A text writer with clear and simple interface allowing you to concentrate on your text"
+arch=('i686' 'x86_64')
+url="http://catlooking.com/"
+license=('GPL3')
+depends=('qt4')
+makedepends=('git')
+provides=('catlooking')
+conflicts=('catlooking')
+source=('git://github.com/sychev/catlooking.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/catlooking"
+ git log -1 --format="%cd" --date=short | tr -d -
+}
+
+build() {
+ cd "$srcdir/catlooking"
+ qmake-qt4
+ make
+}
+
+package() {
+ cat "$srcdir/catlooking/debian/install" | sed -e 's/^\(.*\)\/\([^\/]*\) \(.*\)$/install -Dm0644 "$srcdir\/catlooking\/\1\/\2" "$pkgdir\/\3\/\2"/g' | srcdir="$srcdir" pkgdir="$pkgdir" sh
+ chmod 755 "$pkgdir/usr/bin/catlooking"
+}