summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKikooDX2020-12-29 11:48:57 +0100
committerKikooDX2020-12-29 11:48:57 +0100
commit43f675b6cb169feab9cbd78c913f7bc9f8bde2fe (patch)
tree6749253e96be5fe846ac01ddee96cd507e69f7f5
downloadaur-cazy-git.tar.gz
First commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53c53a1415c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cazy-git
+ pkgdesc = Tool to build and transfer Casio add-ins using gint and fxsdk.
+ pkgver = r5.cabf574
+ pkgrel = 1
+ url = https://gitea.planet-casio.com/KikooDX/cazy
+ arch = any
+ license = 0BSD
+ makedepends = git
+ depends = bash
+ optdepends = gint-devel-git
+ provides = cazy
+ conflicts = cazy
+ source = git+https://gitea.planet-casio.com/KikooDX/cazy.git
+ sha256sums = SKIP
+
+pkgname = cazy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c16ef0b6779c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: KikooDX <kikoodx@paranoici.org>
+# Based on bashmount-git package maintened by caltlgin
+
+_pkgname='cazy'
+pkgname="${_pkgname}-git"
+pkgver=r5.cabf574
+pkgrel=1
+pkgdesc='Tool to build and transfer Casio add-ins using gint and fxsdk.'
+arch=('any')
+url='https://gitea.planet-casio.com/KikooDX/cazy'
+license=('0BSD')
+depends=('bash')
+makedepends=('git')
+optdepends=('gint-devel-git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+#backup=("etc/${_pkgname}.conf")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${_pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.md'
+}
+
+# vim: ts=2 sw=2 et: