summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2015-07-10 11:34:57 +0500
committerDmitry Kharitonov2015-07-10 11:34:57 +0500
commitd61ce00b840b405edb5d5e22e4e971b68e6eacc3 (patch)
tree4d06e099c60fd7131bd17e9292ae7c5ef236d660
downloadaur-d61ce00b840b405edb5d5e22e4e971b68e6eacc3.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--cb2bib.install11
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a62c49929345
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cb2bib
+ pkgdesc = A tool for parsing clipboard data into BibTeX bibliographic database files
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://www.molspaces.com/cb2bib/
+ install = cb2bib.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = desktop-file-utils
+ depends = lzo2
+ depends = qt4
+ optdepends = openssl: network reference query support
+ optdepends = perl-image-exiftool: meta data support
+ optdepends = texlive-core: file correctness checking; bib2pdf printing
+ optdepends = xpdf: pdftotext support
+ source = http://www.molspaces.com/dl/progs/cb2bib-1.5.0.tar.gz
+ sha256sums = e5eae392c9223889fb21c5a656b014d5a81a333c5378196075a985233885f3b9
+
+pkgname = cb2bib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f851fff43474
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Egon Geerardyn < egon DOT geerardyn AT gmail DOT com >
+# Contributor: TDY <tdy@gmx.com>
+
+pkgname=cb2bib
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="A tool for parsing clipboard data into BibTeX bibliographic database files"
+arch=('i686' 'x86_64')
+url="http://www.molspaces.com/cb2bib/"
+license=('GPL3')
+depends=('desktop-file-utils' 'lzo2' 'qt4')
+optdepends=('openssl: network reference query support'
+ 'perl-image-exiftool: meta data support'
+ 'texlive-core: file correctness checking; bib2pdf printing'
+ 'xpdf: pdftotext support')
+install=cb2bib.install
+source=(http://www.molspaces.com/dl/progs/$pkgname-$pkgver.tar.gz)
+sha256sums=('e5eae392c9223889fb21c5a656b014d5a81a333c5378196075a985233885f3b9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix /usr --qmakepath /usr/bin/qmake-qt4
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+}
diff --git a/cb2bib.install b/cb2bib.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/cb2bib.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}