summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValère Monseur2015-08-04 00:31:27 +0200
committerValère Monseur2015-08-04 00:31:27 +0200
commit49e38575c5f5e43925d0df5d9db6307f6c2e2801 (patch)
treec4f3519e24f4d307ea7eedc27f1aff1aab1e4432
downloadaur-cbmbasic-git.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
-rw-r--r--license33
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43988d075476
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cbmbasic-git
+ pkgdesc = A 100% compatible version of Commodore's version of Microsoft BASIC 6502
+ pkgver = 0.r17.89093eb
+ pkgrel = 1
+ url = https://github.com/mist64/cbmbasic/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = glibc
+ provides = cbmbasic
+ conflicts = cbmbasic
+ source = cbmbasic::git+https://github.com/mist64/cbmbasic.git
+ source = license
+ md5sums = SKIP
+ md5sums = 75bfb930010784e9cacecac750607738
+
+pkgname = cbmbasic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0c031a87748
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Manalishi <manalishi at freenet dot de>
+# Maintainer: Valère Monseur <valere dot monseur at ymail dot com>
+
+_pkgname=cbmbasic
+pkgname=cbmbasic-git
+pkgver=0.r17.89093eb
+pkgrel=1
+pkgdesc="A 100% compatible version of Commodore's version of Microsoft BASIC 6502"
+arch=('i686' 'x86_64')
+url='https://github.com/mist64/cbmbasic/'
+license=('custom')
+depends=('glibc')
+makedepends=('git')
+provides=('cbmbasic')
+conflicts=('cbmbasic')
+source=("${_pkgname}"::'git+https://github.com/mist64/cbmbasic.git'
+ 'license')
+md5sums=('SKIP'
+ '75bfb930010784e9cacecac750607738')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm755 "${_pkgname}"/cbmbasic "${pkgdir}"/usr/bin/cbmbasic
+ install -dm755 "${pkgdir}"/usr/share/"${_pkgname}"
+ install -m644 "${_pkgname}"/test/*.bas "${pkgdir}"/usr/share/"${_pkgname}"
+ install -Dm644 license "${pkgdir}"/usr/share/licenses/"${_pkgname}"/license
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..b062952dd7a2
--- /dev/null
+++ b/license
@@ -0,0 +1,33 @@
+Copied from README.md
+
+Feel free to use this project for any purpose, give credit if you like,
+and send back improvements to the authors, if you like, so that others
+can benefit from it. See source for license details.
+
+Copied from cbmbasic.c:
+
+/*
+ * Copyright (c) 2009 Michael Steil, James Abbatiello
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */