summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-09-19 00:01:05 +0200
committerJose Riha2021-09-19 00:01:05 +0200
commit1a8e54e313f4779040906e94f546fb9fdaaf9823 (patch)
tree431579805c2ff295d1705c1d54d3e8e0bd3e411c
parent08aa53602eb548bcd4c5864e7caf57dea9a8c603 (diff)
downloadaur-ccfe.tar.gz
Fix directories
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD6
-rw-r--r--install.patch130
3 files changed, 92 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d045351ccb61..ec661dfea066 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ccfe
pkgdesc = Tool to supply an interactive screen-oriented interface to command line scripts and commands
pkgver = 1.58
- pkgrel = 1
+ pkgrel = 2
url = http://ccfe.altervista.org
arch = any
license = GPL2
@@ -11,6 +11,6 @@ pkgbase = ccfe
source = install.patch
md5sums = 043617fe5331776a8aa600e505d5fdfa
md5sums = 9f78a2fa9c90676d60fa9cae28393733
- md5sums = 4ce34496f93ce68a7f0bde297d18acfd
+ md5sums = 2c95353b53b3399ac9317a7a6fd299a4
pkgname = ccfe
diff --git a/PKGBUILD b/PKGBUILD
index 4fa746b8a58e..fa3e104b3fcb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ccfe
pkgver=1.58
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to supply an interactive screen-oriented interface to command line scripts and commands"
url="http://ccfe.altervista.org"
arch=('any')
@@ -13,7 +13,7 @@ source=("${pkgname}.tar.gz::http://ccfe.altervista.org/dnload/dnload.php?fname=$
md5sums=('043617fe5331776a8aa600e505d5fdfa'
'9f78a2fa9c90676d60fa9cae28393733'
- '4ce34496f93ce68a7f0bde297d18acfd')
+ '2c95353b53b3399ac9317a7a6fd299a4')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -21,7 +21,7 @@ package() {
./install.sh -b -p "${pkgdir}/usr" \
-c "${pkgdir}/etc/${pkgname}" \
-o "${pkgdir}/var/log/${pkgname}" \
- -d "${pkgdir}/usr/share/doc" \
+ -d "${pkgdir}/usr/share/doc/${pkgname}" \
-a "${pkgdir}/usr/share/man" \
-m "${pkgdir}/usr/share/${pkgname}/msg"
install -D -m644 "${srcdir}/ccfeinstall.conf" "${pkgdir}/etc/${pkgname}/ccfeinstall.conf"
diff --git a/install.patch b/install.patch
index 1cf7acdf84cb..d77bdbf9ee2a 100644
--- a/install.patch
+++ b/install.patch
@@ -1,43 +1,87 @@
-79,80c79,80
-< - directory ${LIBDIR}/ccfe/ccfe.menu (the previous test menu)
-< - file ${LIBDIR}/ccfe/it_works.txt (this file)
----
-> - directory /usr/lib/ccfe/ccfe.menu (the previous test menu)
-> - file /usr/lib/ccfe/it_works.txt (this file)
-121a122,128
-> exp_etcdir="\/etc\/ccfe"
-> exp_bindir="\/usr\/bin"
-> exp_libdir="\/usr\/lib"
-> exp_logdir="\/var\/log\/ccfe"
-> exp_msgdir="\/usr\/share\/ccfe\/msg"
-> exp_docdir="\/usr\/share\/doc"
->
-158,167c165,174
-< cat <<EOT > "$ETCDIR/$SAVED_INFO"
-< # Installed on $(date)
-< ETCDIR="$ETCDIR"
-< BINDIR="$BINDIR"
-< LIBDIR="$LIBDIR"
-< LOGDIR="$LOGDIR"
-< MSGDIR="$MSGDIR"
-< MANDIR="$MANDIR"
-< DOCDIR="$DOCDIR"
-< EOT
----
-> #cat <<EOT > "$ETCDIR/$SAVED_INFO"
-> ## Installed on $(date)
-> #ETCDIR="$ETCDIR"
-> #BINDIR="$BINDIR"
-> #LIBDIR="$LIBDIR"
-> #LOGDIR="$LOGDIR"
-> #MSGDIR="$MSGDIR"
-> #MANDIR="$MANDIR"
-> #DOCDIR="$DOCDIR"
-> #EOT
-316,321d322
-< exp_etcdir=$(echo $ETCDIR | sed -e 's/\//\\\//g')
-< exp_bindir=$(echo $BINDIR | sed -e 's/\//\\\//g')
-< exp_libdir=$(echo $LIBDIR | sed -e 's/\//\\\//g')
-< exp_logdir=$(echo $LOGDIR | sed -e 's/\//\\\//g')
-< exp_msgdir=$(echo $MSGDIR | sed -e 's/\//\\\//g')
-< exp_docdir=$(echo $DOCDIR | sed -e 's/\//\\\//g')
+diff -aur src.orig/ccfe-1.58/install.sh src/ccfe-1.58/install.sh
+--- src.orig/ccfe-1.58/install.sh 2021-09-18 23:45:22.434752742 +0200
++++ src/ccfe-1.58/install.sh 2021-09-18 23:59:34.092535077 +0200
+@@ -95,23 +95,23 @@
+ IT WORKS!!!
+
+ Please remove the following objects:
+- - directory ${LIBDIR}/ccfe/ccfe.menu (the previous test menu)
+- - file ${LIBDIR}/ccfe/it_works.txt (this file)
++ - directory /usr/lib/ccfe/ccfe.menu (the previous test menu)
++ - file /usr/lib/ccfe/it_works.txt (this file)
+
+ The demo menu will still be available running the command
+
+- ${BINDIR}/ccfe demo
++ /usr/bin/ccfe demo
+
+ but if you want to remove it, you have to delete the following directories:
+- ${LIBDIR}/ccfe/demo.menu
+- ${LIBDIR}/ccfe/demo.d
++ /usr/lib/ccfe/demo.menu
++ /usr/lib/ccfe/demo.d
+
+ CCFE demos uses /bin/sh as shell interpreter, and they assume that it is a
+ Bourne compatible shell. If it is not like this, please change the CCFE shell
+- in the ${ETCDIR}/ccfe.conf file.
++ in the /etc/ccfe.conf file.
+
+ You can find documentation, samples and Licensing Information in the
+- directory ${DOCDIR}.
++ directory /usr/share/doc/ccfe.
+
+
+ Enjoy!
+@@ -138,6 +138,13 @@
+ fi
+
+ echo "Copying program files..."
++ exp_etcdir="\/etc\/ccfe"
++ exp_bindir="\/usr\/bin"
++ exp_libdir="\/usr\/lib"
++ exp_logdir="\/var\/log\/ccfe"
++ exp_msgdir="\/usr\/share\/ccfe\/msg"
++ exp_docdir="\/usr\/share\/doc"
++
+ sed -e "/^\$PREFIX = /d ; s/^\$ETCDIR = .*$/\$ETCDIR = '$exp_etcdir';/ ; s/^\$BINDIR = .*$/\$BINDIR = '$exp_bindir';/ ;s/^\$LIBDIR = .*$/\$LIBDIR = '$exp_libdir';/ ;s/^\$LOGDIR = .*$/\$LOGDIR = '$exp_logdir';/ ;s/^\$MSGDIR = .*$/\$MSGDIR = '$exp_msgdir';/ ;" ccfe.pl > $BINDIR/ccfe
+ chmod 755 $BINDIR/ccfe
+
+@@ -175,16 +182,16 @@
+ if [ $update -eq 0 ]; then
+ # Save subdirs for future uninstall option:
+ echo "Saving install informations..."
+- cat <<EOT > "$ETCDIR/$SAVED_INFO"
+-# Installed on $(date)
+-ETCDIR="$ETCDIR"
+-BINDIR="$BINDIR"
+-LIBDIR="$LIBDIR"
+-LOGDIR="$LOGDIR"
+-MSGDIR="$MSGDIR"
+-MANDIR="$MANDIR"
+-DOCDIR="$DOCDIR"
+-EOT
++ #cat <<EOT > "$ETCDIR/$SAVED_INFO"
++## Installed on $(date)
++#ETCDIR="$ETCDIR"
++#BINDIR="$BINDIR"
++#LIBDIR="$LIBDIR"
++#LOGDIR="$LOGDIR"
++#MSGDIR="$MSGDIR"
++#MANDIR="$MANDIR"
++#DOCDIR="$DOCDIR"
++#EOT
+ fi
+ echo "Done."
+ }
+@@ -333,11 +340,5 @@
+
+ if [ \( "$keybuff" = 'S' -o "$keybuff" = 's' \) -o $batch -eq 1 ]
+ then
+- exp_etcdir=$(echo $ETCDIR | sed -e 's/\//\\\//g')
+- exp_bindir=$(echo $BINDIR | sed -e 's/\//\\\//g')
+- exp_libdir=$(echo $LIBDIR | sed -e 's/\//\\\//g')
+- exp_logdir=$(echo $LOGDIR | sed -e 's/\//\\\//g')
+- exp_msgdir=$(echo $MSGDIR | sed -e 's/\//\\\//g')
+- exp_docdir=$(echo $DOCDIR | sed -e 's/\//\\\//g')
+ install
+ fi