summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 16:32:07 +0200
committerMattias Andrée2015-06-11 16:32:07 +0200
commita3f50a62e40043395ea8e8d4c774c928d1a5da34 (patch)
tree192e47ff6d2756f112d3d6113a74383fc5f1d1d0
downloadaur-cedilla.tar.gz
Initial import, version 0.7
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7141e27b19b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cedilla
+ pkgdesc = A simple text printer that uses Unicode internally
+ pkgver = 0.7
+ pkgrel = 1
+ url = http://www.pps.jussieu.fr/~jch/software/cedilla/
+ arch = any
+ license = GPL
+ depends = clisp
+ depends = texlive-core
+ source = http://www.pps.jussieu.fr/~jch/software/files/cedilla-0.7.tar.gz
+ md5sums = 57d2a80d3fd8fdc72827ada5e6257be2
+
+pkgname = cedilla
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ebfdfe5db38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=cedilla
+pkgver=0.7
+pkgrel=1
+pkgdesc="A simple text printer that uses Unicode internally"
+arch=(any)
+url="http://www.pps.jussieu.fr/~jch/software/cedilla/"
+license=('GPL')
+depends=(clisp texlive-core)
+makedepends=()
+source=(http://www.pps.jussieu.fr/~jch/software/files/$pkgname-$pkgver.tar.gz)
+md5sums=('57d2a80d3fd8fdc72827ada5e6257be2')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./compile-cedilla
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # the install-cedilla script would not find the man path in fakeroot, so
+ # we need to create the dirs for it
+ source cedilla-config
+ mkdir -p $pkgdir/$MANDIR
+
+ TARGET=$pkgdir ./install-cedilla
+ sed -i -e 's/texmf-tetex/texmf-dist/g' $pkgdir/etc/cedilla-config.lisp
+}
+