summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2017-11-03 01:11:05 +0100
committerCarsten Teibes2017-11-03 01:11:05 +0100
commitc908e33ed25178ca7fd353c5962519f5531e5d24 (patch)
tree8ca8b6bec9ce7e89b28e4565761ec003da48cb98
parent047f6efd30c524b6a4900b9ad03b575e5a135f5b (diff)
downloadaur-cegui-0.7.tar.gz
[fix] compilation
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
-rw-r--r--cegui-0.7-compilation-fix.diff85
3 files changed, 106 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 319c8f68b471..732e20bd4a01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = cegui-0.7
pkgdesc = A free library providing windowing and widgets for graphics APIs/engines (legacy version)
pkgver = 0.7.9
- pkgrel = 4
- url = http://crayzedsgui.sourceforge.net
+ pkgrel = 5
+ url = http://cegui.org.uk
arch = i686
arch = x86_64
license = MIT
@@ -21,14 +21,15 @@ pkgbase = cegui-0.7
depends = mesa
depends = glm
depends = glfw
+ depends = freeimage
optdepends = python2: python bindings
- optdepends = boost-libs: null renderer with python2
+ optdepends = boost-libs: renderer with python2
optdepends = gtk2: gtk2 module
- provides = cegui
conflicts = cegui
- options = !libtool
source = http://downloads.sourceforge.net/crayzedsgui/CEGUI-0.7.9.tar.gz
+ source = cegui-0.7-compilation-fix.diff
sha256sums = 7c3b264def08b46de749c2acaba363e907479d924612436f3bd09da2e474bb8c
+ sha256sums = 95b747470a2419bc9d0df7ade7d45ef0acb694609172d3b4110c1836b256ca39
pkgname = cegui-0.7
diff --git a/PKGBUILD b/PKGBUILD
index 587d94ceee2b..d8d58272374d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,34 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: josephgbr <rafael.f.f1@gmail.com>
-# based on cegui from Arch Linux repository, original credits go to:
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Contributor: Juergen Hoetzel <juergen@archlinux.org>
-# Contributor: William Rea <sillywilly@gmail.com>,
-# Contributor: Bjorn Lindeijer <bjorn@lindeijer.nl>
-
pkgname=cegui-0.7
pkgver=0.7.9
-pkgrel=4
+pkgrel=5
pkgdesc="A free library providing windowing and widgets for graphics APIs/engines (legacy version)"
arch=('i686' 'x86_64')
-url="http://crayzedsgui.sourceforge.net"
+url="http://cegui.org.uk"
license=("MIT")
-depends=('glew' 'freetype2' 'libxml2' 'devil' 'freeglut' 'lua51' 'silly' 'mesa' 'glm' 'glfw')
-makedepends=('python2' 'doxygen' 'gtk2' 'boost' 'graphviz') # 'ogre' 'irrlicht')
+depends=('glew' 'freetype2' 'libxml2' 'devil' 'freeglut' 'lua51' 'silly' 'mesa' 'glm' 'glfw' 'freeimage')
+makedepends=('python2' 'doxygen' 'gtk2' 'boost' 'graphviz')
optdepends=("python2: python bindings"
- "boost-libs: null renderer with python2"
- #"ogre: ogre module"
- #"irrlicht: irrlicht module"
+ "boost-libs: renderer with python2"
"gtk2: gtk2 module")
-provides=('cegui')
conflicts=('cegui')
-options=('!libtool')
-source=("http://downloads.sourceforge.net/crayzedsgui/CEGUI-$pkgver.tar.gz")
-sha256sums=('7c3b264def08b46de749c2acaba363e907479d924612436f3bd09da2e474bb8c')
+source=("http://downloads.sourceforge.net/crayzedsgui/CEGUI-$pkgver.tar.gz"
+ "$pkgname-compilation-fix.diff")
+sha256sums=('7c3b264def08b46de749c2acaba363e907479d924612436f3bd09da2e474bb8c'
+ '95b747470a2419bc9d0df7ade7d45ef0acb694609172d3b4110c1836b256ca39')
+
+prepare() {
+ patch -Np0 < $pkgname-compilation-fix.diff
+}
build() {
cd CEGUI-$pkgver
./bootstrap
- Lua_CFLAGS="$(pkg-config --cflags lua5.1)" \
- Lua_LIBS="$(pkg-config --libs lua5.1)" \
+ Lua_CFLAGS="$(pkg-config --cflags lua51)" \
+ Lua_LIBS="$(pkg-config --libs lua51)" \
PYTHON="/usr/bin/python2" ./configure --prefix=/usr --sysconfdir=/etc \
--enable-null-renderer --with-gtk2 --disable-samples \
--disable-ogre-renderer --disable-irrlicht-renderer
diff --git a/cegui-0.7-compilation-fix.diff b/cegui-0.7-compilation-fix.diff
new file mode 100644
index 000000000000..00efcedd6aee
--- /dev/null
+++ b/cegui-0.7-compilation-fix.diff
@@ -0,0 +1,85 @@
+diff --color -Naur CEGUI-0.7.9.old/cegui/include/CEGUISystem.h CEGUI-0.7.9/cegui/include/CEGUISystem.h
+--- CEGUI-0.7.9.old/cegui/include/CEGUISystem.h 2013-01-12 18:07:24.000000000 +0100
++++ CEGUI-0.7.9/cegui/include/CEGUISystem.h 2017-11-03 00:10:40.105586714 +0100
+@@ -1123,12 +1123,6 @@
+ ScriptModule* scriptModule, const String& configFile,
+ const String& logFile);
+
+- /*!
+- \brief
+- Destructor for System objects.
+- */
+- ~System(void);
+-
+ /*!
+ \brief
+ Given Point \a pt, return a pointer to the Window that should receive a mouse input if \a pt is the mouse location.
+@@ -1364,6 +1358,13 @@
+ RenderedStringParser* d_customRenderedStringParser;
+ //! true if mouse click events will be automatically generated.
+ bool d_generateMouseClickEvents;
++
++protected:
++ /*!
++ \brief
++ Destructor for System objects.
++ */
++ ~System(void);
+ };
+
+ } // End of CEGUI namespace section
+diff --color -Naur CEGUI-0.7.9.old/cegui/include/RendererModules/OpenGL/CEGUIOpenGLRenderer.h CEGUI-0.7.9/cegui/include/RendererModules/OpenGL/CEGUIOpenGLRenderer.h
+--- CEGUI-0.7.9.old/cegui/include/RendererModules/OpenGL/CEGUIOpenGLRenderer.h 2013-01-12 18:07:24.000000000 +0100
++++ CEGUI-0.7.9/cegui/include/RendererModules/OpenGL/CEGUIOpenGLRenderer.h 2017-11-03 00:10:56.968556323 +0100
+@@ -291,12 +291,6 @@
+ */
+ OpenGLRenderer(const Size& display_size, const TextureTargetType tt_type);
+
+- /*!
+- \brief
+- Destructor for OpenGLRenderer objects
+- */
+- virtual ~OpenGLRenderer();
+-
+ //! init the extra GL states enabled via enableExtraStateSettings
+ void setupExtraStates();
+
+@@ -336,6 +330,13 @@
+ OGLTextureTargetFactory* d_textureTargetFactory;
+ //! What blend mode we think is active.
+ BlendMode d_activeBlendMode;
++
++protected:
++ /*!
++ \brief
++ Destructor for OpenGLRenderer objects
++ */
++ virtual ~OpenGLRenderer();
+ };
+
+ } // End of CEGUI namespace section
+diff --color -Naur CEGUI-0.7.9.old/cegui/src/XMLParserModules/TinyXMLParser/CEGUITinyXMLParser.cpp CEGUI-0.7.9/cegui/src/XMLParserModules/TinyXMLParser/CEGUITinyXMLParser.cpp
+--- CEGUI-0.7.9.old/cegui/src/XMLParserModules/TinyXMLParser/CEGUITinyXMLParser.cpp 2013-01-12 18:07:24.000000000 +0100
++++ CEGUI-0.7.9/cegui/src/XMLParserModules/TinyXMLParser/CEGUITinyXMLParser.cpp 2017-11-03 00:37:06.384155617 +0100
+@@ -145,7 +145,7 @@
+ processElement(childNode->ToElement());
+ break;
+ case CEGUI_TINYXML_NAMESPACE::TiXmlNode::CEGUI_TINYXML_TEXT:
+- if (childNode->ToText()->Value() != '\0')
++ if (childNode->ToText()->Value() != NULL)
+ d_handler->text((utf8*)childNode->ToText()->Value());
+ break;
+
+diff --color -Naur CEGUI-0.7.9.old/configure.ac CEGUI-0.7.9/configure.ac
+--- CEGUI-0.7.9.old/configure.ac 2013-01-12 18:07:24.000000000 +0100
++++ CEGUI-0.7.9/configure.ac 2017-11-03 00:53:07.011026565 +0100
+@@ -14,7 +14,8 @@
+
+ AC_INIT([CEGUI], [CEGUI_RELEASE_VERSION], [http://mantis.cegui.org.uk/], [CEGUI])
+ AC_CONFIG_SRCDIR([cegui/src/CEGUIBase.cpp])
+-AM_INIT_AUTOMAKE([dist-zip tar-ustar])
++AM_INIT_AUTOMAKE([dist-zip tar-ustar subdir-objects])
++AM_SILENT_RULES([yes])
+ AC_CONFIG_HEADER([cegui/include/config.h])
+ AC_CANONICAL_HOST
+