summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Hannen2014-05-30 21:41:48 +0200
committerIdo Rosen2014-06-29 08:53:07 -0400
commit83b7ea5c494ac98afca41bf7cfbf024331782576 (patch)
tree473d29ce08c8a636f5a6a351a63791223589fe38
parent5271d34c4b2b91b53c43c4e8646a8748a1b8d0a2 (diff)
downloadaur-83b7ea5c494ac98afca41bf7cfbf024331782576.tar.gz
This fixes the Issue with Ceph 0.80 not compiling
Upstream started using sub-modules to build Ceph. So this enables the compilation again. Not sure if this is enough for being mentioned in a "Contributor" line, feel free to remove that if you want.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a619b0c8737..d3e2b5a08382 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ceph-git
pkgdesc = Distributed, fault-tolerant file system delivering object, block, and file storage in one unified system.
- pkgver = 0.72.255.g574cb61
+ pkgver = 0.80.693.g3b884be
pkgrel = 1
epoch = 1
url = http://ceph.newdream.net/
diff --git a/PKGBUILD b/PKGBUILD
index 79e9515c2729..a2050f93ab1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@
# Contributor: Sandman <the0sandman@hotmail.com>
# Contributor: raw <spam@rw23.de>
# Contributor: Dave Simons <miouhpi@gmail.com>
+# Contributor: Dominik Hannen <cantares1+github@gmail.com>
#
# NOTE: To request changes to this package, please submit a pull request
# to the GitHub repository at https://github.com/ido/packages-archlinux
@@ -14,7 +15,7 @@
#
pkgname=ceph-git
-pkgver=0.72.255.g574cb61
+pkgver=0.80.693.g3b884be
pkgrel=1
epoch=1
pkgdesc='Distributed, fault-tolerant file system delivering object, block, and file storage in one unified system.'
@@ -62,6 +63,20 @@ prepare() {
build() {
cd "${srcdir}/${pkgname%%-git}"
+ git clean -fdx && git reset --hard
+ git submodule foreach 'git clean -fdx && git reset --hard'
+ rm -rf ceph-object-corpus
+ rm -rf src/leveldb
+ rm -rf src/libs3
+ rm -rf src/mongoose
+ rm -rf src/civetweb
+ rm -rf src/erasure-code/jerasure/gf-complete
+ rm -rf src/erasure-code/jerasure/jerasure
+ rm -rf .git/modules/
+ git submodule sync
+ git submodule update --init
+ git clean -fdx
+
./autogen.sh
LIBS="-lpthread -lboost_system" ./configure \
--prefix=/usr \