summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 19:07:25 +0200
committerMattias Andrée2015-06-11 19:07:25 +0200
commite749a055193ac031dfe4bc90f5c5374058699c5b (patch)
tree4a52f99dd32f68b8b5156212b93559adc16ebfc9
downloadaur-cerberus-logging.tar.gz
Initial import, version 1428445270
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
-rw-r--r--cerberus-logging.install20
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cdba1b3cdc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = cerberus-logging
+ pkgdesc = Log-in logging extension for cerberus
+ pkgver = 1428445270
+ pkgrel = 1
+ url = https://github.com/GNU-Pony/cerberus-logging
+ install = cerberus-logging.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = make
+ makedepends = coreutils
+ makedepends = gcc
+ makedepends = glibc
+ makedepends = audit
+ makedepends = texinfo
+ depends = glibc
+ depends = coreutils
+ depends = sh
+ optdepends = audit: for logging with audit
+ source = https://github.com/GNU-Pony/cerberus-logging/archive/1428445270.tar.gz
+ sha256sums = fedb5423eef21f108f1a293c17e625a3e49be9b891737b65b1284b6817ef59f1
+
+pkgname = cerberus-logging
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ad201a1ca46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=cerberus-logging
+pkgver=1428445270
+pkgrel=1
+pkgdesc="Log-in logging extension for cerberus"
+url="https://github.com/GNU-Pony/cerberus-logging"
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(glibc coreutils sh)
+optdepends=('audit: for logging with audit')
+makedepends=(make coreutils gcc glibc audit texinfo)
+install=cerberus-logging.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(fedb5423eef21f108f1a293c17e625a3e49be9b891737b65b1284b6817ef59f1)
+
+build() {
+ cd "${srcdir}/cerberus-logging-${pkgver}"
+
+ LDFLAGS= make PKGNAME="${pkgname}" info btmp utmp lastlog syslog audit
+}
+
+package() {
+ cd "${srcdir}/cerberus-logging-${pkgver}"
+
+ make PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install-base install-info \
+ install-btmp install-utmp install-lastlog install-syslog install-audit
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+
diff --git a/cerberus-logging.install b/cerberus-logging.install
new file mode 100644
index 000000000000..dd40e58d51c2
--- /dev/null
+++ b/cerberus-logging.install
@@ -0,0 +1,20 @@
+_file="cerberus-logging"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+