summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2023-09-16 09:25:20 +0200
committerRasmus Karlsson2023-09-16 09:25:20 +0200
commit0364f416873502bda4a3a1ea8003db87729e6800 (patch)
treee6f15a74ffb9619923891e2358b7266db2a663fe
parenta87578d9475c53f85280936aace93cfaa99408ca (diff)
downloadaur-0364f416873502bda4a3a1ea8003db87729e6800.tar.gz
Forward `-flto` flag to Chatterino
Thanks @sunred
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile7
-rw-r--r--PKGBUILD7
3 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b58fddccfadb..fec601235c91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-git
pkgdesc = Second installment of the Twitch chat client series "Chatterino", dev/git version
- pkgver = v2.4.5.r0.g05a72d335
+ pkgver = v2.4.5.r24.g2d5f07830
pkgrel = 1
url = https://chatterino.com
install = chatterino2-git.install
diff --git a/Makefile b/Makefile
index 54240e24aa55..ddaadea323a4 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,12 @@ srcinfo:
makepkg --printsrcinfo > .SRCINFO
clean:
- rm -rf pkg src chatterino2/ chatterino2-*.pkg.tar.xz \
+ rm -rf \
+ pkg \
+ src \
+ chatterino2 \
+ chatterino2-*.pkg.tar.xz \
+ chatterino2-*.pkg.tar.zst \
libcommuni \
humanize \
crashpad \
diff --git a/PKGBUILD b/PKGBUILD
index 09830383a116..d938f11453a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ckat <ckat@teknik.io>
pkgname=chatterino2-git
_pkgname=chatterino2
-pkgver=v2.4.5.r0.g05a72d335
+pkgver=v2.4.5.r24.g2d5f07830
pkgrel=1
pkgdesc='Second installment of the Twitch chat client series "Chatterino", dev/git version'
arch=('any')
@@ -67,10 +67,15 @@ build() {
cd "$srcdir/chatterino2"
mkdir -p build
cd build
+ declare -a flags
+ if [[ $CXXFLAGS == *"-flto"* ]]; then
+ flags+=("-DCHATTERINO_LTO=ON")
+ fi
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DUSE_SYSTEM_QTKEYCHAIN=ON \
-DUSE_PRECOMPILED_HEADERS=OFF \
+ "${flags[@]}" \
..
cmake --build .
}