summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2022-05-22 16:43:51 +0200
committerRasmus Karlsson2022-05-22 16:43:51 +0200
commitfcbcb898d3cf221f219fd5e2b4fe1e2ed37e94fa (patch)
tree0a26a07e28cf3026e4adb46f36aacd8517345e57
parent745c7be6f84ef4c5023edcc2733dd7fa56048905 (diff)
downloadaur-fcbcb898d3cf221f219fd5e2b4fe1e2ed37e94fa.tar.gz
Add googletest submodule
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile3
-rw-r--r--PKGBUILD7
3 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 679ee02ef172..10f88ad92333 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-git
pkgdesc = Second installment of the Twitch chat client series "Chatterino", dev/git version
- pkgver = r3508.f97780d8
+ pkgver = r3535.7d9c3c65
pkgrel = 1
url = https://chatterino.com
install = chatterino2-git.install
@@ -32,6 +32,8 @@ pkgbase = chatterino2-git
source = git+https://github.com/arsenm/sanitizers-cmake
source = git+https://github.com/zaphoyd/websocketpp
source = git+https://github.com/Neargye/magic_enum
+ source = git+https://github.com/google/googletest.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/Makefile b/Makefile
index 4514f2ef621d..1f8d926ce47a 100644
--- a/Makefile
+++ b/Makefile
@@ -21,4 +21,5 @@ clean:
qtkeychain \
sanitizers-cmake \
websocketpp \
- magic_enum
+ magic_enum \
+ googletest
diff --git a/PKGBUILD b/PKGBUILD
index 035612aaca5b..a354c4f176f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ckat <ckat@teknik.io>
pkgname=chatterino2-git
_pkgname=chatterino2
-pkgver=r3508.f97780d8
+pkgver=r3535.7d9c3c65
pkgrel=1
pkgdesc='Second installment of the Twitch chat client series "Chatterino", dev/git version'
arch=('any')
@@ -26,7 +26,8 @@ source=("git+https://github.com/Chatterino/chatterino2"
"git+https://github.com/Chatterino/qtkeychain"
"git+https://github.com/arsenm/sanitizers-cmake"
"git+https://github.com/zaphoyd/websocketpp"
- "git+https://github.com/Neargye/magic_enum")
+ "git+https://github.com/Neargye/magic_enum"
+ "git+https://github.com/google/googletest.git")
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -38,6 +39,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -61,6 +63,7 @@ prepare () {
# We can't set the local directory of this submodule as we have no way of accessing the config name `submodule.magic_enum` because underscores are actually not allowed.
# The only thing I can think of is moving the submodule to `lib/magicenum` but that feels like an off approach. I'll look into it only if builds fail because of the below call is missing.
# git config submodule.magic_enum $srcdir/$_pkgname/lib/magic_enum
+ git config submodule.googletest $srcdir/$_pkgname/lib/googletest
git submodule update
}