summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2017-11-21 15:01:55 +0100
committerBalló György2017-11-21 15:01:55 +0100
commit6b354fd83f8e2b167f5f0268f253ac286a6823c3 (patch)
treedad70b9d883bafe5e693045ffbc8426a3fa67d32
parent1486ba2a8dbe045d78d5ec3f81ce501bd251bd1b (diff)
downloadaur-chatzilla.tar.gz
Use xulrunner instead of firefox
Firefox>=57 does not support XUL apps any more.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xchatzilla.sh2
3 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fdaf6b13c2b..b1627b152ca1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue May 9 12:55:53 UTC 2017
pkgbase = chatzilla
pkgdesc = Clean, easy to use and highly extensible Internet Relay Chat (IRC) client, built on the Mozilla platform
pkgver = 0.9.93
- pkgrel = 1
+ pkgrel = 2
url = http://chatzilla.hacksrus.com/
arch = any
license = MPL
@@ -11,7 +9,7 @@ pkgbase = chatzilla
license = LGPL
makedepends = python2
makedepends = unzip
- depends = firefox
+ depends = xulrunner
source = chatzilla-0.9.93.tar.gz::http://hg.mozilla.org/chatzilla/archive/CHATZILLA_0_9_93_RELEASE.tar.gz
source = xrmakeM.diff
source = version.patch
@@ -20,7 +18,7 @@ pkgbase = chatzilla
sha256sums = 7c03e742fb6b8ec82f884464a1129ab4f644c74824963cd7d1ebddb9c8cc7523
sha256sums = 355ff3f351eb5c38a7e04bf2e83aa5f038f937753d7acb239fe0b0aef589c351
sha256sums = 43d3299ccf6f59d0123fc57d0affc8014d46650869c6edc251cd5cb54093ffa1
- sha256sums = 0cf6529326def9bbff73b04f9abd45193c41ca3c8b44dd922739c3f969701a59
+ sha256sums = 0c6b2b68055f9c4e39e7e72a4ebfb3d4c13d439a30ca3ec8ed84109ceb16e8f1
sha256sums = 548e758a5334ea9e920fd8b21d29c0e4acd63bdd5f3c3b6eb6e5f5a79644f9cb
pkgname = chatzilla
diff --git a/PKGBUILD b/PKGBUILD
index 9351a82efb08..809c531b928e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=chatzilla
pkgver=0.9.93
_pkgver=0_9_93
-pkgrel=1
+pkgrel=2
pkgdesc='Clean, easy to use and highly extensible Internet Relay Chat (IRC) client, built on the Mozilla platform'
arch=('any')
url='http://chatzilla.hacksrus.com/'
license=('MPL' 'GPL' 'LGPL')
-depends=('firefox')
+depends=('xulrunner')
makedepends=('python2' 'unzip')
source=("$pkgname-$pkgver.tar.gz::http://hg.mozilla.org/chatzilla/archive/CHATZILLA_${_pkgver}_RELEASE.tar.gz"
"xrmakeM.diff"
@@ -19,7 +19,7 @@ source=("$pkgname-$pkgver.tar.gz::http://hg.mozilla.org/chatzilla/archive/CHATZI
sha256sums=('7c03e742fb6b8ec82f884464a1129ab4f644c74824963cd7d1ebddb9c8cc7523'
'355ff3f351eb5c38a7e04bf2e83aa5f038f937753d7acb239fe0b0aef589c351'
'43d3299ccf6f59d0123fc57d0affc8014d46650869c6edc251cd5cb54093ffa1'
- '0cf6529326def9bbff73b04f9abd45193c41ca3c8b44dd922739c3f969701a59'
+ '0c6b2b68055f9c4e39e7e72a4ebfb3d4c13d439a30ca3ec8ed84109ceb16e8f1'
'548e758a5334ea9e920fd8b21d29c0e4acd63bdd5f3c3b6eb6e5f5a79644f9cb')
prepare() {
diff --git a/chatzilla.sh b/chatzilla.sh
index 36030f161c69..60863bf1ee9b 100755
--- a/chatzilla.sh
+++ b/chatzilla.sh
@@ -1 +1 @@
-XUL_APP_FILE="/usr/share/chatzilla/application.ini" exec firefox "$@"
+XUL_APP_FILE="/usr/share/chatzilla/application.ini" exec xulrunner "$@"