summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-09-07 09:06:04 -0600
committerMark Wagie2020-09-07 09:06:04 -0600
commit5e4766111f6a194c21afd7cf28d74718379fa33a (patch)
tree32fcedb3089f68ae4b5536333fd66306c99046c0
parentac43206f3cc1ebae732fcf61ece26ceaf934d1af (diff)
downloadaur-5e4766111f6a194c21afd7cf28d74718379fa33a.tar.gz
revert using Makefile, use static commit for cheatsheets
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 815a5990bb7a..cc97f7f5d6a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
pkgver = 4.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cheat/cheat
arch = i686
arch = x86_64
@@ -21,8 +21,8 @@ pkgbase = cheat
backup = etc/cheat/conf.yml
source = cheat-4.1.0.tar.gz::https://github.com/cheat/cheat/archive/4.1.0.tar.gz
source = conf.yml
- source = git+https://github.com/cheat/cheatsheets.git
- source = https://raw.githubusercontent.com/cheat/cheatsheets/master/.github/LICENSE.txt
+ source = git+https://github.com/cheat/cheatsheets.git#commit=92db692c0fd6348793ee0641cb63d08977be90fd
+ source = https://github.com/cheat/cheat/raw/4.1.0/LICENSE.txt
sha256sums = b392c3a77eda61f4b1f0991cb30c6202f74472713293e73f645fb697665ca72c
sha256sums = a0aa691a318219d048107b835fe0e8cddfa734618fc5ccbb800b5bb463e00ea5
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d02371234694..261ba09129a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Bogdan <d0xi at inbox dot ru>
pkgname=cheat
pkgver=4.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://github.com/cheat/cheat"
@@ -14,10 +14,11 @@ optdepends=('bash-completion: for bash completions'
conflicts=("python-$pkgname" "$pkgname-bash-git")
replaces=("python-$pkgname")
backup=("etc/$pkgname/conf.yml")
+_commit='92db692c0fd6348793ee0641cb63d08977be90fd'
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
'conf.yml'
- 'git+https://github.com/cheat/cheatsheets.git'
- "https://raw.githubusercontent.com/$pkgname/cheatsheets/master/.github/LICENSE.txt")
+ "git+https://github.com/cheat/cheatsheets.git#commit=$_commit"
+ "https://github.com/cheat/cheat/raw/$pkgver/LICENSE.txt")
sha256sums=('b392c3a77eda61f4b1f0991cb30c6202f74472713293e73f645fb697665ca72c'
'a0aa691a318219d048107b835fe0e8cddfa734618fc5ccbb800b5bb463e00ea5'
'SKIP'
@@ -34,8 +35,11 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -mod=readonly -modcacherw"
- make
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -v "./cmd/$pkgname"
+
+ # Generate man page
+ pandoc -s -t man "doc/$pkgname.1.md" -o "doc/$pkgname.1"
# Clean mod cache for makepkg -C
go clean -modcache
@@ -43,7 +47,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
- install -Dm755 "dist/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
install -Dm755 "scripts/$pkgname.bash" \
"$pkgdir/usr/share/bash-completion/completions/$pkgname"
install -Dm755 "scripts/$pkgname.fish" -t "$pkgdir/usr/share/fish/completions"