summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-04-08 09:19:58 -0600
committerMark Wagie2020-04-08 09:19:58 -0600
commit7849284397aa44e94269b6e49680af01b17f095c (patch)
tree5a0487086379f6d80e1ab8b0d33f241de4348e61
parent74247224211a44695b122a9e9ca334ab41817d86 (diff)
downloadaur-7849284.tar.gz
reverted conflict with zsh-completions, don't install completion file for now
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3856ac9a149a..71e5778cfb45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
pkgver = 3.9.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/cheat/cheat
arch = arm
arch = armv6h
@@ -16,7 +16,6 @@ pkgbase = cheat
optdepends = fzf: Fuzzy Finder integration for bash-completion
conflicts = python-cheat
conflicts = cheat-bash-git
- conflicts = zsh-completions
replaces = python-cheat
backup = etc/cheat/conf.yml
source = cheat-3.9.0.tar.gz::https://github.com/cheat/cheat/archive/3.9.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 36a424019df0..40591af0d3f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Bogdan <d0xi at inbox dot ru>
pkgname=cheat
pkgver=3.9.0
-pkgrel=2
+pkgrel=3
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('arm' 'armv6h' 'armv7h' 'x86_64')
url="https://github.com/cheat/cheat"
@@ -11,7 +11,7 @@ license=('MIT' 'CC0 1.0 Universal')
makedepends=('go-pie' 'git' 'pandoc')
optdepends=('bash-completion: for bash completions'
'fzf: Fuzzy Finder integration for bash-completion')
-conflicts=("python-$pkgname" "$pkgname-bash-git" 'zsh-completions')
+conflicts=("python-$pkgname" "$pkgname-bash-git")
replaces=("python-$pkgname")
backup=("etc/$pkgname/conf.yml")
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
@@ -57,7 +57,7 @@ package() {
install -Dm755 "scripts/$pkgname.bash" \
"$pkgdir/usr/share/bash-completion/completions/$pkgname"
install -Dm755 "scripts/$pkgname.fish" -t "$pkgdir/usr/share/fish/completions"
- install -Dm755 "scripts/$pkgname.zsh" "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+# install -Dm755 "scripts/$pkgname.zsh" "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/$pkgname-LICENSE"
install -Dm644 "doc/$pkgname.1" -t "$pkgdir/usr/share/man/man1"