summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-11-05 11:57:35 -0600
committerMark Wagie2022-11-05 11:57:35 -0600
commit826ab8bd565d9562f2569d22943bb7f69f17d8ca (patch)
tree8d02739657225d1bd8559fb79073c263de6a479a
parent49730801f54df6d8135b86704e5d05e660fcaa8e (diff)
downloadaur-826ab8bd565d9562f2569d22943bb7f69f17d8ca.tar.gz
4.4.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD12
-rw-r--r--conf.yml2
3 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e447c4cc87ba..82623440053f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
- pkgver = 4.3.3
- pkgrel = 3
+ pkgver = 4.4.0
+ pkgrel = 1
url = https://github.com/cheat/cheat
arch = x86_64
arch = arm
@@ -10,7 +10,6 @@ pkgbase = cheat
arch = aarch64
license = MIT
license = CC0 1.0 Universal
- makedepends = auth-tarball-from-git
makedepends = git
makedepends = go
makedepends = pandoc
@@ -19,13 +18,13 @@ pkgbase = cheat
conflicts = python-cheat
replaces = python-cheat
backup = etc/cheat/conf.yml
- source = cheat-4.3.3.tar.gz::https://github.com/cheat/cheat/archive/refs/tags/4.3.3.tar.gz
+ source = cheat-4.4.0.tar.gz::https://github.com/cheat/cheat/archive/refs/tags/4.4.0.tar.gz
source = chris.pgp
source = conf.yml
- source = git+https://github.com/cheat/cheatsheets.git#commit=ff3e2f2fcd85b8420243559ceaebfddb761fec36
- sha256sums = 6a1739b71d436f45dc7c028ec79863a34e30cc13da7159bf23604b77f43faaf2
+ source = git+https://github.com/cheat/cheatsheets.git#commit=a005739f3cd402e015a6129c36e7c2b4911ae657
+ sha256sums = 8694d75896dcb1dfb91ed95ec37f7fe409ad2bde76e66f80b20be24ee92ae3ec
sha256sums = 6318f816e4c8f2e9c34b8dc1855adeff58c1254809b8aa86c2b39ed155f3d2b6
- sha256sums = 30df814034a3b7146232e195829564baa7c269940b40c81e1caefbbdc83744e8
+ sha256sums = 7eddb96f22a29b0d4dc1d953cdb047342495230ea3c0cb16f78a1d888e79fa8e
sha256sums = SKIP
pkgname = cheat
diff --git a/PKGBUILD b/PKGBUILD
index 26fc6a1c5662..d0a738affcf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
# Co-Maintainer: Joost Bremmer <contact at madeofmagicandwires dot online>
# Contributor: Bogdan <d0xi at inbox dot ru>
pkgname=cheat
-pkgver=4.3.3
-pkgrel=3
+pkgver=4.4.0
+pkgrel=1
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/cheat/cheat"
license=('MIT' 'CC0 1.0 Universal')
-makedepends=('auth-tarball-from-git' 'git' 'go' 'pandoc')
+makedepends=('git' 'go' 'pandoc') # 'auth-tarball-from-git'
optdepends=('bash-completion: for bash completions'
'fzf: Fuzzy Finder integration for bash-completion')
conflicts=("python-$pkgname")
replaces=("python-$pkgname")
backup=("etc/$pkgname/conf.yml")
-_commit=ff3e2f2fcd85b8420243559ceaebfddb761fec36
+_commit=a005739f3cd402e015a6129c36e7c2b4911ae657
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
'chris.pgp' # Christopher Allen Lane <chris@chris-allen-lane.com>
'conf.yml'
"git+https://github.com/cheat/cheatsheets.git#commit=$_commit")
-sha256sums=('6a1739b71d436f45dc7c028ec79863a34e30cc13da7159bf23604b77f43faaf2'
+sha256sums=('8694d75896dcb1dfb91ed95ec37f7fe409ad2bde76e66f80b20be24ee92ae3ec'
'6318f816e4c8f2e9c34b8dc1855adeff58c1254809b8aa86c2b39ed155f3d2b6'
- '30df814034a3b7146232e195829564baa7c269940b40c81e1caefbbdc83744e8'
+ '7eddb96f22a29b0d4dc1d953cdb047342495230ea3c0cb16f78a1d888e79fa8e'
'SKIP')
prepare() {
diff --git a/conf.yml b/conf.yml
index 88563cb15efc..283f525e23d8 100644
--- a/conf.yml
+++ b/conf.yml
@@ -17,7 +17,7 @@ formatter: terminal256
# Through which pager should output be piped?
# 'less -FRX' is recommended on Unix systems
# 'more' is recommended on Windows
-#pager: PAGER_PATH
+pager: less -FRX
# Cheatpaths are paths at which cheatsheets are available on your local
# filesystem.