summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-29 19:19:44 -0700
committerJoost Bremmer2020-04-10 01:36:32 +0200
commitdd4c0fcc9def2abb9bad1e871b4f83fd7b7015f8 (patch)
tree10a12bde955c82ad8b3614e59b0582e0b580235a
parentb502a04bb32606d745556ead096e662416f4434e (diff)
downloadaur-dd4c0fcc9def2abb9bad1e871b4f83fd7b7015f8.tar.gz
upgpkg: cheat 3.2.2-2
add cheatsheets license, update cheatsheets
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba6fa988efc1..d0610b150497 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = cheat
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
pkgver = 3.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cheat/cheat
arch = arm
arch = armv6h
arch = armv7h
arch = x86_64
license = MIT
+ license = CC0 1.0 Universal
makedepends = go-pie
makedepends = git
optdepends = fzf: for Fuzzy Finder integration
@@ -19,9 +20,11 @@ pkgbase = cheat
source = cheat-3.2.2.tar.gz::https://github.com/cheat/cheat/archive/3.2.2.tar.gz
source = conf.yml
source = git+https://github.com/cheat/cheatsheets.git
+ source = https://raw.githubusercontent.com/cheat/cheatsheets/master/.github/LICENSE.txt
sha256sums = 9a756b249ae9a9ea7beb2149a57a6556b145075e97c4c90b52ea6492334a5c7e
sha256sums = 1c3a6ebb65d3a91f9f9711dfaf81463f6b68b9e73fe341720946dd31b311d35b
sha256sums = SKIP
+ sha256sums = a2010f343487d3f7618affe54f789f5487602331c0a8d03f49e9a7c547cf0499
pkgname = cheat
diff --git a/PKGBUILD b/PKGBUILD
index 4aa2495eb167..c27f022148c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Co-Maintainer: Joost Bremmer <contact at madeofmagicandwires dot online>
pkgname=cheat
pkgver=3.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('arm' 'armv6h' 'armv7h' 'x86_64')
url="https://github.com/cheat/cheat"
-license=('MIT')
+license=('MIT' 'CC0 1.0 Universal')
makedepends=('go-pie' 'git')
optdepends=('fzf: for Fuzzy Finder integration'
'bash-completion: for bash completions'
@@ -16,10 +16,12 @@ conflicts=('cheat-bash-git' 'cheat-git')
replaces=('python-cheat')
source=("$pkgname-$pkgver.tar.gz::https://github.com/cheat/cheat/archive/$pkgver.tar.gz"
'conf.yml'
- 'git+https://github.com/cheat/cheatsheets.git')
+ 'git+https://github.com/cheat/cheatsheets.git'
+ 'https://raw.githubusercontent.com/cheat/cheatsheets/master/.github/LICENSE.txt')
sha256sums=('9a756b249ae9a9ea7beb2149a57a6556b145075e97c4c90b52ea6492334a5c7e'
'1c3a6ebb65d3a91f9f9711dfaf81463f6b68b9e73fe341720946dd31b311d35b'
- 'SKIP')
+ 'SKIP'
+ 'a2010f343487d3f7618affe54f789f5487602331c0a8d03f49e9a7c547cf0499')
prepare() {
@@ -58,7 +60,7 @@ package() {
"$pkgdir/usr/share/bash-completion/completions/cheat"
install -Dm755 "scripts/$pkgname-autocompletion.fish" \
"$pkgdir/usr/share/fish/completions/cheat.fish"
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/cheat-LICENSE"
install -dm755 "$pkgdir/usr/share/cheat/cheatsheets/community"
find "$srcdir/cheatsheets" \
@@ -69,4 +71,6 @@ package() {
install -m644 "{}" \
"$pkgdir/usr/share/$pkgname/cheatsheets/community/" \;
install -Dm644 "$srcdir/conf.yml" -t "$pkgdir/etc/cheat"
+ install -Dm644 "$srcdir/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/cheatsheets-LICENSE"
}