summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuan Guo2015-06-17 21:29:55 +0200
committerQuan Guo2015-06-17 21:29:55 +0200
commit100db25997b6b9a538c0e3ef6e95a35fb495897a (patch)
tree5029a1f110654f80449e48581fc08874809b9614
downloadaur-100db25997b6b9a538c0e3ef6e95a35fb495897a.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
3 files changed, 59 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d6837da4c5e2
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = cheat-git
+ pkgdesc = Cheat allows you to create and view interactive cheatsheets on the command-line
+ pkgver = 2.0.9.30.g7eb405d
+ pkgrel = 1
+ url = https://github.com/chrisallenlane/cheat
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python2
+ depends = python2-docopt
+ optdepends = python-pygments
+ source = cheat-git::git+https://github.com/chrisallenlane/cheat.git
+ md5sums = SKIP
+
+pkgname = cheat-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6837da4c5e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cheat-git
+ pkgdesc = Cheat allows you to create and view interactive cheatsheets on the command-line
+ pkgver = 2.0.9.30.g7eb405d
+ pkgrel = 1
+ url = https://github.com/chrisallenlane/cheat
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python2
+ depends = python2-docopt
+ optdepends = python-pygments
+ source = cheat-git::git+https://github.com/chrisallenlane/cheat.git
+ md5sums = SKIP
+
+pkgname = cheat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d947dfb5678
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexandr Skurikhin <askurihin@gmail.com>
+# Maintainer: Robert Orzanna <orschiro@gmail.com>
+# Maintainer: Quan Guo < guotsuan@gmail.com>
+
+pkgname=cheat-git
+pkgver=2.0.9.30.g7eb405d
+pkgrel=1
+pkgdesc="Cheat allows you to create and view interactive cheatsheets on the command-line"
+arch=('any')
+license=('GPL3')
+url="https://github.com/chrisallenlane/cheat"
+depends=('python2' 'python2-docopt')
+optdepends=('python-pygments')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/chrisallenlane/cheat.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $pkgname
+ git describe | sed 's/^v//;s/-/./g'
+}
+
+package(){
+ cd "$pkgname"
+ python2 setup.py install --root=$pkgdir
+}