summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-04-07 18:20:23 -0600
committerMark Wagie2020-04-07 18:20:23 -0600
commit6de58086de49b3afe553aac0adc6cfb61890b16d (patch)
treeee9e7c570556006f11c7f63944d8fcfdeff3ee17
parent4f03223d96edcb8b229d6a48179d712ff8058dbe (diff)
downloadaur-6de58086de49b3afe553aac0adc6cfb61890b16d.tar.gz
forgot a few things
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c707c133674..72876514a18c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat-git
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
pkgver = 3.8.0.r0.g3e67eaa
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cheat/cheat
arch = arm
arch = armv6h
@@ -11,13 +11,14 @@ pkgbase = cheat-git
license = CC0 1.0 Universal
makedepends = git
makedepends = go-pie
+ makedepends = pandoc
optdepends = fzf: for Fuzzy Finder integration
optdepends = bash-completion: for bash completions
- optdepends = fish: for fish completions
provides = cheat
conflicts = cheat
conflicts = cheat-bash-git
conflicts = python-cheat
+ backup = etc/cheat-git/conf.yml
source = git+https://github.com/cheat/cheat.git
source = conf.yml
source = git+https://github.com/cheat/cheatsheets.git
diff --git a/PKGBUILD b/PKGBUILD
index d630a6fba8b4..0083d7ffaa2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@
# Contributor: Quan Guo < guotsuan@gmail.com>
pkgname=cheat-git
pkgver=3.8.0.r0.g3e67eaa
-pkgrel=1
+pkgrel=2
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('arm' 'armv6h' 'armv7h' 'x86_64')
url="https://github.com/cheat/cheat"
license=('MIT' 'CC0 1.0 Universal')
-makedepends=('git' 'go-pie')
+makedepends=('git' 'go-pie' 'pandoc')
optdepends=('fzf: for Fuzzy Finder integration'
- 'bash-completion: for bash completions'
- 'fish: for fish completions')
+ 'bash-completion: for bash completions')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" "${pkgname%-git}-bash-git" "python-${pkgname%-git}")
+backup=("etc/$pkgname/conf.yml")
source=('git+https://github.com/cheat/cheat.git'
'conf.yml'
'git+https://github.com/cheat/cheatsheets.git')
@@ -50,6 +50,9 @@ build() {
# Clean mod cache for makepkg -C
go clean -modcache
+
+ # Generate man page
+ pandoc -s -t man "doc/${pkgname%-git}.1.md" -o "doc/${pkgname%-git}.1"
}
package() {
@@ -57,8 +60,13 @@ package() {
install -Dm755 "dist/${pkgname%-git}" -t "$pkgdir/usr/bin"
install -Dm755 "scripts/${pkgname%-git}.bash" \
"$pkgdir/usr/share/bash-completion/completions/${pkgname%-git}"
- install -Dm755 "scripts/${pkgname%-git}.fish" -t "$pkgdir/usr/share/fish/completions"
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/${pkgname%-git}/${pkgname%-git}-LICENSE"
+ install -Dm755 "scripts/${pkgname%-git}.fish" -t \
+ "$pkgdir/usr/share/fish/completions"
+# install -Dm755 "scripts/${pkgname%-git}.zsh" \
+# "$pkgdir/usr/share/zsh/site-functions/_${pkgname%-git}"
+ install -Dm644 LICENSE.txt \
+ "$pkgdir/usr/share/licenses/${pkgname%-git}/${pkgname%-git}-LICENSE"
+ install -Dm644 "doc/${pkgname%-git}.1" -t "$pkgdir/usr/share/man/man1"
install -dm755 "$pkgdir/usr/share/${pkgname%-git}/cheatsheets/community"
find "$srcdir/cheatsheets" \