summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Kraev2015-06-09 12:04:43 +0300
committerMaxim Kraev2015-06-09 12:04:43 +0300
commit8431c99bad661f174b054dc1b4bd198a03d40caa (patch)
tree85a4c0249d3d842caebd74ca49e82fb2af23a6d0
downloadaur-8431c99bad661f174b054dc1b4bd198a03d40caa.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a281fd88f56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = chef-dk
+ pkgdesc = The Chef Development Kit contains everything you need to start using Chef along with the tools essential to managing the code that runs your business.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://downloads.chef.io/chef-dk/
+ arch = x86_64
+ license = Apache
+ conflicts = chef
+ conflicts = chef-solo
+ source = https://opscode-omnibus-packages.s3.amazonaws.com/ubuntu/12.04/x86_64/chefdk_0.6.0-1_amd64.deb
+ sha512sums = 4158b9228d44c6ff7543c91b9d0eff047d25287daf8f50355012221de9f3b012edf1a2c87912fbc6294f4222cdf948e9cfc6d3cfc65d79901cb779d4e7fd59a5
+
+pkgname = chef-dk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86e4c08b4666
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Maxim Kraev <maxim.kraev@gmail.com>
+
+pkgname=chef-dk
+pkgver=0.6.0
+pkgrel=1
+_ubuntuver=raring
+_ubunturel=4
+pkgdesc="The Chef Development Kit contains everything you need to start using Chef along with the tools essential to managing the code that runs your business."
+arch=('x86_64')
+url="https://downloads.chef.io/chef-dk/"
+license=('Apache')
+depends=()
+conflicts=( chef chef-solo )
+source=("https://opscode-omnibus-packages.s3.amazonaws.com/ubuntu/12.04/x86_64/chefdk_0.6.0-1_amd64.deb")
+sha512sums=('4158b9228d44c6ff7543c91b9d0eff047d25287daf8f50355012221de9f3b012edf1a2c87912fbc6294f4222cdf948e9cfc6d3cfc65d79901cb779d4e7fd59a5')
+
+
+package() {
+ cd "$srcdir"
+ bsdtar -xf data.tar.gz -C "$pkgdir"
+
+ # cleanup .git folders, any idea why they are in the package?
+ find $pkgdir -type d -name ".git" | xargs rm -rf
+
+ # link executables
+ binaries="chef chef-solo chef-apply chef-shell knife shef ohai berks chef-zero fauxhai foodcritic kitchen rubocop strain strainer chef-client"
+
+ mkdir -p $pkgdir/usr/bin
+
+ for binary in $binaries; do
+ ln -sf /opt/chefdk/bin/$binary $pkgdir/usr/bin/ || error_exit "Cannot link $binary to /usr/bin"
+ done
+ chown -R 0:0 $pkgdir
+} \ No newline at end of file