summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJunker2024-01-02 20:37:52 +0700
committerJunker2024-01-02 20:37:52 +0700
commit22ade7c65948eed7d9a962a59de1ae0777804e8e (patch)
tree5dba8264274d4badd6acc15ae8134e7a807a8335
downloadaur-chicken-srfi-27.tar.gz
main commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d58a81662e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chicken-srfi-27
+ pkgdesc = Sources of Random Bits for Chicken Scheme
+ pkgver = 4.2.3
+ pkgrel = 1
+ url = http://wiki.call-cc.org/eggref/5/srfi-27
+ arch = x86_64
+ license = BSD
+ depends = chicken
+ depends = chicken-srfi-1
+ depends = chicken-vector-lib
+ depends = chicken-timed-resource
+ depends = chicken-miscmacros
+ depends = chicken-check-errors>=3.6.0
+
+pkgname = chicken-srfi-27
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b518c8f561a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=chicken-srfi-27
+_name=srfi-27
+pkgver=4.2.3
+pkgrel=1
+pkgdesc='Sources of Random Bits for Chicken Scheme'
+arch=('x86_64')
+license=('BSD')
+depends=("chicken" "chicken-srfi-1" "chicken-vector-lib" "chicken-timed-resource" "chicken-miscmacros" "chicken-check-errors>=3.6.0")
+url='http://wiki.call-cc.org/eggref/5/srfi-27'
+
+build() {
+ CHICKEN_INSTALL_REPOSITORY=${srcdir} CHICKEN_INSTALL_PREFIX=${srcdir} chicken-install -no-install-dependencies $_name:$pkgver
+}
+package() {
+ install -d ${pkgdir}/usr/lib/chicken/11
+ find ${srcdir} -maxdepth 1 -type f -exec cp -t ${pkgdir}/usr/lib/chicken/11 {} +
+}
+